Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Closing a few tabs does not slim down memory usage

  • 4 risposte
  • 6 hanno questo problema
  • 3 visualizzazioni
  • Ultima risposta di cor-el

more options

Firefox 55.0, latest Win 10: Firefox operates properly. HOWEVER, by chance, using Task Manager, I noticed that when I close a few tabs, the amount of memory space Firefox uses does not decrease. If I close Firefox down and then re-launch, Task Manager does show that Firefox is using less memory. This strikes me as a big. Is there any way to fix this, or any add-on?

Firefox 55.0, latest Win 10: Firefox operates properly. HOWEVER, by chance, using Task Manager, I noticed that when I close a few tabs, the amount of memory space Firefox uses does not decrease. If I close Firefox down and then re-launch, Task Manager does show that Firefox is using less memory. This strikes me as a big. Is there any way to fix this, or any add-on?

Tutte le risposte (4)

more options

There are buttons on the about:memory page to reduce memory that can try.

more options

Tnx, will try that.

more options

I have the same problem with 56.0.1. I go from about 390 MB to 3.7 GB in task manger with only 5 or 6 tabs open and a couple that are mostly static. It gets so bad that Firefox starts short burst of not responding and not responding to keyboard and mouse input immediately.

more options

You can try to modify multi-process settings to see if this has effect.

  • set dom.ipc.processCount to 1 if it is currently set to a higher value (4)
  • disable multi-process windows in Firefox

You can disable multi-process windows in Firefox by setting these prefs to false on the about:config page.

  • browser.tabs.remote.autostart = false
  • browser.tabs.remote.autostart.2 = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.