Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Firefox 42 does NOT observe "Keep Me logged in" for **some** websites

  • 3 risposte
  • 3 hanno questo problema
  • 1119 visualizzazioni
  • Ultima risposta di jscher2000

more options

Since upgrading to Firefox 42 (Mac), browser does NOT keep me logged in to Verizon webmail account even though I repeatedly click to keep me logged in. It logs me out BOTH if I quit that Firefox session and restart later --AND-- if that Firefox is left running and the webmail browser window/tab is "inactive" for a period of time then I go back to it. This behavior did NOT occur in previous version of FF. This behavior also does NOT occur under these circumstances when using Safari browser. ... I have read posts & replies by others experiencing this same or similar problem behaviors. I DID try :

 - clearing cache, 
 - deleting all Verizon cookies for possible corruptions,  
 - checking Privacy Settings,  being sure to use "Custom Settings"  &  NOT using Private Browsing (see screen shot)
 - writing exception for cookies to verizon.com &  webmail.verizon.com

... Don't know what else to do. Curious that this does NOT seem affect *most* other sites (that I've noted)

  AND that it did NOT occur with earlier version of Firefox  nor with other browsers.

...

Tutte le risposte (3)

more options

The System Detail list next to the question shows that you run an older Firefox 42 version that is no longer supported with security updates. Always update Firefox and Add-ons to the latest versions to get all security fixes.

Please update to the current Firefox 45.0.2 release.

  • Help > About Firefox

Note that Firefox 46 is scheduled to be released next week (probably on Tuesday).


A detail like a website remembering you (log you in automatically) is stored in a cookie.

You can use these steps to make a website recognize and remember you:

  • You can create a cookie "Allow" exception to keep specific cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: Exceptions

Removing the cookies from a website makes the website forget about you.


You can let the cookies expire when Firefox is closed to make them session cookies.

  • Firefox > Preferences > Privacy > "Use custom settings for history" > Cookies: Keep until: "I close Firefox"

You can create a cookie "Allow" exception to keep specific cookies.

In case you use "Clear history when Firefox closes" or otherwise clear history.

  • do not clear the Cookies
  • do not clear the Site Preferences
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exception for password and other website specific data
  • clearing cookies will remove all selected cookies including cookies with an "Allow" exception you may want to keep

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the profile folder that stores the cookies got corrupted.

  • Rename/remove cookies.sqlite (cookies.sqlite.old) and if present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder in case cookies.sqlite got corrupted.

You can use this button to go to the current Firefox profile folder:

more options

Do you use any extensions that might touch cookies or privacy settings, or might submit any background requests to the Verizon website that might cause the site to terminate your session (for example, requests that might be perceived as "bot" activity or fraud)?

Since the problem can occur without quitting Firefox, it might be worth testing in Firefox's Safe Mode. In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? Not sure how long you need to run in Safe Mode to confirm a different behavior...

more options

There are some sites that force a fresh login if certain connection parameters, such as your IP address, change during your session. If you are using a peer-to-peer connection (e.g., Hola) or Tor, that could make your address unstable. Alternately, some users have noted this issue on AOL network sites and Yahoo sites with a particular connection setting which you can check here:

"3-bar" menu button (or Firefox menu) > Preferences

In the left column, click Advanced, then on the right side select the Network mini-tab at the top. Click the "Settings" button.

The "Auto-detect" setting is the one users have reported can cause problems with some sites. "No proxy" should avoid that issue.