Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

How do I stop firefox from opening a tab for Tools/options

  • 12 risposte
  • 37 hanno questo problema
  • 39662 visualizzazioni
  • Ultima risposta di Shanker

more options

Firefox 38.0.1

Suddenly instead of a box opening now I have a tab opening when I go to Tools/Options - how can I get the box back and stop the tab from opening, I prefer to be able to see my current tab below the Tools/Options box, and now I can't. This is making things very awkward.

Soluzione scelta

Hi, FredMcD's advice is what you need: You can go back to the old Options window by: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.preferences.inContent and double click to change 'Value' from True to False, taking care not to alter anything else. You may then need to restart Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Leggere questa risposta nel contesto 👍 11

Tutte le risposte (12)

more options

Hello!

Match your settings with mine

Picture: http://prntscr.com/79ayor

To access the settings area. In the URL bar enter about:preferences#general

more options

I think this is what you are looking for;

browser.preferences.inContent

Options displayed in tab (true) or window (false)

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

more options

Microrobot said

Hello! Match your settings with mine Picture: http://prntscr.com/79ayor To access the settings area. In the URL bar enter about:preferences#general

Mine already match that except the multiple tabs part - and that's because I work with multiple tabs and don't want to be warned all the time.

more options

Soluzione scelta

Hi, FredMcD's advice is what you need: You can go back to the old Options window by: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.preferences.inContent and double click to change 'Value' from True to False, taking care not to alter anything else. You may then need to restart Firefox.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

more options

FredMcD said

I think this is what you are looking for; browser.preferences.inContent Options displayed in tab (true) or window (false) Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

Okay I get the bit about the about:config... and the "Be Careful" button, but I'm not sure what to do then, I've tried pasting "browser.preferences.inContent" into the search bar, but I don't then see: "Options displayed in tab (true) or window (false)"

I see this: (see image)

Er... could you explain a bit more?

more options

Scribe_uk said

Hi, FredMcD's advice is what you need: You can go back to the old Options window by: Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.preferences.inContent and double click to change 'Value' from True to False, taking care not to alter anything else. You may then need to restart Firefox. If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Oh I SEE!! Thanks Scribe_uk, that last little bit of explanation did the trick, it certainly kick-started my brain so I could understand the entire procedure. Lol!

Thanks to all for their replies.

more options

What I don't get is why Firefox just up and decided to change it without asking me, or getting any instructions from me or without an update deciding it should be that way... just suddenly one morning - things were different. Odd.

more options

What Mozilla Giveth, Mozilla Taketh Away

more options

I too HAD this problem. I fixed it. In my case it had nothing to do with browser preferences, which I did change first of all but made no difference because it was something else causing it. When entering your homepage address as your tab opening page, make sure you delete what is already there in the box. i.e. "about:options" (or something like that, I can't reproduce it now). My own fault.

Modificato da lesfox il

more options

Hi lesfox,

Yes, your solution worked for me too. In my case, whenever I opened the Firefox, the Options Tab also opened with the Home Page. I checked the address in Options and found that it had added a string of #General preference with a separator before at the end of the Page address. First, I removed the string but left the separator as it is. So, Firefox loaded a New Tab along with the Home Page. Then, when I removed the 'separator' also, it stopped loading another tab.

Thanks!

more options

@answer - Type about:config into the address bar, press Enter, accept the warning, scroll down to browser.preferences.inContent and double click to change 'Value' from True to False.

This solution does not work for me. My 'Homepage' and 'Options/General' Tabs open when starting Firefox.

'Help/About Firefox' reads as follows:

41.0.2 Funnelcake October 2015 Mozilla53 - 1.0

So how do I disable Options/General Tab as a 2nd Tab after opening Firefox?

Sheilah

more options

Shanker said

Hi lesfox, Yes, your solution worked for me too. In my case, whenever I opened the Firefox, the Options Tab also opened with the Home Page. I checked the address in Options and found that it had added a string of #General preference with a separator before at the end of the Page address. First, I removed the string but left the separator as it is. So, Firefox loaded a New Tab along with the Home Page. Then, when I removed the 'separator' also, it stopped loading another tab. Thanks!

I had to apply the 'Refresh Firefox' too, to stop this problem from reappearing!

Modificato da Shanker il