X
Tocca qui per la versione per piattaforma mobile del sito.

Forum di supporto

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Why won't firefox hold my enabled cookies settings? it changes them back after I set them.

Inserita

I am enrolled in an online math course. It has been required of me to allow cookies. I have tried to allow cookies in firefox, but everytime I do, I click ok, and then when I go back the settings are back to the way they were. I can change other things, but not cookies. Please help me, I am unable to access my math course, and have already spent a lot of time on trouble shooting, for this issue, and others I have resolved. Thank you

I am enrolled in an online math course. It has been required of me to allow cookies. I have tried to allow cookies in firefox, but everytime I do, I click ok, and then when I go back the settings are back to the way they were. I can change other things, but not cookies. Please help me, I am unable to access my math course, and have already spent a lot of time on trouble shooting, for this issue, and others I have resolved. Thank you

Soluzione scelta

This is a frequent problem.Try resetting firefox to solve the problem but in case it doesn't try one of these:-

As your cookies are not being saved,it could be a third party program changing it back to its previous setting,user.js file overriding preferences.

Your installation of Firefox may have been customized to add a program configuration file that locks certain preferences or prevents certain changes from being saved.So try to reinstall.

Firefox may be unable to save your settings if the prefs.js file (or the prefs.js.moztmp file, if it exists) is write-protected or there are other prefs backup files. The preferences file may be corrupt, preventing Firefox from writing to it. If you delete this file, Firefox will automatically create another one when it needs to.

Try one of the above...it should work.

Leggere questa risposta nel contesto 8

Dettagli aggiuntivi sul sistema

Plugin installati

  • Shockwave Flash 14.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • TestGen plug-in, Version 7.5.3
  • 5.1.30514.0
  • McAfee MSC FF plugin DLL
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Applicazione

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0

Ulteriori informazioni

ishita 3 soluzioni 18 risposte

Soluzione scelta

This is a frequent problem.Try resetting firefox to solve the problem but in case it doesn't try one of these:-

As your cookies are not being saved,it could be a third party program changing it back to its previous setting,user.js file overriding preferences.

Your installation of Firefox may have been customized to add a program configuration file that locks certain preferences or prevents certain changes from being saved.So try to reinstall.

Firefox may be unable to save your settings if the prefs.js file (or the prefs.js.moztmp file, if it exists) is write-protected or there are other prefs backup files. The preferences file may be corrupt, preventing Firefox from writing to it. If you delete this file, Firefox will automatically create another one when it needs to.

Try one of the above...it should work.

This is a frequent problem.Try resetting firefox to solve the problem but in case it doesn't try one of these:- As your cookies are not being saved,it could be a third party program changing it back to its previous setting,user.js file overriding preferences. Your installation of Firefox may have been customized to add a program configuration file that locks certain preferences or prevents certain changes from being saved.So try to reinstall. Firefox may be unable to save your settings if the prefs.js file (or the prefs.js.moztmp file, if it exists) is write-protected or there are other prefs backup files. The preferences file may be corrupt, preventing Firefox from writing to it. If you delete this file, Firefox will automatically create another one when it needs to. Try one of the above...it should work.
Lancer525 1 soluzioni 28 risposte

Risposta utile

Whomever wrote this reply, assumes that the people reading it know what "resetting Firefox" means, and further assumes that we know how to do it.

All the rest of the post is unintelligible mumbo-jumbo too.

Don't just tell someone to do something, without including step-by-step instructions on how to do it too...

Whomever wrote this reply, assumes that the people reading it know what "resetting Firefox" means, and further assumes that we know how to do it. All the rest of the post is unintelligible mumbo-jumbo too. Don't just tell someone to do something, without including step-by-step instructions on how to do it too...
cor-el
  • Top 10 Contributor
  • Moderator
17565 soluzioni 158874 risposte

Do you mean that the "Use custom settings for history" didn't stay selected?

If all History and cookie settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made.


You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location/address bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab
Do you mean that the "Use custom settings for history" didn't stay selected? If all History and cookie settings are default then the custom settings are hidden and you see "Firefox will: (Never) Remember History". The "Use custom settings for history" selection allows to see the current history and cookie settings, but selecting this doesn't make any changes to history and cookie settings. Firefox shows "Use custom settings for history" as an indication that at least one of the history and cookie settings is not the default to make you aware that changes were made. ----- You can inspect and manage permissions for the domain in the currently selected tab via these steps: *Click the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location/address bar *Click "More Information" to open "Tools > Page Info" with the Security tab selected *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab
Lancer525 1 soluzioni 28 risposte

I don't know what any of that means.

All I know is, I can't log into some websites. I enter my (valid) username and password, and Firefox won't hold the login. In other words, I can log into those sites with IE, and it holds the UID and Pass just fine. Firefox won't log in to the sites.

I don't know what any of that means. All I know is, I can't log into some websites. I enter my (valid) username and password, and Firefox won't hold the login. In other words, I can log into those sites with IE, and it holds the UID and Pass just fine. Firefox won't log in to the sites.
cor-el
  • Top 10 Contributor
  • Moderator
17565 soluzioni 158874 risposte

Try to clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

See also:

Try to clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" See also: *https://support.mozilla.org/kb/how-clear-firefox-cache *https://support.mozilla.org/kb/Deleting+cookies
Lancer525 1 soluzioni 28 risposte

Risposta utile

Thanks. I'll give that one a try.

Much appreciated!

Thanks. I'll give that one a try. Much appreciated!