Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Skype for Business 2016 desktop app not launching from Firefox

more options

Skype for Business 2016 desktop app is not loaded from Mozilla Firefox (102.15.1 ESR) Using handlers.json : "lync15":{"action":2,"handlers":[{"name":"lync.exe","path":"C:\\Program Files (x86)\\Microsoft Office\\Office16\\lync.exe"}]}.

lync15://foo or any generated skype meeting just does not open Skype for Business 2016 desktop app.

It is working with MS Edge, but not with Firefox. It was working before on Windows Server 2012 R2, but now with Windows Server not.

Skype for Business 2016 desktop app is not loaded from Mozilla Firefox (102.15.1 ESR) Using handlers.json : "lync15":{"action":2,"handlers":[{"name":"lync.exe","path":"C:\\Program Files (x86)\\Microsoft Office\\Office16\\lync.exe"}]}. lync15://foo or any generated skype meeting just does not open Skype for Business 2016 desktop app. It is working with MS Edge, but not with Firefox. It was working before on Windows Server 2012 R2, but now with Windows Server not.

All Replies (6)

more options

If you change the action for that content type to "Always ask" can you select Skype for Business in the popup list and, if you do, does it work?

Helpful?

more options

Hi, yes I have tried. I can see Skype for Business and can select it ,the change is visible and applied in the hadnlers.json file as well. But still nothing happens. Skype is just not starting.

Helpful?

more options

Helpful?

more options

Hi, I've checked it , but this could not help me. When I set the option for Lync15 to always ask , I see the following notes in the the event viewer :

Application popup: lync.exe - Entry Point Not Found : The procedure entry point GetCurrentProcessId could not be located in the dynamic link library C:\PROGRA~2\MICROS~2\Office16\RtmMvrSplitter.dll.

There was similar issue for Firefox long time, but it was fixed after version 62 or 63.

Helpful?

more options

I don't use Skype for Business, but I guess it is installed as part of Office and hasn't been completely replaced by Teams.

My Registry has this under HKEY_CLASSES_ROOT\lync15\shell\open\command

C:\Program Files (x86)\Microsoft Office\Root\Office16\lync.exe "%1"

which is somewhat different from your path.

After testing a link (and getting a popup to sign in), my handlers.json just shows "4" and the Settings page has "Use Skype for Business (default)" -- there is no path specified in the file.

Could you double-check whether you have that "(default)" option in case the path in your handlers.json is obsolete?

Helpful?

more options

Hi, it has been already tested with value 4 , "Use Skype for Business (default) in the handlers.json file ( with or without path to lync.exe) and is still not working.

Helpful?

Jụọ ajụjụ

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.