On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hide the yellow notification bar in fullscreen mode

  • 6 replies
  • 1 nwere nsogbu anwere nsogbu a
  • 399 views
  • Nzaghachi ikpeazụ nke firefoxuser

more options

Each time I watch a movie on my video streaming website I get an error message in a yellow notification bar ("the clearkey plugin has crashed" -- translation), and there is no issues with video playback. How can I automatically get rid of this bar (other than by clicking "close this message"), which sticks on the top of the window even in full screen mode?

Each time I watch a movie on my video streaming website I get an error message in a yellow notification bar ("the clearkey plugin has crashed" -- translation), and there is no issues with video playback. How can I automatically get rid of this bar (other than by clicking "close this message"), which sticks on the top of the window even in full screen mode?
Nseta ihuenyo ndị agbakwunyere

Asịsa ahọpụtara

firefoxuser said

notification[value="plugin-crashed"]{
 display:none !important;
}

in userChrome.css solves the problem, thank you. However this workaround seems dangerous as it catches all crash notification.

You might be able to limit the effect of the rule to full screen windows this way -- assembled from random web posts and not tested because I have no way of testing this:

#main-window[inFullscreen] notification[value="plugin-crashed"]{
 display:none !important;
}
Gụọ azịza a na nghọta 👍 0

All Replies (6)

more options

I would disable the plugin in the settings -> options -> extensions & add ons -> Plugins since it doesn't seem to matter if its working or not.

more options

Thanks for the reply. I indeed tried to disable the plugin, widevine, but then firefox asked (in a yellow bar!) to allow DRM by enabling the plugin. Circular problem...

EDIT: widevine has nothing to do with the error message (the message still shows up when the DRM notification is hidden), but I did not find a way to disable "clearkey"

Edeziri site na firefoxuser

more options

Some of those infobar controls can be hidden using custom style rules in a userChrome.css file. A good site to find fixes along those lines is the following subreddit:

https://www.reddit.com/r/FirefoxCSS/

more options

notification[value="plugin-crashed"]{

display:none !important;

}

in userChrome.css solves the problem, thank you. However this workaround seems dangerous as it catches all crash notification.

more options

Asịsa Ahọpụtara

firefoxuser said

notification[value="plugin-crashed"]{
 display:none !important;
}

in userChrome.css solves the problem, thank you. However this workaround seems dangerous as it catches all crash notification.

You might be able to limit the effect of the rule to full screen windows this way -- assembled from random web posts and not tested because I have no way of testing this:

#main-window[inFullscreen] notification[value="plugin-crashed"]{
 display:none !important;
}
more options

jscher2000 said

#main-window[inFullscreen] notification[value="plugin-crashed"]{
 display:none !important;
}

Perfect! For information, I get this issue on this website: https://www.canalplus.com/, from the home page.