Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

payment auto-fill

  • 1 nzaghachinzaghachi
  • 1 nwere nsogbu anwere nsogbu a
  • 3 views
  • Nzaghachi ikpeazụ nke cor-el

more options

Hi, I can't get firefox to save my payment info in the forms. It would be great to not have to fill it every time

I've set the preferences so it should save form info but nothing seems to help.

I'm on a Mac. Downloaded the new firefox.

Please help! Thanks.

Hi, I can't get firefox to save my payment info in the forms. It would be great to not have to fill it every time I've set the preferences so it should save form info but nothing seems to help. I'm on a Mac. Downloaded the new firefox. Please help! Thanks.

All Replies (1)

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache:

  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window