Pomoc přepytać

Hladajće so wobšudstwa pomocy. Njenamołwimy was ženje, telefonowe čisło zawołać, SMS pósłać abo wosobinske informacije přeradźić. Prošu zdźělće podhladnu aktiwitu z pomocu nastajenja „Znjewužiwanje zdźělić“.

Learn More

Firefox option "Allow Website to choose their own font/color" fails in High Contrast

  • 2 wotmołwje
  • 2 matej tutón problem
  • 24 napohladow
  • Poslednja wotmołwa wot Darvin

more options

On Windows 8.1 and Firefox 32, the option to Allow pages to choose their own colors, instead of my selections above" Fails completely if Windows 8 is using a High Contrast Theme.

Regardless of the Windows Theme, Firefox should allow pages to use their designed colors otherwise problems will exist on a number of sites. Including the Mozilla.org page.

With the Allow Pages... turned on, it should look like this: http://yosemitelandscapes.com/temp/correct.jpg

Instead the Windows High Contrast is forced upon the web site: http://yosemitelandscapes.com/temp/incorrect.jpg

For reference Chrome does this correctly which has forced me to switch to the Chrome Browser until a fix is issued for this problem.

NOTE: This is not the same problem people reported where High Contrast did not function in Firefox 29. But I think it may be related to the fix.

I have tried "reverse logic" and turned these options on and off to see if the behavior changed. Pages refreshed and even closed and reloaded. I can find no way to work in High Contrast Themes and allow pages to show up normally in Firefox 32.

I much prefer the security and design of Firefox. Help us please!!!

On Windows 8.1 and Firefox 32, the option to Allow pages to choose their own colors, instead of my selections above" Fails completely if Windows 8 is using a High Contrast Theme. Regardless of the Windows Theme, Firefox should allow pages to use their designed colors otherwise problems will exist on a number of sites. Including the Mozilla.org page. With the Allow Pages... turned on, it should look like this: http://yosemitelandscapes.com/temp/correct.jpg Instead the Windows High Contrast is forced upon the web site: http://yosemitelandscapes.com/temp/incorrect.jpg For reference Chrome does this correctly which has forced me to switch to the Chrome Browser until a fix is issued for this problem. NOTE: This is not the same problem people reported where High Contrast did not function in Firefox 29. But I think it may be related to the fix. I have tried "reverse logic" and turned these options on and off to see if the behavior changed. Pages refreshed and even closed and reloaded. I can find no way to work in High Contrast Themes and allow pages to show up normally in Firefox 32. I much prefer the security and design of Firefox. Help us please!!!

Wšě wotmołwy (2)

more options

That's a painful example. I don't have access to Windows 8/8.1 myself, but I suspect this is by design, as I have seen other screenshots from users using high contrast dark themes that did not have background colors and images.

Firefox 32 contains a change from this bug: Bug 1042625 - Page should be drawn in accordance with the high contrast themes. The testing (and a comment in the patch) refers to solving a problem on Windows 7, but apparently Windows 8 also was affected.

I don't know whether there is a workaround to tweak what is and isn't displayed in the page with a high contrast theme.

more options

I think the problem would include Windows 7 but it had better control over the color scheme of Windows. Windows 8 removed much of the control which can only be addressed in the High Contrast Themes.

If other browsers are an example, Chrome and IE seem to behave properly. Only Firefox and then more recent versions of it, seem to have the problem. Making it unusable if you do choose a High Contrast Theme which is quite useful if you do photography, art, video...

Thanks Darv