Relay Phone Masking users currently cannot register for a new phone number, this will primarily impact new phone masking users. Please check https://status.relay.firefox.com/ for updates.

Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

Any way to force Firefox to prioritize IPv4 without disabling IPv6?

  • 3 Mbohovái
  • 0 oguereko ko apañuãi
  • 21 Hecha
  • Mbohovái ipaháva cor-el

more options

Firefox prioritizes IPv6 (even on a network with internet-accessible fd00:: address, which contradicts my currently set up prefix policies) over IPv4. Now the problem is that my IPv6 address is a tunnelbroker.net one, and while I still want to be able to access the IPv6 internet, I don't want a tunneled connection to be my default. And I don't want to disable IPv6 completely. Is there a way to force Firefox to prioritize IPv4 over IPv6?

Note: the first time when connecting to a website, the browser connects via IPv4 (like the prefix policies are supposed to work), but then it remembers that the website is accessible via IPv6, saves it into the content-prefs.sqlite file (removing the said file makes the connection fall back to IPv4 first again) and connects via IPv6 again. Is there a way to make Firefox NOT remember that in content-prefs.sqlite and still connect abiding the prefix policies?

Using Firefox Dev Edition 103.0b9 on Windows 11 x64
Firefox prioritizes IPv6 (even on a network with internet-accessible fd00:: address, which contradicts my currently set up prefix policies) over IPv4. Now the problem is that my IPv6 address is a tunnelbroker.net one, and while I still want to be able to access the IPv6 internet, I don't want a tunneled connection to be my default. And I don't want to disable IPv6 completely. Is there a way to force Firefox to prioritize IPv4 over IPv6? Note: the first time when connecting to a website, the browser connects via IPv4 (like the prefix policies are supposed to work), but then it remembers that the website is accessible via IPv6, saves it into the content-prefs.sqlite file (removing the said file makes the connection fall back to IPv4 first again) and connects via IPv6 again. Is there a way to make Firefox NOT remember that in content-prefs.sqlite and still connect abiding the prefix policies? Using Firefox Dev Edition 103.0b9 on Windows 11 x64

Opaite Mbohovái (3)

more options

So is your ISP and VPN or Proxy that your using?

Moambuepyre Dropa rupive

¿Imba’eporãva?

more options

I confess that I don't understand your question. How is a tunnel involved??

But I'm not aware of any built-in feature to reverse the preference for ipv6 over ipv4.

In case it helps: it appears you can add domain to an "ipv4-only" preference to bypass ipv6 for those domains. But this is only practical for a short list of sites. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste network.dns.ipv4OnlyDomains and pause while the list is filtered

(3) Double-click the preference to display an editing field, and add the desired domain(s) using the following syntax, then press Enter or click the blue check mark button to save the change:

example.com,example.org


Perhaps you can run your own DNS service that returns ipv4 addresses preferentially? If you're not the only person who ever wanted this, maybe it's out there somewhere.

Moambuepyre jscher2000 - Support Volunteer rupive

¿Imba’eporãva?

more options

¿Imba’eporãva?

Eporandumína

Nde eikéke nde mba’etepe embohovái hag̃ua ñe’ẽmondo. Ikatúpa, emoñepyrũ peteĩ porandu, ndereguerekói gueteriramo nemba’ete.