Eheka Pytyvõha

Emboyke pytyvõha apovai. Ndorojeruremo’ãi ehenói térã eñe’ẽmondóvo pumbyrýpe ha emoherakuãvo marandu nemba’etéva. Emombe’u tembiapo imarãkuaáva ko “Marandu iñañáva” rupive.

Learn More

Firefox - laggy scrolling since 98.0.

  • 6 Mbohovái
  • 1 oguereko ko apañuãi
  • 23 Hecha
  • Mbohovái ipaháva mjstep61

more options

OS: ArchLinux DE: i3wm, X11 GPU: GTX770, Kepler, proprietary nvidia driver Firefox version: 98.0(64-bit)

Hi! Since updating Firefox to 98.0 I've been experiencing sudden performance drops(lags/freezes/stutters) while scrolling. `about:support` page shows that compositing is `WebRender`. The issue occurs with fresh profile without any addons installed and also in `firefox-nightly`(100.0a1). However, scrolling is totally smooth in 97.0.2 and earlier versions of Firefox.

What changes in Firefox 98 could cause this, and are there any settings in `about:config` I can try to tune to solve the issue? These are the settings I've always used, and, as I mentioned, scrolling was smooth before 98.0:


gfx.webrender.all = true general.smoothScroll.mouseWheel.durationMaxMS = 400 general.smoothScroll.mouseWheel.durationMinMS = 200 mousewheel.min_line_scroll_amount = 40 mousewheel.system_scroll_override.enabled = false

'''OS: ArchLinux''' '''DE: i3wm, X11''' '''GPU: GTX770, Kepler, proprietary nvidia driver''' '''Firefox version: 98.0(64-bit)''' Hi! Since updating Firefox to 98.0 I've been experiencing sudden performance drops(lags/freezes/stutters) while scrolling. `about:support` page shows that compositing is `WebRender`. The issue occurs with fresh profile without any addons installed and also in `firefox-nightly`(100.0a1). However, scrolling is totally smooth in 97.0.2 and earlier versions of Firefox. What changes in Firefox 98 could cause this, and are there any settings in `about:config` I can try to tune to solve the issue? These are the settings I've always used, and, as I mentioned, scrolling was smooth before 98.0: gfx.webrender.all = true general.smoothScroll.mouseWheel.durationMaxMS = 400 general.smoothScroll.mouseWheel.durationMinMS = 200 mousewheel.min_line_scroll_amount = 40 mousewheel.system_scroll_override.enabled = false

Moambuepyre Alexey104 rupive

Opaite Mbohovái (6)

more options

Try downloading another copy of Firefox, run it from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

@jonzn4SUSE, Thank you for the response, but, unfortunately, it didn't help. I've also created a report at bugzilla, but it seems no other users can confirm it yet:

https://bugzilla.mozilla.org/show_bug.cgi?id=1759147

more options

I would log into another account and see if Firefox has the same issue. Also try a different desktop environment or try a Live image.


Operating System: openSUSE Tumbleweed 20220310 KDE Plasma Version: 5.24.2 KDE Frameworks Version: 5.91.0 Qt Version: 5.15.2 Kernel Version: 5.16.11-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Moambuepyre jonzn4SUSE rupive

more options

I've tried Gnome and KDE - the same results. Maybe this is something Nvidia-related. When start to scroll, it might be smooth for a while, but suddenly "lag mode" turns on and everything becomes slow and choppy. I've also tried switching to free driver, but in this case I have to enable software vsync in a compositor like Picom, that makes things even worse. Switching back to Firefox 97 solves the issue completely.

more options

Interesting...

more options

I'm seeing the same issue since the latest update (101.0.1 on Windows 11). Multiple sites the scroll either from the trackpad or on the touch screen locks and is laggy. Very frustrating and introduced recently.