Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do Facebook External 'Like' Links not connect properly in Firefox but are ok in Internet Explorer?

  • 11 respostas
  • 41 have this problem
  • 2 views
  • Last reply by NocFenix

more options
You may of noticed the "new" 'like' pages spreading wildly across facebook. You know the ones that go to a website like: mylikebook.com, bawaal.in and many others.

WELL i can't for the life of me get it to actually LIKE the pages. I click the 'like' button. A popup window appears and loads an address. The page changes from 34,000 people to YOU & 34,000 people the popup closes.. the page changes BACK to just 34,000 people the popup reloads... it does it al again... and again and again and will keep doing it until i close the page... BUT it doesnt add the page to my LIKES

URL of affected sites

http://mylikebook.com, http://bawaal.in, http://www.likethisthing.com, http://likecentral.com/ and many others.

You may of noticed the "new" 'like' pages spreading wildly across facebook. You know the ones that go to a website like: mylikebook.com, bawaal.in and many others. WELL i can't for the life of me get it to actually LIKE the pages. I click the 'like' button. A popup window appears and loads an address. The page changes from 34,000 people to YOU & 34,000 people the popup closes.. the page changes BACK to just 34,000 people the popup reloads... it does it al again... and again and again and will keep doing it until i close the page... BUT it doesnt add the page to my LIKES == URL of affected sites == http://mylikebook.com, http://bawaal.in, http://www.likethisthing.com, http://likecentral.com/ and many others.

All Replies (11)

more options

Same problem here. FF 3.6.3 on Mac 10.5.8 Works perfectly fine on Safari.

more options

I'm seeing exactly the same issue with FF 3.5.9 on Mac 10.5.8. I am using a facebook like plugin for wordpress - it works fine in safari but not in FF. If I am not logged into FB when I click the "like" button on my site a small popup login window appears. But if I am logged in when I hit the like button I get the exact same weird behavior mentioned by Sean.

Daniel.

more options

well pleased to know its not just me.. I wonder if anyone actually has a fix for this?

more options

Seems to be a Facebook problem, which doesn't really surprise me when you look at their crappy code :(

more options

I have this problem with a "Like" for Facebook on any site external from Facebook. This is only an issue I get with Firefox, Google Chrome doesn't have this issue.

more options

Why dont my Facebook games work on Firefox anymore, I have updated the Flash as told but it s till not work. It work on Internet Explorer

more options

I have experienced this trying to implement a Facebook "Like" button in one of my own sites. I thought it was a problem with my coding, as I had not inserted one of these in a site before, but after re-doing it six times I decided to check it on Chrome — it worked fine. Clearly there is something not working between FF and FB. I'm running FF 3.5.11 on Mac OS X.

more options

Yep, count me in this group too. Pops up a window, the page updates with the blue, checked "Like", the popup then closes. Then page updates with the white, unchecked "Like" and the popup pops up again. Rinse, repeat. Rinse, repeat. So annoying.

more options

This isn't something I really want to test on a random web site, so let me ask someone who has this problem. If you check Firefox's Error Console (Tools menu), do you see any errors reported during this process?

To get meaningful results, first click the Clear button in the console, then try to like the page, then check the console again. You can copy errors by right-clicking them.

more options

This happens to me a lot when I'm trying to use the "like" button on Pandora or IMDB.

A ton of these warnings:

Warning: Expected declaration but found '*'. Skipped to next declaration. Source File: https://support.mozilla.com/minify.php/css_styles_mozcommon;css_styles_mozkb Line: 1

Some other ones mixed in as well

more options

I had this problem and I figured it out tonight. I'm on a Mac, but I'm assuming it will be similar for Windows users as well.

Go to Preferences Privacy tab Check the boxes: Accept cookies from sites, Accept third-party cookies