Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Conatinually asks to update plug-ins that are already updated?

  • 3 fhreagra
  • 11 leis an bhfadhb seo
  • 235 views
  • Freagra is déanaí ó AliceWyman

more options

When I check my plugins, a few of them say to update due to vulnerability issues. Either some have been updated already and still ask to be updated or when they are actually updated and everything is refreshed, the plugins still show that they need to be updated.

All Replies (3)

more options

Some plugins has been completely disabled, due to known vulnerabilities in all available versions, thus Firefox will prevent updating and totally disabling the vulnerability until a secure update is released.

If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

more options

Note that Oracle has re;leased the Java 8 version and this has caused the Java 7U51 version to be reported as vulnerable.

You can find the latest Java 8 version on the Oracle website.

See Java Platform > Java SE 8 (JRE 8 Download)

more options

You don't need to do anything since Java 7 Update 51 is not vulnerable (afaik) and is the recommended version offered at http://www.java.com/en/download/manual.jsp and http://www.java.com/en/download/

If you check the "Do I have Java?" link at http://www.java.com/en/download/ and run the Java Detection applet it will tell you that you have the recommended Java installed (Version 7 Update 51).

Related bugs:

  • Bug 985968 - Mozilla Plugin check page displays Java plugin as vulnerable even if the latest version is installed.
  • Bug 985056 - Java JDK 8 released

P.S. The bug reports are for information only. Don't comment in bug reports unless you have something constructive to add (see Bugzilla Etiquette).

Athraithe ag AliceWyman ar