Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Adobe Flash Not Working Firefox 21

  • 32 freagra
  • 192 leis an bhfadhb seo
  • Freagra is déanaí ó user633449

more options

I just installed Firefox's newest version 21. I went to a website which required flash and it said I did not have flash installed. So I installed flash from adobe's website and it said it installed successfully I went back to the website after restarting my browser and it still did not work. I restarted my computer and nothing. I reinstalled flash again and it still does not work even though adobe is telling me it installed successfully.

I just installed Firefox's newest version 21. I went to a website which required flash and it said I did not have flash installed. So I installed flash from adobe's website and it said it installed successfully I went back to the website after restarting my browser and it still did not work. I restarted my computer and nothing. I reinstalled flash again and it still does not work even though adobe is telling me it installed successfully.

Réiteach roghnaithe

Hi sayang, can you confirm:

  • The plugin is in the customary location which I think for XP is:

  • If you are comfortable using RegEdit, the Adobe Flash plugin is registered in this key:

Read this answer in context 👍 1

All Replies (20)

more options

The forum software did not detect your Flash plugin. Can you check whether it is disabled? You can do that here:

orange Firefox button (or Tools menu) > Add-ons > Plugins category

It should be listed as Shockwave Flash. If it's disabled, it will be sorted to the end on a grayed out background.

To see whether the Flash player plugin installed to its usual location, check this folder:

C:\Windows\SysWOW64\Macromed\Flash {based on Windows 7 64-bit}

You want to find NPSWF32_11_7_700_202.dll

If that file does not exist, you may need to install again. Make sure to specify that you want the player for non-IE browsers.

more options

I have Flash player 11.2 successfully working on one machine with Firefox 18.0.2. It does not work on my new machine under version 21. When I go to Tools -> Add-ons -> Plugins, Flash is not listed, even though I have put in /usr/lib64/mozilla/plugins (it is also in /usr/lib/mozilla/plugins).

I am able to get YouTube videos and other sites that depend on Flash working under Chrome, but not under Firefox.

more options
more options

I am very frustrated by the same problem but using W32 not W64. Immediately after upgrading from FF 19 to 21 videos showed this message "Cannot play media. You do not have the correct version of the flash player. Download the correct version".

I downloaded uninstall, latest flash player plugin for FF and ActiveX version for IE 9. Ran FF Flash Player uninstall then plugin install for FF and also ActiveX version for IE9. IE9 works but FF does not. I have been searching for and trying solutions over the past 3 days but no success. I have ensure Javascript is working OK, temporarily disabled Adobe Reader plugin and other plugins one at a time to see if this would resolve the problem. Still not working & very frustrating. Also have tried re-installing FF19 and previous version of Flash Player plugin for FF without success as well as clearing FF cache.

I have noticed that after installing Flash Player plugin for FF, whereas IE9 with ActiveX version had been working, it no longer does, so I had to re-install ActiveX version which fixed IE9 again. This suggests there’s an incompatibility somewhere as previously both IE9 and Firefox v19 worked OK.

After running Flash Player plugin uninstall for FF then plugin install it returns a "Successfully installed" message but Flash Player still does not appear in the FF plugin list and does not work.

I've seen so many similar complaints I’m sure there must be a FF expert somewhere who can tell me what I have to do to get Flash Player working with v21.0?

Flash player has all this time worked OK on Chrome. The reason I need it working on FF, IE & Chrome is because I manage an interactive website containing videos and any changes I make I test on all 3 browsers so I know all 500 members are OK.


more options

Hi clarkec59, is Firefox your default browser? Usually Adobe will launch the successful install message in your default browser without actually checking that it works in other browsers, so if Firefox is not your default browser, that Adobe page is not very meaningful.

(Regarding Chrome, Flash is bundled in by Google; Chrome does not rely on the system-level Flash player.)

It sounds as though you checked your plugins tab and did not see Shockwave Flash disabled:

orange Firefox button (or Tools menu) > Add-ons > Plugins category

The path for Flash on 32-bit Windows should be:


You want to find NPSWF32_11_7_700_202.dll

If you have the DLL but Firefox is not finding it, you can force Firefox to rebuild its plugins database by deleting or renaming a settings file. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename pluginreg.dat to something like pluginreg.old

Restart Firefox. Did it find Flash?

Athraithe ag jscher2000 - Support Volunteer ar

more options

[link(s) removed by Moderator]

Athraithe ag cor-el ar

more options

jscher2000 Thanks for quick response. Yes I had checked and Shockwave Flash not showing at all in Plugins list. Yes NPSWF32_11_7_700_202.dll is in C:\Windows\System32\Macromed\Flash I have just tried to force Firefox to rebuild its plugins database by the method you described but still unsuccessful. Its past midnight now so I will get onto the problem again tomorrow morning. Your help much appreciated.

more options

If Firefox didn't find the plugin, the setting to scan the registry for new plugins might have been disabled. You could check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste scan and pause while the list is filtered

(3) If plugin.scan.plid.all is not set to its default value of true, double-click it to toggle it back to the default. You might need to exit and restart Firefox to trigger another scan.

If this change doesn't stick, check for a user.js file as described in this article: How to fix preferences that won't save.

more options

It is installed and enabled and the file is in the correct location. I have Windows 8 if that helps.

more options

I also tried resetting my plugins following your instructions to another user and that did not fix my problem either.

Windows 8 64bit

more options

Hi richey.kyle.i, does Flash work on some pages and not others, such as:

If it's a problem with particular sites, can you give an example or two? Some sites do not code in the Flash player directly but instead run a script to do it. This allows them to better adapt to different browsers, but creates an extra dependency. If you use any kind of site-based filtering, be aware that many sites are now splitting their scripts onto different servers or content distribution networks, and may require additional permissions (e.g., being allowed in the NoScript extension, or being added to content filtering software like BlueCoat K9).

more options

jscher2000 I found that plugin.scan.plid.all is installed and set to true. user.js does not exist; prefs.js does exist and in Attributes there is no check in the box next to Read Only. I do have RealPlayer installed and there was an update done a short while ago but cannot recall if update coincided exactly with this FF failure. There are about 4 RealPlayer extensions listed which a few days ago I disabled but this did not free the FF problem. I think I shall try disabling each in turn again to see if that works as it has been mentioned a few times in the support pages. I haven’t tried anything else on that support page yet but will work though it. Re: your last message. No videos works in FF since going to v21 but they always used to. My default website is which I use daily and which always has a lot of video content. At present I'm using IE and Chrome to supplement FF where all the setting are exactly to my liking and I don't like using these other browsers. Its a real pain and I am most grateful for your advice.

more options

Hi, I have updated FF today to 22.0 I have got the same problem: Flashplayer not showing in plugins list and every time I access a site, I have this message displayed: "Additional plugins are required to display all the media on this page"; there is a button named: Install Missing plugin.

FF was working properly before the update...

more options

Hi pacha2003, did you check toward the bottom of the page to see whether it has been disabled (area with the gray background)?

orange Firefox button (or Tools menu) > Add-ons > Plugins category

If it is disabled, does the Enable button work? If it doesn't work or the button is missing, what version of the Shockwave Flash plugin do you have?

If it is truly missing but you know it still is installed, and you run Windows, can you check the setting in this post:

more options

jscher2000 As mentioned I did each of the the mods you suggested without apparent success. However on 7th June after booting up as usual I went to the BBC news page and lo and behold the videos had started working again! Also OK on any other website I go to. Its puzzling why and a bit disconcerting not knowing the cause of the problem or what fixed it. Anyway still working OK so I have my fingers crossed it will continue. Many thanks for your suggestions, you have been very helpful. Best regards Chris

more options

Dear jscher2000, Thanks for your answer. I can not see if it has been disabled because, as I mentioned before, it doesn't appear in the plugins page at all!

I am sure the Shockwave is installed because in the previous version of FF, i.e, 20, it was working perfectly. I am running W7 X64 and I have checked all the settings you advised without success. Thanks again for your help

more options

clarkec59 mentioned that reinstalling the flash plugin resulted in firefox mysteriously starting to work properly. With that advice, I have done the same, and lo and behold, it is working now for me too. I have Firefox 21.0 running under Fedora 18 on an AMD 86-64 cpu. The only change that I am aware that I made was to change the default theme to oxygen-gtk.

more options

Hi pacha2003, a Flash updated was released on Monday Tuesday. Could you update and then if Firefox still can't find Flash, could you check the following:

(1) The plugin is in the usual location (64-bit Windows):

C:\Windows\SysWOW64\Macromed\Flash => NPSWF32_11_7_700_224.dll

(2) The plugin path is set in the registry (assuming you are familiar with regedit.exe):

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins\ => Path = C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_7_700_224.dll

Athraithe ag jscher2000 - Support Volunteer ar

more options

My Flash Player was crashing a lot for about 5 day. but today everything seems to be fine.

except that no one can answer the question i posted  :)

more options

I was having the same issue, though ultimately the registry key was not there, and was in a macromedia key.

I was able to fix the issue by uninstalling flash, then restarting Windows in safe mode, then reinstalling.

I notice that I have a problem with many updates from Adobe. (Acrobat, Photoshop, etc)

  1. 1
  2. 2