Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Menu bar stopped working after upgrading to Firefox 20.0.1

  • 14 freagra
  • 6 leis an bhfadhb seo
  • 1244 views
  • Freagra is déanaí ó conspiritech

more options

I am an owner of thedjhookup.com web site. After upgrading to Firefox 20.0.1, menu completely stopped working. I am running Microsoft Windows [Version 6.1.7601]

Réiteach roghnaithe

it works in all other browsers. If I change the code, I can break this.

You might think that, but the deprecation.js library purely targets Firefox. Check line #15 in the comment block. You can confirm that by looking at the init function:

  init: function(deprecatedMethods) {
    if (!Prototype.Browser.Gecko) return;

"Gecko" is the rendering engine in Firefox and doesn't match IE or any Webkit based browser. So if it isn't Firefox, exit the deprecation library.

Ready to test?

Read this answer in context 👍 1

All Replies (14)

more options

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

____________________________________________________________________________

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

more options

Make sure that you use the latest versions of all JavaScript files.

more options

I tried all of suggested steps, but it did not make any difference. Our customers start reporting that they are having the same issue after Firefox pushes upgrade. That is a huge problem for us. Please help.

more options

Thank you for the recommendation. Do you know how to do this (making sure we use all latest versions?). The site works fine on all other browsers. It used to work great on Firefox (actually, it was our #1 recommended browser) until this upgrade.

more options

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

more options

Followed the steps, but unfortunately it did not help

more options

Remove the deprecation.js library, which breaks getElementsByClassName in Firefox 20. References:

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

Athraithe ag Amit Kumar Thakur ar

more options

it works in all other browsers. If I change the code, I can break this.

more options

Réiteach Roghnaithe

it works in all other browsers. If I change the code, I can break this.

You might think that, but the deprecation.js library purely targets Firefox. Check line #15 in the comment block. You can confirm that by looking at the init function:

  init: function(deprecatedMethods) {
    if (!Prototype.Browser.Gecko) return;

"Gecko" is the rendering engine in Firefox and doesn't match IE or any Webkit based browser. So if it isn't Firefox, exit the deprecation library.

Ready to test?

more options

Thank you. That fixed the problem. I just commented out the code that was loading this library.

more options

the suggestion about clearing cache and stuff worked for me. but i had this issue in firefox 20.0.1 for a small screen android phone. i have never seen such behavior (essentially no ability to use it no address bar no top page links , only pages i could get to were firefox pages from the menu) . whatever the cause of this crippling problem is, i suggest you guys change it. i have considerable it web design and web master ecperience. a cookie sjould not be able tp shut off the browsers primary fumctionality. it msnifested as the start page reloading eavh and every time i tried to type an address.

more options

Hi conspiritech, the original problem in this thread had to be fixed by changing the website. I suspect you have a different issue, although perhaps it only occurs on particular websites. If it recurs, could you start a new thread and make sure to tag it with "mobile" so it is spotted by the volunteers in the best position to help? You could do that here:

https://support.mozilla.org/questions/new/mobile

more options

It has actually stopped, apparently without my intervention. I did have a notice when I tried it just now that my '[privacy]defense' plugin trial (?) expired.