Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't restore my search bar

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó Jay

more options

My search box disappeared. I know about clicking the 3 horizontal lines, selecting customize and dragging the box. Actually the box is still there on the customize screen, but not in any other tabs.

Dragging a second box does nothing. Refreshing Firefox does nothing. Rebooting does nothing. Firefox 125.0.2

My search box disappeared. I know about clicking the 3 horizontal lines, selecting customize and dragging the box. Actually the box is still there on the customize screen, but not in any other tabs. Dragging a second box does nothing. Refreshing Firefox does nothing. Rebooting does nothing. Firefox 125.0.2

Réiteach roghnaithe

Or in case Firefox isn't updating the underlying preference when you use Customize, you could use this as a starting point:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since this is simply a mirror image of the customization, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.search.widget.inNavBar and pause while the list is filtered

(3) If the preference has its default value of false, double-click it (or click the Toggle button) to set it to true

This will put the Search bar immediately next to the address bar. Use Customize to move it if you prefer it somewhere else on the bar.

Read this answer in context 👍 0

All Replies (6)

more options

Hi Henry, there should be enough space for the short search bar to the right of the main address bar. Does your Firefox show that the main toolbar is overflowing? The overflow list button looks like >>. On the Customize tab, the controls that don't fit should be listed in a small box on the right side.

Helpful?

more options

It is not overflowing, in fact the refresh moved everything to the little puzzle piece icon.

Helpful?

more options

Thank you for checking that. Yes, it's normal for add-on buttons to start off on the Extensions button drop-down. The overflow list would only have built-in buttons and controls.

Where did you place the search bar? You may need to remove that spacer from the bar and place the search bar immediately next to the address bar in order to allocate more width to the search bar. After closing out of Customize, hover your mouse over the space immediately to the right of the address bar and look for the mouse pointer to change to a double-headed arrow. Then click and drag left to shift width from the address bar to the search bar. Any luck with that?

Helpful?

more options

Réiteach Roghnaithe

Or in case Firefox isn't updating the underlying preference when you use Customize, you could use this as a starting point:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since this is simply a mirror image of the customization, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.search.widget.inNavBar and pause while the list is filtered

(3) If the preference has its default value of false, double-click it (or click the Toggle button) to set it to true

This will put the Search bar immediately next to the address bar. Use Customize to move it if you prefer it somewhere else on the bar.

Helpful?

more options

Thank you, the about:config fix worked.

Helpful?

more options

I too was having this issue. All efforts to resolve failed. I found that the search box was in the toolbar "overflow" area. Re-sizing my window - making it wider - resolved my issue. (It only took 3 days to find this resolution. I was losing it...)

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.