Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

4K YouTube videos often skip segments and buffer on Mac

  • 1 freagra
  • 0 leis an bhfadhb seo
  • 21 views
  • Freagra is déanaí ó zeroknight

more options

Running on an M1 Ultra Mac Studio, Firefox struggles to play 4K videos in recent days where it would've normally performed fine. I've never had troubles watching 4K YouTube on Firefox, until the past week or two. There are no other applications running, and only the one tab open in Firefox. Just a regular 4K video. Why won't it play properly? Why does it start buffering randomly when I can see my network is just fine? Why does it just randomly skip 10 seconds every minute or so while playing? This exclusively happens on 1440p or 2160p (4K). Please fix this ASAP.

Running on an M1 Ultra Mac Studio, Firefox struggles to play 4K videos in recent days where it would've normally performed fine. I've never had troubles watching 4K YouTube on Firefox, until the past week or two. There are no other applications running, and only the one tab open in Firefox. Just a regular 4K video. Why won't it play properly? Why does it start buffering randomly when I can see my network is just fine? Why does it just randomly skip 10 seconds every minute or so while playing? This exclusively happens on 1440p or 2160p (4K). Please fix this ASAP.

All Replies (1)

more options

If you disabled hardware acceleration, try enabling it.

Does it still happen in Troubleshoot Mode?

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.