Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

webp images not loading at all

  • 3 fhreagra
  • 3 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó cor-el

more options

hello! i've been having an issue with mozilla where webp images are not loading at all. this is especially prevalent on youtube, where thumbnails simply do not load, as well as on tumblr, where if an image or gif is a webp file, it will refuse to load. both are attached in the image below to see the difference between firefox and chrome, as the images load fine on chrome. as well as that, discord, when opened with browser instead of the app, does not load profile pictures, server icons, or custom emojis. google hadn't helped me at all, and i don't know what to do at this point. i don't want to go back to using chrome.

in the attached image, the top images show a set of shark sculptures. the first does not load on mozilla, and looking at the image file, it is a webp. the second image is revealed to be a jpg, which mozilla treats normally. in the second set of images, there's a quick look at a random youtuber's page, the top being mozilla and the bottom being chrome, and you can see the mozilla thumbnails do not load.

thank you for reading! i'm very confused and am unsure what to do. any help is appreciated!

hello! i've been having an issue with mozilla where webp images are not loading at all. this is especially prevalent on youtube, where thumbnails simply do not load, as well as on tumblr, where if an image or gif is a webp file, it will refuse to load. both are attached in the image below to see the difference between firefox and chrome, as the images load fine on chrome. as well as that, discord, when opened with browser instead of the app, does not load profile pictures, server icons, or custom emojis. google hadn't helped me at all, and i don't know what to do at this point. i don't want to go back to using chrome. in the attached image, the top images show a set of shark sculptures. the first does not load on mozilla, and looking at the image file, it is a webp. the second image is revealed to be a jpg, which mozilla treats normally. in the second set of images, there's a quick look at a random youtuber's page, the top being mozilla and the bottom being chrome, and you can see the mozilla thumbnails do not load. thank you for reading! i'm very confused and am unsure what to do. any help is appreciated!
Attached screenshots

Réiteach roghnaithe

Go to about:config in the address bar and make sure image.webp.enabled is set to true.

Read this answer in context 👍 1

All Replies (3)

more options

Réiteach Roghnaithe

Go to about:config in the address bar and make sure image.webp.enabled is set to true.

more options

I'm having the exact same issue. But setting image.webp.enable to true did not fix the issue. Still not displaying webp images. Using firefox 117.0 (64-bit) for windows. The same exact page shows great in Chrome and even in (cough, sputter, hack) edge.

more options

@dereksmbox-firefox

What kind of image is this if you check this in the Inspector?

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Athraithe ag cor-el ar