Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Dark Theme

  • 19 freagra
  • 7 leis an bhfadhb seo
  • 3250 views
  • Freagra is déanaí ó syren02

more options

Yesterday my firefox updated to version 96.0. It changed to screen to dark theme. I prefer the light theme and need help to change it back. Thanks

Email me at [email]@Hotmail.com.

Yesterday my firefox updated to version 96.0. It changed to screen to dark theme. I prefer the light theme and need help to change it back. Thanks Email me at [email]@Hotmail.com.

Athraithe ag Andrew ar

Réiteach roghnaithe

I feared so, anyway thanks for helping me understand what is the cause of this sudden shift, at least I know not to waste any more time trying to revert it, since the options now are either black text everywhere or white text everywhere. At least the layout.css.prefers-color-scheme.content-override helped me with reverting the websites.

Read this answer in context 👍 0

All Replies (19)

more options

Hi mmathe8, Firefox 96 now harmonizes more parts of Firefox with your toolbar theme. When the text color on your background tabs is light/white, it triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. It also signals sites that you have a dark theme preference.

What to do about this

The fastest workaround for now is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs such as:

https://addons.mozilla.org/firefox/addon/firefox-b/

I have attached a screenshot illustrating the difference between a theme with light text on the tabs and dark text on the tabs.


Background / Other Settings

Firefox 95+ is taking more and more cues from your toolbar area theme for how to style other aspects of the browser. There is a setting for some of these, but not all of them.

(A) Right-click context menus, toolbar drop-down panels

Starting in Firefox 89, these would flip to a dark background if the text on the inactive/background tabs was white or light. Firefox 96 has extended this adaptation to more parts of the browser. As far as I know, the only built-in way to avoid this is to change your toolbar theme to one with dark text on the inactive/background tabs. (The other way is the not-officially-supported userChrome.css file route.)

(B) Built-in pages, and websites that have light/dark responsive themes

Starting in Firefox 95, Firefox would inform pages that you preferred a light/dark theme based on your Firefox toolbar theme instead of your system theme. There is a way to decouple your page (content) theme preference from your toolbar theme. At this point, it's only available through the back door...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.

more options

I have the same problem after today update, all my themes that I used previously are now forcing dark theme despite previously being light, changing layout.css.prefers-color-scheme.content-override to 2 reverts pages back to light theme but the bookmark background on the left hand side still has a dark background. Is there a way to force the bookmark part to have the white background while not changing the top toolbar theme like I had up till yesterday ?

more options

artur6912 said

Is there a way to force the bookmark part to have the white background while not changing the top toolbar theme like I had up till yesterday ?

At this point, we do not know of a convenient way to change the background in the sidebar or the separate Library window ("Manage Bookmarks"), other than changing your theme. Maybe someone will come up with something in the next few days as people experiment with this new theming.

more options

Réiteach Roghnaithe

I feared so, anyway thanks for helping me understand what is the cause of this sudden shift, at least I know not to waste any more time trying to revert it, since the options now are either black text everywhere or white text everywhere. At least the layout.css.prefers-color-scheme.content-override helped me with reverting the websites.

more options

I have the same problem. I am currently using the solution provided by jscher2000 but I am now satisfied with it. I much preferred the theme I was using. I really with that Mozilla would not change the setting I use, either directly or indirectly. And I hope they resolve this one quickly.

MistWing SilverTail

more options

Why do this? The whole point of using Firefox is the ability to customise. I can just imagine the boffins in the board room thinking this would be really "cool" - Cut To Users: "WTF".

more options

Its enough to push me over to Chrome sadly, like WTH. Why stuff up our settings?

Athraithe ag webcentre ar

more options

i don't like the forced dark mode linked to the toolbar text, it is stupid because several themes are light but use white text instead of grey/black because it is more vsible with the picked color (like orange or pastel based themes, white bring out better than grey or or black). And unfortunately the css modification doesn't change the history page or the background. Hope mozilla will revert back to the older version style or give us an option like windows do (means choose dark task bar with light menu)

more options

Whose dark idea was it to impose DARK THEMES on everyone using a theme? They should be...

more options

JG7 said

Whose dark idea was it to impose DARK THEMES on everyone using a theme?

It's not everyone using a theme. It's everyone using a theme that has light text on a dark background.

For example, these themes trigger a light color scheme in the rest of the browser because they use dark text on the toolbars:

And there are thousands more choices...

more options

Hi, everyone. I used the about:config the other day to change the color scheme content and it worked. but I hate it - hard to navigate my most-used websites. So I tried to change it back - but nothing happens. Wondering if somehow I screwed up the true / false statement? Any help is appreciated. Thank you

more options

Hi sibber, in your screenshot, that first preference isn't doing anything; its name wouldn't be recognized. You can use the trash can at the right end of the row to delete it.

For the second preference, you can experiment with these values:

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System-level light/dark preference (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)
more options

Hi, jscher2000. Thanks for the fast reply. I trashed the first preference. But it doesn't matter what value I put in the second preference - it's forcing a light background. It stays stuck on 1. There is absolutely no change in appearance. I've used the task manager to kill firefox. I also restarted my computer - no change. any other ideas? Truly appreciate your help!

Athraithe ag sibber ar

more options

sibber said

But it doesn't matter what value I put in the second preference - it's forcing a light background. It stays stuck on 1. There is absolutely no change in appearance.

It won't let you change the value to 0 (zero)? Your screenshot doesn't show a lock for that preference, so you really should be able to edit it. Puzzling.

more options

I can edit it to any value. But it takes about 5 times before it works - unsure why. And I can't find any setting that helps me navigate the page the way designers intended. Makes paying bills & ordering stuff much more difficult. sigh. might ask my tech guy to roll back to 95 - beyond my ability. Thanks for all the help

more options

sibber said

I can edit it to any value. But it takes about 5 times before it works - unsure why. And I can't find any setting that helps me navigate the page the way designers intended. Makes paying bills & ordering stuff much more difficult. sigh. might ask my tech guy to roll back to 95 - beyond my ability. Thanks for all the help

If the page isn't showing fully, that probably has a different cause. Just in case, if you haven't already, see Disable high contrast mode in Firefox. If that doesn't help, can you start a new question? Here's a link for that: https://support.mozilla.org/questions/new/desktop/form

more options

Thanks so much! Bye

more options

Hi there,

I've made a post here which I hope is useful: https://support.mozilla.org/en-US/questions/1360389?page=2#answer-1479952

This explains a method to force Firefox to use a Light theme.

more options

Yeah, sitting around thinking of ways to make it more complicated. There was nothing wrong with the way things were. If I couldn't see the text on the menu or whatever, I just choose a different theme. Let us decide what we want to look at. Someone else said it - isn't that the point of customizing?