Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox says I have javascript disabled, but in about:config, javascript.enabled value=true. Currently I can't use Facebook.

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 1289 views
  • Freagra is déanaí ó Cal7

more options

I downloaded Firefox today. I received 3 messages that javascript is disabled. The first one was from Facebook (see screenshot). The second one was from Javascript when I was trying to figure out how to enable javascript (see screenshot). Yet when I checked about:config, javascript.enabled's value is "true" (see screenshot). The third one was from Firefox when I did a survey on why I decided to use Firefox (no screenshot). What am I doing wrong?

Attached screenshots

Réiteach roghnaithe

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 3

All Replies (3)

more options

Réiteach Roghnaithe

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Hi Cal7, you have the NoScript extension installed (you can see its icon in your third screenshot). It automatically blocks all JavaScript from running until you approve each script source. I don't recommend it for average users, only those who are quite paranoid about security. If you didn't intend to install it, you can right-click the icon and choose Remove Extension.

Athraithe ag jscher2000 ar

more options

Thanks so much for the help!