Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dúnadh an snáithe seo agus cuireadh sa chartlann é. Cuir ceist nua má tá cabhair uait.

What happened to "Location" bar

  • 23 freagra
  • 5 leis an bhfadhb seo
  • 666 views
  • Freagra is déanaí ó the-edmeister

more options

What happened to the Location bar in 37.xx

Now I have that long, long Search bar. With the Location bar I could see the link of the site I was on. I could also sent that link to someone if I wanted to.

With every upgrade, things get more complicated.

Thanks.

Réiteach roghnaithe

I'm guessing this is due to the "penguin 3.10.3" theme, which is your current theme. When I installed that, most of the interface disappeared or was not displayed correctly. I would suggest disabling that theme and switching to the default one or a different theme instead.

Read this answer in context 👍 1

All Replies (20)

more options

To change this, click on the three-bars icon in the top right corner and choose "customize". You can then drag any part of firefox (including the location bar and search bar) to wherever you want. You should see the location bar in either the set of buttons on the left, or the menu on the right, and you can drag it into the top of the window.

If the location bar is there but short, you can change that as well. Click and drag on the space between the location and search bars to change the width of the two.

The article Customize Firefox controls, buttons and toolbars also has instructions on how to do this.

more options

Is the location/address bar completely gone or only reduced in width?

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

You can try to click the "Restore Defaults" in the Customize palette window.

You can try to rename (or delete) the xulstore.json file in the Firefox profile folder. You can use this button to go to the currently used Firefox profile folder:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

MY problem has only gotten worse. I can NOT "Customize" and I do not have the three little bars. I also have a totally blank area across the top.

I'm sure while waiting for some help I've messed around and clicked on too many thing.

Please be patient while I try to get back to a starting point. :-(

more options

vegaspatt said

What happened to the Location bar in 37.xx Now I have that long, long Search bar. With the Location bar I could see the link of the site I was on. I could also sent that link to someone if I wanted to. With every upgrade, things get more complicated. Thanks.
more options

Well, once again it appears that the problem might be an add-on. I changed it and now the Location Bar is back. This is so frustrating.

One thing still missing is those 3 Icon Bars in the upper right corner.

Could this be an issue with the current Appearance Add-on?

I also can now "Customize" again where as I couldn't before.

Are there any SAFE Add-Ons?

more options

What Add-on (extension) was causing this problem?

Did you check its page on the Add-ons website?

more options

cor-el,

I think the Add-on was Walnut Light.

I still can't shrink that Location bar. I was able to Customize again and saw those 3 little horizontal bars and added it to the upper right corner of the page. The text under it says Firefox but that's all. I don't think it's the one that user 293 was talking about? The more things I click on the worse things seem to get.

more options

This sounds like it is caused by an addon. Can you please start the browser in safe mode? Hold down the shift key while opening firefox, and see if the problem still exists.

Also, can you add the following?

- a screenshot of the entire window
- a list of all your installed addons

Thank you!

more options

I did try Safe Mode earlier and that's when I discovered it was probably an Add-on. This is the 2nd time the Add-0ns have caused me problems. I had to make 2 screen shots to catch all of the Add-ons.

I think I need to delete all of the Add-ons and start fresh?

more options

I doubt you will be able to even read my screen shots? Sorry.

more options

So one section of the Add-ons page is Appearance, which I think is where you found the list of themes, and another section is Extensions. Extensions are disabled in Safe Mode, so it's worth taking a look at those as well.

If you want to copy/paste a list, you can use the support information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions table, and then you can select and copy the top part (all the ones with Enabled=true) and paste that into a reply. The formatting may be a bit ugly, but hopefully we can still understand it.

more options

Not sure I did this right? Extensions Name Version Enabled ID Add-on Compatibility Reporter 2.0.5 true compatibility@addons.mozilla.org Classic Theme Restorer 1.3.0 true ClassicThemeRestorer@ArisT2Noia4dev ColorfulTabs 26.7 true {0545b830-f0aa-4d7e-8820-50a4629a56fe} Gish It! 1.4 true gish-it.ffext@gishpuppy Image and Flash Blocker 0.7 true imgflashblocker@shimon.chohen Image Blocker 1.0.1 true image-blocker@erikvold.com Padlock 0.5.0 true {d09e32df-8610-4b33-b929-1e631b764130} PrivacyChoice TrackerBlock 2.2 true trackerblock@privacychoice.org Theme Font & Size Changer 37.0 true {f69e22c7-bc50-414a-9269-0f5c344cd94c} Vacuum Places Improved 1.2 true VacuumPlacesImproved@lultimouomo-gmail.com Yahoo Mail Hide Ad Panel 2.43 true {c37bac34-849a-4d28-be41-549b2c76c64e} AniWeather 0.8.48 false {4176DFF4-4698-11DE-BEEB-45DA55D89593} Avast Online Security 10.2.0.187 false wrc@avast.com Big theme 1.7 false bigTheme@digdug.org Weather Forecast 0.1.7 false jid1-aqwHRwQpv3JUMs@jetpack

I STILL get nothing from those 3 horizontal bars at the top right corner as user 293 said I should. Is this not the Icon I should have up there? As you can tell I more confused all the time.

more options

Réiteach Roghnaithe

I'm guessing this is due to the "penguin 3.10.3" theme, which is your current theme. When I installed that, most of the interface disappeared or was not displayed correctly. I would suggest disabling that theme and switching to the default one or a different theme instead.

more options

The most powerful and comprehensive of your appearance-related extensions is Classic Theme Restorer. If you find that customizing the main navigation toolbar doesn't do what you need, please check through its extensive settings dialogs to see if there's a useful adjustment there. You can access them using the Options button for Classic Theme Restorer on the Add-ons page, Extensions section.

more options

jscher2000-The Classic Theme Restorer was a life saver to me after one of the FF updates and I did search for settings in it but was afraid to try much of anything.

user293. Penguin was the one I changed to and only then did I get my location bar back. I will try another one to see if I still have my Location Bar.

more options

user293--I changed to a different theme and I still have my Location Bar. So it must have been that one theme that messed me up. I will delete that one for sure.

I will consider this as "Solved" but why don't I have those 3 horizontal bars as mentioned previously?

more options

Normally, the "3-bar" menu button doesn't have any text label under it, but the text labels might be a feature of Classic Theme Restorer.

more options

I've always used the Icon/Text version on my "Bars". So I'm just going to quit fretting about it.

Thanks for all the help.

more options

Me too. I just re-opened browser after a system restart (I rarely do that, big fan of hibernate) and so much is gone. menu (old style), location bar, customize menu, options, theme, bookmark toolbar. Persona's says I am using default theme. I think I was last using non-default.

All I see the old title bar (translucent), my navigation bar with icon/text and a tab bar. things are somewhat squished vertically too, but that's minor for now.

I am pretty sure I did not just get a browser update because I usually turn auto-update off. But perhaps I did not this time. I have no HELP->ABOUT to see what version I am on. I recently upgraded to 36.0.something.

Of course, this happens when I don't have time to play around and try troubleshooting things, but thought I would chime in. REcently I learned about the Tools->troubleshooting menu item, but I guess that only works if you have a Tools menu. I think if I post this, I will be able to see system details. That sure is a roundabout way to uncover system details!

note to self: make sure auto update is off!!! ugh.

more options

Hi Wendy444, to display the classic menu bar, you can access the toolbar list to turn it on using any of these:

  • (Windows) tap the Alt key to activate the classic menu bar temporarily, then View > Toolbars
  • right-click a blank area of the tab bar, or the "+" button on the tab bar
  • "3-bar" menu button > Customize > Show/Hide Toolbars

Hopefully that will help get you back to work quickly. For other issues, you might want to start a new question (link at the top of the page) since this one is already marked "Solved" and it's hard to spot new posts in solved threads on this forum.

  1. 1
  2. 2