Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Linux bookmarks with Proton (Firefox 89)

  • 4 antwurd
  • 1 hat dit probleem
  • 14 werjeftes
  • Lêste antwurd fan mrphnixdev

more options

Hello,

I have Firefox 89 installed on my PC with Linux (Pop_OS!). The new proton interface does not change the bookmarks.

browser.proton.contextmenus.enabled is set on true.

Hello, I have Firefox 89 installed on my PC with Linux (Pop_OS!). The new proton interface does not change the bookmarks. browser.proton.contextmenus.enabled is set on true.
Keppele skermôfbyldingen

Alle antwurden (4)

more options

mrphnixdev said

The new proton interface does not change the bookmarks.

What kind of change were you expecting to see?

It is a little odd that the separator line above "Open All in Tabs" is not in a contrasting color.

more options

Sorry for not being clear enough.

I just want Firefox on Linux to have the same UI as on Windows. I have added a new screenshot showing the difference between the two.

I've done some research and I think I've found the problem, it's the GTK Pop theme that replaces the default theme, I don't know how to remove it.


I tried to change "widget.content.gtk-theme-override" in about:config, but it doesn't work. (widget.content.gtk-theme-override is set on Pop by default)


I changed: "toolkit.legacyUserProfileCustomizations.stylesheets" to "true". I created a "chrome/userContent.css" file in my profile :

input:not(.urlbar-input):not(.textbox-input):not(.form-control):not([type='checkbox']):not([type='radio']), textarea, select {

   -moz-appearance: none !important;

}

It does not work either


The context menu and bookmark bar changes when I change the global theme of GTK via gnome tweaks So I would like to find a way to disable the GTK theme for firefox only.

I don't think it's a Firefox problem but rather a GTK problem. I will install Fedora to see if I have the same problem.

more options

Does your about:config show a preference named widget.non-native-theme.enabled ? I'm not sure what it does, actually, but I think it affects how closely Firefox follows your OS theme.

There are a bunch of preferences starting with widget.non-native-theme. that might be relevant in some way...

more options

In my about:config, the preference widget.non-native-theme.enabled is set to true.

I tried changing the preferences with booleans from true to false in widget.non-native-theme. It does not change anything.