Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Can't do 'Undo Close Tab' anymore

  • 7 antwurd
  • 5 hawwe dit probleem
  • 14 werjeftes
  • Lêste antwurd fan fweth

more options

Since my update to Firefox 29 (OS: Arch Linux) my 'Undo Close Tab' feature stopped working. I tried to disable all extension, with no luck. Neither the entry in the context menu nor the shortcut (cmd+shift+t) is working anymore.

Since my update to Firefox 29 (OS: Arch Linux) my 'Undo Close Tab' feature stopped working. I tried to disable all extension, with no luck. Neither the entry in the context menu nor the shortcut (cmd+shift+t) is working anymore.

Alle antwurden (7)

more options

Are you running 29.0.1? If not, please update as there is a fix for this issue in that release that isn't in 29.0.0

more options

Yes, I'm running 29.0.1. Also there seems to be a problem with history restoring, after disabling an extension and clicking on 'restart now' in the extensions menu, Firfox restarted in the startpage and the entry 'Restore Previous Session' was not available in the 'History' menu (greyed out). Please note that 'Undo Close Tab' does not appear greyed out, it just doesn't do anything.

more options

Hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Just tried, same behaviour as before.

more options

Make sure that you do not run Firefox in permanent Private Browsing mode (Never remember history).

  • Edit > Preferences > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use Private Browsing mode"
more options

No, the value of 'Firfox will' is 'Remember history' and it also does, manually revoking single entries from the history works just fine.

more options

I should also say that my Firefox was interrupted a few times lately since my laptop battery is broken and the AC adapter gets plugged off easily. But I never referred to problems having to do with Firefox not remembering something that happened *before* an interruption.