Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

characters are displayed incorrectly on some webpages

  • 9 réponses
  • 0 a ce problème
  • 1 vue
  • Dernière réponse par Dario48true

more options

I am on arch linux running wayland, and whenever I visit some webpages (example reddit, github) some character are displayed incorrectly: spaces are incredibly large and numbers appear as . or , or other random punctuation or don't appear at all

examples in uploaded images

I am on arch linux running wayland, and whenever I visit some webpages (example reddit, github) some character are displayed incorrectly: spaces are incredibly large and numbers appear as . or , or other random punctuation or don't appear at all examples in uploaded images
Captures d’écran jointes

Solution choisie

cor-el said

gfx.e10s.font-list.shared => false

Troubleshoot Mode disables the shared font list which has already been tested without success.

Does it still happen with the flatpak version?

Lire cette réponse dans son contexte 👍 1

Toutes les réponses (9)

more options

Could be that Firefox is using some emoji font.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. If the Fonts tab is hidden, click the down arrow at the right end.

Cela vous a-t-il été utile ?

more options

firefox is doing that, but I don't understand why, as in my settings I have set normal fonts

Cela vous a-t-il été utile ?

more options

Privacy Badger may be interfering.

Does it still happen in Troubleshoot Mode?

Cela vous a-t-il été utile ?

more options

it still does not work (not displayed in the screenshot are the numbers still not working)

Cela vous a-t-il été utile ?

more options

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Cela vous a-t-il été utile ?

more options

it still happens on a new profile on a different instalation of firefox (same version) and it does not happen on brave (installed to test if it was system related)

Cela vous a-t-il été utile ?

more options

The screenshot sows that Twemoji font is used like I expected as we have seen such issues reported in the past with a font like that. You can try:

  • about:config => gfx.e10s.font-list.shared => false

See also:

  • /questions/1373348 The number and space fonts render much bigger and wider than other letters?

Cela vous a-t-il été utile ?

more options

Solution choisie

cor-el said

gfx.e10s.font-list.shared => false

Troubleshoot Mode disables the shared font list which has already been tested without success.

Does it still happen with the flatpak version?

Cela vous a-t-il été utile ?

more options

the flatpak version has no problems, huh probably a dependencies issue on the arch package, sorry to have disturbed and taken your time

Cela vous a-t-il été utile ?

Poser une question

Vous devez vous identifier avec votre compte pour répondre aux messages. Veuillez poser une nouvelle question, si vous n’avez pas encore de compte.