Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

white on black

  • 13 réponses
  • 6 ont ce problème
  • 103 vues
  • Dernière réponse par Navigator1Ann

more options

After new 96.0 update today, browser changed to white on black background; always had the opposite. Can't see method to change back. Setting in font section still says black on white, to no effect.’ Don't want the white on black.

After new 96.0 update today, browser changed to white on black background; always had the opposite. Can't see method to change back. Setting in font section still says black on white, to no effect.’ Don't want the white on black.

Toutes les réponses (13)

more options

As a preliminary comment, if you use a "High Contrast" dark theme on Windows, you can instruct Firefox to ignore that. See: Disable high contrast mode in Firefox.

Firefox 95+ is taking more and more cues from your toolbar area theme for how to style other aspects of the browser. There is a setting for some of these, but not all of them.

(A) Right-click context menus, toolbar drop-down panels

Starting in Firefox 89, these would flip to a dark background if the text on the inactive/background tabs was white or light. Firefox 96 has extended this adaptation to more parts of the browser. As far as I know, the only built-in way to avoid this is to change your toolbar theme to one with dark text on the inactive/background tabs. (The other way is the not-officially-supported userChrome.css file route.)

(B) Built-in pages, and websites that have light/dark responsive themes

Starting in Firefox 95, Firefox would inform pages that you preferred a light/dark theme based on your Firefox toolbar theme instead of your system theme. There is a way to decouple your page (content) theme preference from your toolbar theme. At this point, it's only available through the back door...

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.prefers-color-scheme.content-override and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to whatever you prefer from the list below, then press Enter or click the blue check mark button to save the change.

  • 0 => Force a Dark background
  • 1 => Force a Light background
  • 2 => Follow the System theme (default in Firefox 94)
  • 3 => Follow the Browser toolbar theme (default in Firefox 95+)

The about:config page should immediately reflect your saved change.


I have attached a composite screenshot of what Firefox considers a "Dark" theme (light text) and a "Light" theme for reference. It's difficult to say exactly where the line is.

more options

The config "layout.css etc" did reset the main browser page to white for me, but the toolbars remain white on black. How is toolbar color changed?

more options

Which theme are you using -- System? It tries to read from your OS. You could switch to Light instead. See: Use themes to change the look of Firefox.

more options

Thank you so much for your help. I do have a pretty dark theme (black cat eyes) and the tabs and menu bar are all white on black as expected and as I want.. But when I pull down a menu item , say file, bookmarks, tools, etc, the displayed menu items (up until today w/96.0) were always black on white. Now suddenly the are all white on black and I would like to change back to they way they were yesterday. I did not do anything, the change manifested from the 96.0 automatic update.

more options

I think the developers are trying to make it all consistent. Right now, I'm not aware of any easy/quick fix that lets you have black-on-white menus with a light text-on-dark background theme.

Unofficial Community-Supported Workaround

I did post some style code for Firefox 89+ to lighten the menus. If you are handy with files, you could take a look here: https://www.userchrome.org/firefox-89-styling-proton-ui.html#menucolors. But that's limited and doesn't affect the sidebar, Library windows, and probably various other things. If you want to try it, I can spell out the steps involved.

DISCLAIMER: modifications made through a userChrome.css file often stop working as Firefox evolves in new releases, and occasionally "breaks" the interface in serious ways. You can (re)start Firefox in its Troubleshoot Mode to bypass the userChrome.css file so you can get Firefox running, and then edit or remove the file as needed.

more options

There's got to be a way, cause that's what I had until this morning with the 96.0 update. What did they change?

more options

This is the second time my background has change due to an update. When Firefox updates the version and dramatic changes are made to the appearance of the screen there should be an "easy" option to put it back to what the user was comfortable with. The last version update changed my tab bar to gray making it hard for me to see the tabs. There was no solution for this other than changing the theme. I get up to do my morning work and internet surfing and I find that my browser has updated to 96.0 and my screen is now white text on black background. I DO NOT WANT THIS!!! I very annoyed by the fact I had to spend the last 30 minutes this morning trying to find a solution. Sorry to tell you jscher2000, but your solution is complicated, cumbersome and there is no reason I should have to do this in the first place. It is ridiculous that i have to go into about:config and make changes. I'm about to remove Firefox and switch to Chrome. To the developers of Firefox.... Please stop doing this!!!!!!

more options

I tried just for fun to switch to a light theme. Weird. Everything reverted to black on white, except the search bar. Fix for this? Hope the overall question is resolved soon.

more options

Hi perktech57, could you temporarily change to a theme that doesn't use white text on the tabs? That should resolve it until we have a better idea. This one popped up in a search and might tide you over:

https://addons.mozilla.org/firefox/addon/new-orleans-saints-v2/

more options

diben681 said

I tried just for fun to switch to a light theme. Weird. Everything reverted to black on white, except the search bar. Fix for this? Hope the overall question is resolved soon.

Do you mean the main address bar or the optional short search bar? Either way, they should follow the general theme, so it's odd that they do not. (I always use a light theme and haven't noticed a change with either.)

more options

Both search windows to answer your question. So now I've learned to pay attention to the horizontal stripes in the themes examples to indicate print color. Duh Hate light themes, found one I thought might be OK for temp, all OK but now I have another problem: The blank home page is so bright, so I went to change it and the color pick controls don't do anything. Don't work at all.

more options

When you say the blank home page, I think it's completely empty. I don't know whether you can color it because it doesn't have any content for a background color to sit behind. ?? I might find time to look at that between other crises...

more options

Twitch makes it easy by having a light/dark option straight from the profile drop down list. Firefox people ..hint hint.