Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Can't disable Firefox login autofill

  • 5 réponses
  • 1 a ce problème
  • 10 vues
  • Dernière réponse par cor-el

more options

The settings for login and password autofill are checked but not available for me to disable. I don't want autofill enabled. How can I stop it? Thanks.

The settings for login and password autofill are checked but not available for me to disable. I don't want autofill enabled. How can I stop it? Thanks.

Solution choisie

You're welcome.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (5)

more options

Hi fred.alternative, what about the main setting, "Ask to save logins and passwords for websites"? If that is unchecked, then the items below it are grayed out and the password manager is disabled.

Could you compare your settings with this screenshot -- what's the same and what's different?

more options

Hi, there are a number of differences with my settings. The first part of Logins and Passwords is the same (Ask to save logins and password for websites is unchecked) but I don't have Use a Master Password checked.

Forms And Autofill doesn't appear as a setting for me at all and History is set to Never Remember History.

Thanks, Steve.

more options

If you are in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) then you won't be prompted to save a new password and you won't be able to modify the "Ask to save logins and passwords for websites" and other login settings.
Note that you can still use "Fill Login" in the right-click context menu in a web form and use "Create a new login" in Lockwise in Private Browsing mode.

To modify the autofill setting you either need to start Firefox in regular mode of modify signon.autofillForms and possibly signon.autofillForms.http directly via the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

That seems to have done the job. Thanks very much for your help.

Steve.

more options

Solution choisie

You're welcome.