Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

It doesn't appear your computer can support WebGL.

  • 1 réponse
  • 1 a ce problème
  • 2 vues
  • Dernière réponse par Ikhwan

more options

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

This is a server that I'm trying to use for a WebGL-based python library 'vpython' from Mac. It is equipped with 4 NVIDIA RTX2080, Driver Version: 435.21 CUDA Version: 10.1

Via SSH, X11 and xQuartz, I have reached to connect these two computers, then I got faced to this error message shown as: 'It doesn't appear your computer can support WebGL. Click here for more information(this is directed to https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#firefox:linux:fx76.'

From the page 'about:config', webgl.disabled set as false.

From the page 'about:support', WebGL 1 Driver Renderer is described as

WebGL creation failed:

  • Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_GLXTEST_FAILED
  • Exhausted GL driver options.

with a detailed description as;

GLXtest process failed (exited with status 1): X error occurred in GLX probe, error_code=160, request_code=149, minor_code=6

While I am reluctant to try overriding the blacklist, any other opinion is not showing..

Any comments would be appreciated.

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0 This is a server that I'm trying to use for a WebGL-based python library 'vpython' from Mac. It is equipped with 4 NVIDIA RTX2080, Driver Version: 435.21 CUDA Version: 10.1 Via SSH, X11 and xQuartz, I have reached to connect these two computers, then I got faced to this error message shown as: 'It doesn't appear your computer can support WebGL. Click here for more information(this is directed to https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration#firefox:linux:fx76.' From the page 'about:config', webgl.disabled set as false. From the page 'about:support', WebGL 1 Driver Renderer is described as WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: FEATURE_FAILURE_GLXTEST_FAILED * Exhausted GL driver options. with a detailed description as; GLXtest process failed (exited with status 1): X error occurred in GLX probe, error_code=160, request_code=149, minor_code=6 While I am reluctant to try overriding the blacklist, any other opinion is not showing.. Any comments would be appreciated.
Captures d’écran jointes

Toutes les réponses (1)

more options

When I change 'about:config -> webgl.force-enabled' to be true, still didn't work.


when I try 'glxinfo', it gives Error: unable to open display (from vscode terminal)

or

name of display: localhost:11.0 libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: swrast X Error of failed request: GLXBadContext

 Major opcode of failed request:  149 (GLX)
 Minor opcode of failed request:  6 (X_GLXIsDirect)
 Serial number of failed request:  31
 Current serial number in output stream:  30

(from mac terminal)

Modifié le par Ikhwan