X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

Bookmark favicon keep changing to wrong one.

Publié

Hi, everyone. I'm using Firefox quantum 61.0.1 64bit windows10.

I have a problem with bookmark favicon. Some favicons keep changing to the different site of favicon.

I've already tried: - delete profile folder (including favicon.sqlite, place.sqlite ) - delete all firefox related files & uninstall & re-install - refresh & clear the profile.

Yes, these methods once fixed favicon problems temporary, but, this problem is keep happening & back to the wrong favicon. But it happens to only "google" related website.

"Google maps" "Google adsense" favicons change to Google.com search favicon. Then I realized,

Google map address is https://www.google.com/maps/

Google adsense address is https://www.google.com/adsense/

yes, both of them, addresses start with https://www.google.com/. I guess that's why firefox bookmark favicon keep changing to google search favicon.

But the favicon on the tab shows proper favicon. Also other browsers bookmark show proper favicon. This is firefox bug, right? Is there any solutions?

Thank you.

Hi, everyone. I'm using Firefox quantum 61.0.1 64bit windows10. I have a problem with bookmark favicon. Some favicons keep changing to the different site of favicon. I've already tried: - delete profile folder (including favicon.sqlite, place.sqlite ) - delete all firefox related files & uninstall & re-install - refresh & clear the profile. Yes, these methods once fixed favicon problems temporary, but, this problem is keep happening & back to the wrong favicon. But it happens to only "google" related website. "Google maps" "Google adsense" favicons change to Google.com search favicon. Then I realized, Google map address is https://www.google.com/maps/ Google adsense address is https://www.google.com/adsense/ yes, both of them, addresses start with https://www.google.com/. I guess that's why firefox bookmark favicon keep changing to google search favicon. But the favicon on the tab shows proper favicon. Also other browsers bookmark show proper favicon. This is firefox bug, right? Is there any solutions? Thank you.
Captures d’écran jointes

Solution choisie

I have been seeing a bookmark assume the favicon image of an adjacent bookmark for quite a few years now (like 12 -13 years, 2005-ish). The only consistency that I ever saw was that the favicon that "took over" another was never of the older favicon.ico format and the saved bookmark favicon image was located in other than the website server file path root directory which was the original W3C standard for favicon placement for web browsers to loom for it. IOW, Firefox wouldn't find the image in a standard, expected location when Firefox went to save the favicon for a newly saved bookmark during the first use of the new bookmark. And IMO that is part of the problem; Firefox does retrieve the image after the bookmark was first saved; unless drag'n'drop is used to save the bookmark.

That said, I lessen the occurrence of that happening by not using the "Save as a bookmark" feature in Firefox. Like {Ctrl + D} and the provided Menu items spread throughout the UI menu system. But rather I drag'n'drop the URL into the Bookmarks Toolbar or into the Bookmarks Sidebar when I want to save a new bookmark. When doing that the favicon image is saved immediately; no waiting for the "first use" for the image to get saved. Worked fine for a number of years and then with the number of websites getting HTML5 coding and combining "mobile" with "desktop" code on the same page, I started seeing that happen again. Not as bad as before and mostly it seems to happen much later after the bookmark was saved than previously. But some websites just seem to have the ability to screw up the favicon for an adjacently saved bookmark; and if a bookmark like that is moved, it will contaminate another bookmark.

The Reddit main page was one "offender", but sub-Reddit links don't have that issue. So I dumped the main Reddit page.

Lire cette réponse dans son contexte 0

Détails additionnels sur le système

Plugins installés

  • Shockwave Flash 29.0 r0

Application

  • Agent utilisateur : Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

Plus d’informations

TyDraniu
  • Top 25 Contributor
302 solutions 1686 réponses

Do you have any addons?

It may be a bug in Firefox, but it's usually triggered by an addon.

Do you have any addons? It may be a [https://bugzilla.mozilla.org/show_bug.cgi?id=1453751 bug in Firefox], but it's usually triggered by an addon.

Réponse utile

TyDraniu said

Do you have any addons? It may be a bug in Firefox, but it's usually triggered by an addon.


I once deleted all add-ons & I started to use firefox without any add-ons after clean-install. However, it happened again. So, I assume it is not add-on problem.

Anyway, thank you for your advice!

''TyDraniu [[#answer-1135003|said]]'' <blockquote> Do you have any addons? It may be a [https://bugzilla.mozilla.org/show_bug.cgi?id=1453751 bug in Firefox], but it's usually triggered by an addon. </blockquote> I once deleted all add-ons & I started to use firefox without any add-ons after clean-install. However, it happened again. So, I assume it is not add-on problem. Anyway, thank you for your advice!
the-edmeister
  • Moderator
5391 solutions 40026 réponses

Solution choisie

I have been seeing a bookmark assume the favicon image of an adjacent bookmark for quite a few years now (like 12 -13 years, 2005-ish). The only consistency that I ever saw was that the favicon that "took over" another was never of the older favicon.ico format and the saved bookmark favicon image was located in other than the website server file path root directory which was the original W3C standard for favicon placement for web browsers to loom for it. IOW, Firefox wouldn't find the image in a standard, expected location when Firefox went to save the favicon for a newly saved bookmark during the first use of the new bookmark. And IMO that is part of the problem; Firefox does retrieve the image after the bookmark was first saved; unless drag'n'drop is used to save the bookmark.

That said, I lessen the occurrence of that happening by not using the "Save as a bookmark" feature in Firefox. Like {Ctrl + D} and the provided Menu items spread throughout the UI menu system. But rather I drag'n'drop the URL into the Bookmarks Toolbar or into the Bookmarks Sidebar when I want to save a new bookmark. When doing that the favicon image is saved immediately; no waiting for the "first use" for the image to get saved. Worked fine for a number of years and then with the number of websites getting HTML5 coding and combining "mobile" with "desktop" code on the same page, I started seeing that happen again. Not as bad as before and mostly it seems to happen much later after the bookmark was saved than previously. But some websites just seem to have the ability to screw up the favicon for an adjacently saved bookmark; and if a bookmark like that is moved, it will contaminate another bookmark.

The Reddit main page was one "offender", but sub-Reddit links don't have that issue. So I dumped the main Reddit page.

I have been seeing a bookmark assume the favicon image of an adjacent bookmark for quite a few years now ''(like 12 -13 years, 2005-ish)''. The only consistency that I ever saw was that the favicon that "took over" another was never of the older favicon.ico format and the saved bookmark favicon image was located in other than the website server file path root directory which was the original W3C standard for favicon placement for web browsers to loom for it. IOW, Firefox wouldn't find the image in a standard, expected location when Firefox went to save the favicon for a newly saved bookmark during the first use of the new bookmark. ''And IMO that is part of the problem; Firefox does retrieve the image after the bookmark was first saved; unless drag'n'drop is used to save the bookmark.'' That said, I lessen the occurrence of that happening by not using the "Save as a bookmark" feature in Firefox. ''Like {Ctrl + D} and the provided Menu items spread throughout the UI menu system.'' But rather I drag'n'drop the URL into the Bookmarks Toolbar or into the Bookmarks Sidebar when I want to save a new bookmark. When doing that the favicon image is saved immediately; no waiting for the "first use" for the image to get saved. Worked fine for a number of years and then with the number of websites getting HTML5 coding and combining "mobile" with "desktop" code on the same page, I started seeing that happen again. Not as bad as before and mostly it seems to happen much later after the bookmark was saved than previously. But some websites just seem to have the ability to screw up the favicon for an adjacently saved bookmark; and if a bookmark like that is moved, it will contaminate another bookmark. The Reddit main page was one "offender", but sub-Reddit links don't have that issue. So I dumped the main Reddit page.

Auteur de la question

the-edmeister, thank you for your advice. I hope they fix this problem properly.

the-edmeister, thank you for your advice. I hope they fix this problem properly.

Auteur de la question

I tried the-edmeister's suggestion. I used drag'n'drop the URL into the Bookmarks Toolbar. I think it worked! This 1 week, it won't go back to wrong favicon.

Thank you for your help, the-edmeister.

I tried the-edmeister's suggestion. I used drag'n'drop the URL into the Bookmarks Toolbar. I think it worked! This 1 week, it won't go back to wrong favicon. Thank you for your help, the-edmeister.
the-edmeister
  • Moderator
5391 solutions 40026 réponses

You're welcome!

You're welcome!