Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

Are the camera permission settings broken in Quantum v. 58?

  • 7 réponses
  • 2 ont ce problème
  • 5 vues
  • Dernière réponse par relic25

more options

Our company uses webcams and a web app for ID photos. When each computer's copy of Firefox updated to version 58, the camera feeds stopped working in Firefox. I tried re-allowing the camera for the site by clicking the info button in the address bar, and it was showing that the camera was allowed, but when we look in Tools -> Options -> Privacy & Security -> Permissions -> Camera -> Settings, no sites are listed (even though we explicitly allowed one), and there doesn't appear to be any way to add a site. Version 57.0.4 worked fine, and we have verified this on 6 different computers.

We have begun reverting every computer back to 57.0.4 (which got them working again), but this is not an acceptable long term solution.

Are the camera permissions just broken in 58, or is there some other way I can permanently allow a trusted site to use the camera?

Solution choisie

Just to keep the info together for those who may still be looking for an answer, here is the source of the problem that we encountered (copied from fxsitecompat.com)

The prefixed mozSrcObject property on the HTMLMediaElement interface, deprecated since Firefox 42, has been removed with Firefox 58. Use the standard srcObject property instead.

Changing this in our code fixed the problem for us.

Lire cette réponse dans son contexte 👍 0

Toutes les réponses (7)

more options

Update:

After a lot of trial and error, I managed to get the site to show up in the allowed sites of Permissions/Camera/Settings, but the camera feed is still not appearing. This is definitely due to something in version 58 though, as the feed appears when I revert back to 57.0.4 with no other changes.

Has anyone else reported broken webcam feeds in 58?

more options

Did you contact the company that makes those camera about if there was conflicts as well too?

more options

After further tests, I don't think the camera is the issue.

I tried a different camera (different brand, model, and codec) and it's feed still doesn't appear. It seems to be some kind of conflict between something new in FF 58 and the API on our site that is supposed to display the feed. I can get the feeds from the same cameras to display on webcam testing sites, but not on ours. The only difference I know of is that our site displays the camera image on a jquery overlay window.

The only things at this point that I know for certain is that 1) it's not the camera, and 2) it was working fine in FF 57.0.4 but not in 58.

more options

Check out this question, maybe it's the same reason.

https://support.mozilla.org/questions/1201670

more options

Good info in those links. We'll have our developers try those property changes in the site's code to see if that helps. Thanks!

more options

I have this problem too.

more options

Solution choisie

Just to keep the info together for those who may still be looking for an answer, here is the source of the problem that we encountered (copied from fxsitecompat.com)

The prefixed mozSrcObject property on the HTMLMediaElement interface, deprecated since Firefox 42, has been removed with Firefox 58. Use the standard srcObject property instead.

Changing this in our code fixed the problem for us.