X
Appuyez ici pour vous rendre sur la version mobile du site.

Forum d’assistance

how do I disable session restore

Publié

When a website locks up my browser and I have to close it with task manager and reopen the browser, firefox tries to reopen the site that locked it up. How do I stop this?

When a website locks up my browser and I have to close it with task manager and reopen the browser, firefox tries to reopen the site that locked it up. How do I stop this?

Solution choisie

Hi jcvolt said

When a website locks up my browser and I have to close it with task manager and reopen the browser, firefox tries to reopen the site that locked it up. How do I stop this?

Do you need Firefox not to restore your previous session right now? Because in that case, I'll provide steps to hide your session history files from Firefox so it has no choice but to start with the home page.

But if you meant more generally, going forward:

There are two preferences most relevant to automatic crash recovery:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) To skip automatic restore and display the "This is embarrassing" screen: Double-click the browser.sessionstore.max_resumed_crashes preference and change the value from 1 to 0 (that's a zero) and click OK -- I use this setting to avoid potential loops of problem sites loading and causing another crash, etc.

(4) To never restore your previous session after a crash: Double-click the browser.sessionstore.resume_from_crash preference to switch its value from true to false -- you might still be able to use the History menu to Restore Previous Session, but I haven't tested it myself

Lire cette réponse dans son contexte 11

Détails additionnels sur le système

Plugins installés

  • Shockwave Flash 27.0 r0

Application

  • Agent utilisateur : Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Plus d’informations

Pkshadow 1072 solutions 14836 réponses

Please consider turning on send info to Mozilla before posting a question. This helps us help you. As I have no info from your system that would help see things that cause issues.

Close Firefox. Wait about 20 seconds for Firefox to finish closing. Right-click on the Firefox icon and select Open New Window.

Sometimes this works. If it opens, close it by Menu > File > Exit. This will flush out that web page from the Session Store.

As everything is geared towards Firefox 57 all the old articles do not work since version 54 and have been archived.

Can try this extension. Does not say if compatible to ver 57 https://addons.mozilla.org/en-US/firefox/addon/session-manager/ can also look for comparable type extensions.

Please let us know if this solved your issue or if need further assistance.

Please consider turning on send info to Mozilla before posting a question. This helps us help you. As I have no info from your system that would help see things that cause issues. Close Firefox. Wait about 20 seconds for Firefox to finish closing. Right-click on the Firefox icon and select Open New Window. Sometimes this works. If it opens, close it by Menu > File > Exit. This will flush out that web page from the Session Store. As everything is geared towards Firefox 57 all the old articles do not work since version 54 and have been archived. Can try this extension. Does not say if compatible to ver 57 https://addons.mozilla.org/en-US/firefox/addon/session-manager/ can also look for comparable type extensions. Please let us know if this solved your issue or if need further assistance.
jscher2000
  • Top 10 Contributor
8438 solutions 68871 réponses

Solution choisie

Hi jcvolt said

When a website locks up my browser and I have to close it with task manager and reopen the browser, firefox tries to reopen the site that locked it up. How do I stop this?

Do you need Firefox not to restore your previous session right now? Because in that case, I'll provide steps to hide your session history files from Firefox so it has no choice but to start with the home page.

But if you meant more generally, going forward:

There are two preferences most relevant to automatic crash recovery:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) To skip automatic restore and display the "This is embarrassing" screen: Double-click the browser.sessionstore.max_resumed_crashes preference and change the value from 1 to 0 (that's a zero) and click OK -- I use this setting to avoid potential loops of problem sites loading and causing another crash, etc.

(4) To never restore your previous session after a crash: Double-click the browser.sessionstore.resume_from_crash preference to switch its value from true to false -- you might still be able to use the History menu to Restore Previous Session, but I haven't tested it myself

Hi jcvolt [[#question-1182594|said]]'' <blockquote> When a website locks up my browser and I have to close it with task manager and reopen the browser, firefox tries to reopen the site that locked it up. How do I stop this? </blockquote> Do you need Firefox not to restore your previous session ''right now?'' Because in that case, I'll provide steps to hide your session history files from Firefox so it has no choice but to start with the home page. But if you meant more generally, going forward: There are two preferences most relevant to automatic crash recovery: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''sess''' and pause while the list is filtered (3) ''To skip automatic restore and display the "This is embarrassing" screen:'' Double-click the '''browser.sessionstore.max_resumed_crashes''' preference and change the value from 1 to 0 (that's a zero) and click OK -- I use this setting to avoid potential loops of problem sites loading and causing another crash, etc. (4) ''To never restore your previous session after a crash:'' Double-click the '''browser.sessionstore.resume_from_crash''' preference to switch its value from true to false -- you might still be able to use the History menu to Restore Previous Session, but I haven't tested it myself

Réponse utile

Thank you so much!

Thank you so much!