Sauvegarder et restaurer les informations dans les profils de Firefox

Mozilla Firefox stocke toutes vos données personnelles, comme les marque-pages, mots de passe et plugins dans un dossier de profil sur votre ordinateur, qui est différent du dossier du programme Firefox. Cet article explique comment sauvegarder votre profil, le restaurer ou le déplacer vers un nouvel emplacement ou un autre ordinateur.

Localiser votre dossier de profil

En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  • Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  • Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

    Sauvegarder votre profil

    Pour sauvegarder votre profil, fermez d'abord Firefox, s'il était ouvert, puis copiez le dossier de profil vers un autre emplacement.

    1. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

      Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    2. Localisez votre dossier de profil, comme expliqué plus haut.
    3. Allez à un niveau au dessus de votre dossier de profil, c'est à dire à %APPDATA%\Mozilla\Firefox\Profiles\~/Library/Application Support/Firefox/Profiles/~/.mozilla/firefox/
    4. Faites un clic droitMaintenez enfoncé la touche Ctrl pendant que vous cliquez sur votre dossier de profil (p.ex. xxxxxxxx.default) et sélectionnez Copier.
    5. Faites un clic droitMaintenez enfoncé la touche Ctrl pendant que vous cliquez sur la destination de sauvegarde (p.ex une clé USB ou un CD-RW vierge) et sélectionnez Coller l'élément.

    Restaurer une sauvegarde de profil

    1. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

      Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

    2. Si votre dossier de profil existant et votre sauvegarde de ce dossier ont le même nom, remplacez simplement le dossier de profil existant avec sa sauvegarde, puis redémarrez Firefox.
      Important : Les noms des dossiers de profil doivent avoir exactement le même nom pour cette action, incluant la chaîne aléatoire de huit caractères. Si les noms ne correspondent pas ou si vous restaurez une sauvegarde vers un emplacement différent, suivez les étapes ci-dessous.

    Restaurer vers un emplacement différent

    Si les noms des dossiers de profil ne correspondent pas ou si vous voulez déplacer ou restaurer un profil vers un emplacement différent, suivez ce qui suit :

    1. Fermez complètement Firefox comme expliqué ci-dessus.
    2. Utilisez le gestionnaire de profils pour créer un nouveau profil à l'emplacement voulu, puis quittez le gestionnaire de profils.
      Note : Si vous venez d'installer Firefox sur un nouvel ordinateur, vous pouvez utiliser le profil par défaut qui a été créé automatiquement quand vous avez lancé pour la première fois Firefox, au lieu de créer un nouveau profil.
    3. Localisez le dossier de profil sauvegardé sur votre disque dur ou autres (p.ex. une clé USB).
    4. Ouvrez la sauvegarde du dossier de profil (p.ex. la sauvegarde xxxxxxxx.default).
    5. Copiez le contenu entier de la sauvegarde du dossier de profil, comme les fichiers mimeTypes.rdf, prefs.js, le dossier bookmarkbackups, etc.
    6. Localisez et ouvrez le nouveau dossier de profil comme expliqué au dessus, puis fermez Firefox, s'il était ouvert.
    7. Placez le contenu du dossier de profil sauvegardé dans le nouveau dossier de profil, en remplaçant les fichiers s'ils existaient déjà.
    8. Démarrez Firefox.


    Partagez cet article : http://mzl.la/1xKrFsk

    Cet article vous a-t-il été utile ? Veuillez patienter…

    Ces formidables personnes ont aidé à écrire cet article : scoobidiver, dantidot, irahal. Vous pouvez également aider - découvrez comment.