Le plugin Adobe Flash a planté – empêcher que cela se reproduise

Le message « Le plugin Adobe Flash a planté » s'affiche quand le plugin Flash a cessé de fonctionner inopinément. Recharger la page suffit souvent pour faire fonctionner de nouveau la vidéo, le jeu ou l'animation.

Plugin crash notification
Plugin crash notification Fx21

Si le module Flash continue de planter, installer la version la plus récente du plugin peut souvent résoudre le problème. Cet article explique comment mettre à jour Flash et les autres solutions possibles.

Mettre à jour Flash

La dernière version du plugin Flash est généralement plus robuste et devrait planter moins souvent. Pour vérifier que votre version de Flash est la plus récente, visitez la page de vérification des plugins de Mozilla. Si cette page vous notifie que Flash a besoin d'être mis à jour, installez la dernière version manuellement en suivant la procédure ci-dessous.

  1. Rendez-vous sur la page Adobe de téléchargement du lecteur Flash et téléchargez le fichier d'installation de Flash.
    Avertissement : la page de téléchargement d'Adobe peut inclure une case cochée par défaut pour un logiciel facultatif tel que « Google Chrome » ou « McAfee Security Scan ». Si vous ne décochez pas cette case avant le téléchargement, ce logiciel sera installé sur votre ordinateur lors de l'exécution du fichier d'installation de Flash.
  2. Quand le téléchargement est terminé, fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. Ouvrez le fichier d'installation de Flash, puis suivez les instructions.
Note : si vous avez des problèmes avec le fichier d'installation de Flash récupéré depuis la page de téléchargement d'Adobe, vous pouvez utiliser ce lien vers le fichier d'installation de Flash pour télécharger directement l'installateur complet.
  1. Rendez-vous sur la page d'Adobe page de téléchargement du lecteur Flash et téléchargez le fichier d'installation de Flash.
  2. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. Ouvrez le fichier que vous avez téléchargé (c.à-d. install_flash_player_osx_intel.dmg).
  4. Dans le Finder, ouvrez Install Adobe Flash Player.app pour démarrer l'installation, ensuite suivez les instructions d'installation.
  1. Rendez-vous sur la page de téléchargement du lecteur Flash d'Adobe.
  2. Lorsque vous y êtes invité, enregistrez le fichier install_flash_player_"version"_linux."processor".tar.gz.
  3. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  4. Ouvrez une fenêtre Terminal (dans Gnome, cliquez sur le menu Applications, sélectionnez Accessoires, puis sélectionnez Terminal).
  5. Dans une fenêtre Terminal, rendez-vous dans le répertoire où vous avez enregistré le fichier téléchargé (p.ex. « cd /home/user/Downloads »).
  6. Extrayez libflashplayer.so du fichier que vous avez téléchargé avec la commande tar -zxvf install_flash_player_"version"_linux."processor".tar.gz.
  7. En tant que super utilisateur (sudo), copiez le fichier extrait, libflashplayer.so, vers votre sous-répertoire plugins de votre répertoire d'installation de Firefox. Par exemple, si Firefox est installé dans /usr/lib/mozilla, utilisez la commande « sudo cp libflashplayer.so /usr/lib/mozilla/plugins », puis entrez votre mot de passe de super utilisateur lorsque vous y êtes invité.

    0a85171f1802a3b0d9f46ffb997ddc02-1260326970-447-1.png

Comment désactiver l'accélération matérielle

De nombreux problèmes du plugin Flash peuvent être résolus en désactivant l'accélération graphique dans vos paramètres de Flash Player (la page Aide de Flash Player - Paramètres d'affichage d'Adobe a des détails). Pour désactiver l'accélération matérielle dans Flash :

  1. Allez à cette page d'aide d'Adobe Flash Player (anglais).
  2. Clic droit sur le logo Flash Player de cette page, puis cliquez sur Paramètres dans le menu contextuel. L'écran « Paramètres d'Adobe Flash Player » s'ouvre.

    fpSettings_FR.png
  3. Cliquez sur l'icône en bas à gauche de la fenêtre « Paramètres d'Adobe Flash Player » pour ouvrir le panneau d'affichage.
  4. Décochez Activer l'accélération matérielle.

    fpSettings1_FR.png
  5. Cliquez sur Fermer pour fermer la fenêtre « Paramètres d'Adobe Flash Player ».
  6. Redémarrez Firefox.

Désactiver le mode protégé de Flash

Vous pouvez désactiver l'exécution en mode protégé de Flash. Référez-vous aux instructions données par Adobe dans la partie "Last Resort" : Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox? (anglais)

Désactivez le mode protégé de Flash (anglais) en suivant ces instructions.
Avertissement : Le mode protégé qui est activé par défaut est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. Dans la barre d'adresse, saisissez about:config, puis appuyez sur EntréeRetour.

    • La page d'avertissement « Attention, danger ! » doit apparaître. Cliquez sur Je ferai attention, promis ! pour accéder à la page « about:config ».
  2. Recherchez dom.ipc.plugins.flash.disable-protected-mode dans la liste de préférences.
  3. Double-cliquez sur la préférence pour faire basculer sa valeur de false à true. (Si le paramètre est déjà à true, cela signifie que le mode protégé de Flash est actuellement désactivé.)
  4. Fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Redémarrez Firefox.

Désactivez l'exécution en mode protégé de Flash. Référez-vous aux instructions données par Adobe dans la partie "Last Resort" : Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox? (anglais)

Désactivez le mode protégé de Flash en suivant ces étapes.
Avertissement : Le mode protégé qui est activé par défaut est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. Dans la barre d'adresse, saisissez about:config, puis appuyez sur EntréeRetour.

    • La page d'avertissement « Attention, danger ! » doit apparaître. Cliquez sur Je ferai attention, promis ! pour accéder à la page « about:config ».
  2. Recherchez dom.ipc.plugins.flash.disable-protected-mode dans la liste de préférences.
  3. Double-cliquez sur la préférence pour faire basculer sa valeur de false à true. (Si le paramètre est déjà à true, cela signifie que le Mode Protégé de Flash est actuellement désactivé.)
  4. Fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Redémarrez Firefox.
  • Désactivez le mode protégé de Flash (anglais) en suivant ces étapes.
    Avertissement : Le mode protégé qui est activé par défaut est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. Dans la barre d'adresse, saisissez about:config, puis appuyez sur EntréeRetour.

    • La page d'avertissement « Attention, danger ! » doit apparaître. Cliquez sur Je ferai attention, promis ! pour accéder à la page « about:config ».
  2. Recherchez dom.ipc.plugins.flash.disable-protected-mode dans la liste des préférences.
  3. Double-cliquez sur la préférence pour basculer sa valeur de false à true. (si la préférence est déjà sur true cela signifie que le mode protégé de Flash est désactivé).
  4. Fermez Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Redémarrez Firefox.
  • Désactivez le mode protégé d'Adobe Flash en suivant ces étapes.
    Avertissement : Le mode protégé qui est activé par défaut est une caractéristique de sécurité d'Adobe Flash. La désactivation du mode protégé va réduire la protection de sécurité.
  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre. Cliquez sur le bouton menu New Fx Menu et choisissez Modules. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre.

  2. Dans l'onglet du « Gestionnaire de modules complémentaires », sélectionnez le panneau Plugins
  3. Trouvez Shockwave Flash dans la liste des plugins et cliquez sur Options.
  4. Décochez Activer le mode protégé d'Adobe Flash.
    Fx38-UI-AdobeFlash-protected-mode
  5. Fermer Firefox.

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  6. Redémarrez Firefox.

Autres solutions


Partagez cet article : http://mzl.la/14Ad7Md

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, hogren, irahal, fleurquin, J2m06, Konanoob. Vous pouvez également aider - découvrez comment.