Corriger le message d'erreur « Impossible de lancer le composant de sécurité de l'application »

Cet article traite des causes du message « Impossible de lancer le composant de sécurité de l'application ». La cause la plus probable est un problème avec les fichiers du répertoire des profils de votre application. Veuillez vérifier que ce répertoire n'a pas de restrictions de lecture/écriture et que votre disque dur n'est pas plein ou près de l'être. Il est recommandé de quitter l'application pour résoudre ce problème. Si vous continuez cette session, votre application risque d'avoir un comportement incorrect quant à l'utilisation du système de sécurité.

Pour des informations concernant d'autres messages reçus lorsque vous tentez de charger des sites web, consultez Les sites web ne se chargent pas – investiguer et corriger les messages d'erreur.

Note : La fonctionnalité de réinitialisation de Firefox peut corriger de nombreux problèmes en restaurant Firefox dans son état initial tout en conservant vos informations essentielles. Pensez à l'utiliser avant de commencer un long processus d'investigation.

Espace du disque dur

Vérifiez l'espace libre de votre disque dur.

  1. Depuis le menu « Démarrer » de Windows, cliquez sur Ordinateur ou Mon ordinateur.
  2. Faites un clic droit sur le disque local (C:).
  3. Choisissez Propriétés. Une boîte de dialogue s'affiche.
  4. Allez sur l'onglet Général.
  1. Allez sur votre bureau.
    • Appuyez sur F11.
  2. Sélectionnez Macintosh HD.
  3. Appuyez sur Cmd+I pour afficher la fenêtre d'informations Macintosh HD.
  1. Cliquez sur le menu Raccourcis et sélectionnez Ordinateur.
  2. Faites un clic droit sur Système de fichiers.
  3. Choisissez Propriétés. Une boîte de dialogue s'affiche.
  4. Allez sur l'onglet Standard.

S'il signale moins d'1 Mo d'espace libre disponible, vous devrez faire de la place.

Droits sur fichier

Vérifiez les droits sur fichier dans votre dossier de profil. Le fichier nommé cert8.db ne doit pas être en lecture seule.

  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Faites un clic droit sur le fichier nommé cert8.db.
  6. Choisissez Propriétés. Une boîte de dialogue s'affiche.
  7. Allez sur l'onglet Général.
  8. Assurez-vous que la case En lecture seule n'est pas cochée.
  9. Appuyez sur OK.
  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Sélectionnez le fichier nommé cert8.db.
  6. Appuyez sur Cmd+I pour afficher la fenêtre d'informations cert8.db.
  7. Agrandissez la section « Partage & autorisations ».
  8. Assurez-vous que votre compte utilisateur Mac est réglé sur Lire et écrire.
  9. Fermez la fenêtre d'info cert8.db.
  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Faites un clic droit sur le fichier nommé cert8.db.
  6. Choisissez Propriétés. Une boîte de dialogue s'affiche.
  7. Allez sur l'onglet Autorisations.
  8. Assurez-vous que Accès est réglé sur lire et écrire.
  9. Appuyez sur Fermer.

Redémarrez Firefox et le problème est peut-être résolu.

Fichier corrompu

Le fichier cert8.db dans votre dossier de profil peut avoir été corrompu. Supprimez ce fichier pendant que Firefox est fermé.

  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Cliquez sur le fichier nommé cert8.db.
  6. Appuyez sur Cmd+Suppr.
  7. Redémarrez Firefox.
cert8.db va être recréé quand vous redémarrerez Firefox. C'est normal.

Nouveau profil

Vos paramètres peuvent avoir été corrompus à cause des changements dans votre système ou d'un manque d'espace sur le disque dur. Créez un nouveau profil avec le gestionnaire de profils. Si le problème s'en va, vous pouvez ensuite déplacer vos paramètres vers le nouveau profil. Si le problème persiste, vous pouvez revenir à votre profil d'origine.




Basé sur des informations de Could not initialize the applications security component (mozillaZine KB)



Partager cet article : http://mzl.la/N6hG6N

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : scoobidiver. Vous pouvez également aider - découvrez comment.