Comment s'abonner aux flux de nouvelles et blogs

Note : cet article concerne Thunderbird 52 et versions ultérieures.

Les sites web ont la possibilité de publier du contenu à télécharger par des applications en utilisant au choix le protocole RSS ou Atom. Ce type de contenu est communément appelé « flux d'actualités », « flux RSS » ou « syndication ». Ces flux sont très fréquemment utilisés par les blogs, mais de nombreux sites traditionnels utilisent aussi cette méthode. Lorsque vous vous abonnez aux flux d'un site, les mises à jour sont automatiquement vérifiées par votre agrégateur d'actualités (par exemple, Thunderbird) et les articles téléchargés localement.

Lorsque vous utilisez Thunderbird pour gérer vos flux, vous pouvez utiliser la même présentation et les mêmes les outils (archives, filtres, recherches, etc.) dont vous avez l'habitude pour gérer votre messagerie.

Étape 1 : Créer un compte de flux

Vous devez d'abord créer un compte Thunderbird pour vos flux.

1. Dans la barre de menus, cliquez sur Fichier > Nouveau > Compte de flux… La fenêtre Assistant de compte de flux apparaît.

2. Saisissez un nom pour votre compte de flux dans la case Nom du compte, puis cliquez sur le bouton Suivant

3. Cliquez sur le bouton Terminer. Votre nouveau compte apparaît maintenant dans le volet des dossiers de Thunderbird.

Étape 2 : Abonnez-vous à des flux

Ensuite, choisissez le flux auquel vous souhaitez vous abonner.

1. Utilisez votre navigateur web pour ouvrir un site web auquel vous souhaitez vous abonner. La plupart des sites et des blogs qui sont régulièrement mis à jour ont des flux d'actualités.

2. Recherchez une icône usuelle RSS ou un lien texte sur le site. Sur la plupart des sites, le lien apparaît en bas ou sur le côté de la page d'accueil.

icon_flux_rss.png icon_flux_rss_2.png

3. Effectuez un clic droit sur le lien RSS et copiez l'adresse du lien (si vous utilisez Mozilla Firefox ou Chrome, cliquez sur Copier l'adresse du lien dans le menu contextuel).

flux_rss_lien_xml3
Note : sur certains grands sites Web, le lien RSS de la page d'accueil n'est pas un flux en soi, mais un lien vers un ensemble de flux fournis par le site. Par exemple, un site de presse peut avoir différents flux pour ses actualités, les sports et les rubriques de divertissement. Dans ce cas, il faut cliquer sur l'icône RSS de la page d'accueil, puis exécuter l'étape 3 sur la page qui présente tous les flux proposés par le site.

4. Dans Thunderbird, cliquez sur votre compte de flux dans le volet des dossiers.

5. Cliquez sur Gérer les abonnements

6. Dans la case Adresse du flux, faites un clic droit et collez l'adresse du lien du site.

7. Cliquez sur le bouton Ajouter. Thunderbird va vérifier le lien, créer un nouveau dossier, enregistrer un lien valide dans ce nouveau dossier et télécharger tous les articles actuellement disponibles. Le nouveau dossier apparaît sous votre compte RSS dans le volet des dossiers.

flux_rss_lien_xml4.png

8. Les flux peuvent également être ajoutés rapidement par glisser-déposer des liens depuis un navigateur vers le dossier de votre compte de flux ou n'importe quel dossier de ce compte, directement dans le volet des dossiers. Si un nouveau dossier est créé, le nom du dossier est déduit du titre du flux.

NOTE : Thunderbird va valider les liens des nouveaux flux et vous laisser vérifier que la syntaxe dans un flux existant est conforme au protocole. Pour les flux déjà ajoutés, cliquez sur le lien Valider dans la fenêtre Abonnements aux flux. Si un flux n'est pas validé dans Thunderbird (par exemple, si c'est une page web), il pourrait cependant apparaître comme correct dans le service de validation. Ceci est dû au fonctionnement du service qui essaie de trouver un lien valide. Vérifiez que le lien utilisé par le service est le même que le lien entré dans Thunderbird (une page web peut comporter plus d'un lien de flux RSS ; le service utilisera le premier trouvé).

Étape 3 : Lire vos Flux

La lecture et la gestion de vos flux est aussi facile que l'utilisation de votre messagerie dans Thunderbird.

1 Cliquez sur le bouton Relever pour télécharger les messages les plus récents des flux, ainsi que vos courriers électroniques. Si vous faites un clic droit sur un dossier spécifique et sélectionnez Relever, seuls les messages correspondant aux abonnements de ce dossier (et de tous ses sous-dossiers) seront récupérés.

2. Dans le volet des dossiers, cliquez sur le flux souscrit ayant le contenu que vous souhaitez lire. Une liste de messages non lus du flux s'affiche dans le volet de la liste de messages.

3. Cliquez sur un des messages dans la liste.

4. Lisez l'article dans le corps du message. Si vous voulez voir l'article sur le site, cliquez sur le lien dans l'en-tête de message à côté de Site web (ceci ouvrira le lien dans votre navigateur par défaut).

flux_rss_lien_xml7.png

5. Vous pouvez aussi voir l'article dans un nouvel onglet en double cliquant sur le message ou en appuyant sur la touche Entrée lorsqu'un message est sélectionné dans la liste. Les options se trouvent dans Message > À l'ouverture des messages de flux

Note : vous pouvez également choisir de deux manières différentes si votre message s'affiche sous la forme d'un résumé de l'article ou comme l'article complet :
  • Dans la fenêtre d'abonnements aux flux, sélectionnez le dossier des flux et cochez Afficher le résumé de l'article plutôt que de télécharger la page web. Cette préférence s'applique à tous les flux du dossier.
  • Sélectionnez un message dans la liste des messages, puis cliquez sur Affichage > Corps de message du flux, et choisissez Format par défaut (réglage du dossier ci-dessus), ou remplacez la valeur par défaut et affichez Résumé ou Page Web globalement.
Dans Outils > Paramètres des comptes, sélectionnez le nom de votre compte de flux et décochez la case Par défaut, afficher le résumé de l'article plutôt que de télécharger la page web. C'est la sélection par défaut pour tous les nouveaux abonnements à des flux qui créent un dossier dans ce compte.

Étape 4: Organiser et gérer vos flux

Dossiers et comptes

Vous pouvez créer des dossiers de type courriel pour grouper les flux individuels :

1. Dans le volet des dossiers, cliquez sur le nom de votre compte de flux pour le sélectionner.

2. Cliquez sur Fichier > Nouveau > Dossier. La boîte de dialogue Nouveau dossier apparaît.

3. Saisissez un nom pour votre nouveau dossier, puis cliquez sur Créer le dossier. Pour créer des sous-dossiers dans vos dossiers, sélectionnez d'abord le dossier que vous souhaitez utiliser comme dossier parent, puis cliquez sur Fichier > Nouveau > Sous-dossier

4. Vous pouvez également organiser vos flux en créant des comptes de flux supplémentaires. Il suffit de répéter l'étape 1 pour chaque compte que vous voulez créer, en donnant à chacun un nom différent. Les comptes multiples sont moins utiles maintenant que sont disponibles les intervalles de mise à jour par flux.

Note : un sous-dossier de compte de flux peut contenir zéro, un, ou plusieurs abonnements. En outre, une seule URL unique de flux peut être souscrite par compte.

La boîte de dialogue Abonnements aux flux

1. Depuis le volet des dossiers, il est facile d'aller directement à la gestion des flux en faisant un clic droit et en sélectionnant S'abonner…

2. La boîte de dialogue s'ouvre avec le dossier sélectionné et ouvert, montrant les flux d'abonnements du dossier.

3. Les URL des flux peuvent être glissées-déposées directement dans cette boîte et organisées comme bon vous semble. Par exemple, il est utile d'avoir un flux de blog et ses flux de commentaires dans le même dossier (les éditeurs peuvent même construire leur flux pour que les articles soient reliés ensemble dans un fil de discussion comme pour le courrier électronique !).

Note : le déplacement ou la suppression d'un abonnement de flux RSS à partir d'un dossier n'affectera pas les articles déjà téléchargés. Si vous supprimez un abonnement, la liste des éléments actuellement actifs sera également nettoyée. En conséquence, une nouvelle souscription à l'URL d'un flux provoquera un nouveau téléchargement de messages déjà téléchargés. La suppression d'un dossier ou son déplacement dans la corbeille désinscrit automatiquement tous les flux de ce dossier.

Mises à jour

À partir de la version 54 de Thunderbird, l'intervalle de mise à jour de chaque flux peut être choisi séparément. Si la case Vérifier la présence de nouveaux articles n'est pas cochée, le flux sera « en pause ». Si tous les flux d'un dossier sont « en pause , le dossier est en pause et apparaîtra plus transparent. Un dossier peut aussi être placé en pause ou hors pause par le menu contextuel — le statut s'appliquera à tous les flux du dossier. Le compte entier peut également être mis en pause (sans que cela ne modifie l'état de pause d'un flux spécifique).

Vous pouvez toujours obtenir des mises à jour immédiates en cliquant le bouton Relever même si un compte ou un dossier est placé en pause.

Marquage automatique

Si l'éditeur ajoute des balises <category> pour alimenter les éléments de ses flux, vous pouvez choisir de marquer automatiquement les articles avec ces valeurs. À chaque valeur de la balise <category> correspondra une étiquette de mot-clé dans Thunderbird. Un élément de flux peut avoir de nombreuses balises <category>.

1. Dans la boîte de dialogue Abonnements aux flux, sélectionnez le flux et cochez la case Créer automatiquement des étiquettes depuis les noms des balises <category> du flux.

2. Vous pouvez également ajouter un préfixe personnalisé pour mieux différencier les étiquettes.

Les balises sont stockées dans les en-têtes Keywords: (selon la norme RFC5322) pour la portabilité. Elles sont également marquées par le système interne de Thunderbird et stockées dans l'en-tête X-Mozilla-Keys: de l'article. En conséquence, les étiquettes apparaîtront dans l'en-tête du message et permettront de travailler avec les filtres rapides, filtres de messages et règles de recherches de balises.

Importer et exporter vos flux RSS

1. Si vous avez une liste des URL de flux exportés au format OPML dans un fichier, peut-être d'un autre lecteur de flux, vous pouvez les importer en utilisant Outils > Importer > Abonnements à des flux. Choisissez Nouveau compte ou Blogs et nouvelles.

2. Vous pouvez également importer en utilisant la boîte de dialogue Abonnements aux flux, en sélectionnant le dossier, et en cliquant sur Importer

3. Pour exporter, sélectionnez le compte de flux (en haut de dossier) dans la boîte de dialogue Abonnements aux flux et cliquez sur le bouton Exporter. La structure et les préférences de vos flux seront enregistrées dans un fichier .opml. (Pour exporter une liste simple, appuyez sur la touche Ctrl puis cliquez sur Exporter.)

Conseils

  • Pour marquer rapidement comme lus tous les messages d'un dossier de flux, pour qu'ils n'apparaissent plus en gras, appuyez sur la touche MAJ + C lorsque le dossier de flux est sélectionné.
  • Pour régler la fréquence de vérification des nouveaux messages et les autres propriétés par défaut des flux pour les nouveaux abonnements seulement, cliquez sur Outils > Paramètres des comptes ou Édition > Paramètres des comptes, puis cliquez sur le nom de votre compte de flux. Choisissez les valeurs dans la section Paramètres par défaut pour les nouveaux flux.
  • La conservation des articles est gérée comme pour les courriers électroniques. Cliquez sur Espace disque sous le nom du compte dans la fenêtre Paramètres des comptes Courrier et Groupes pour plus d'options.
  • Utilisez la barre d'outils Filtre rapide pour gagner du temps si vous recevez beaucoup de messages à partir d'un flux.
  • Si vous souhaitez utiliser des filtres de messages sur les messages de flux et trier par site, créez un en-tête personnalisé nommé Content-base. Cet en-tête contient le lien vers le site de flux.
  • Des articles de flux peuvent être placés dans le « nuage » en mettant en place un filtre pour copier ou déplacer des éléments dans un dossier de compte IMAP. Cela ne le synchronisera en aucune façon, mais peut être utile dans certains cas. Le bogue de filtre pour activer cette fonctionnalité a été corrigé dans Thunderbird 38.

Astuces pour les rédacteurs

  • La spécification Atom est fortement recommandée. Si vous utilisez la spécification RSS2.0, la balise <guid> est recommandée. De même, les balises <title> et <link> sont requises par la spécification et le flux sera rejeté si elles ne sont pas présentes. Une autre erreur courante est de représenter les caractères unicode en octal. Assurez-vous que les dates sont codées selon la spécification choisie ; de mauvaises dates peuvent provoquer le rejet d'items. Veuillez toujours suivre les spécifications et valider pour que tout le monde y gagne.
  • L'en-tête Last-Modified (dernière modification) devrait être renvoyé dans la réponse de votre serveur. Thunderbird enverra cette valeur dans If-Modified-Since (si modifié depuis) lors de la prochaine requête à votre serveur, à laquelle vous pouvez répondre avec le code 304 si c'est approprié. S'il n'y a pas de nouveaux éléments ou changements dans votre fichier, cela économisera l'utilisation de la bande passante et du temps de calcul.
  • Si vous utilisez Atom et son extension Threading, Thunderbird regroupera les éléments relatifs au flux (tels les commentaires sur un article) dans des fils de discussion comme il le fait pour les courriers électroniques liés.
  • Les changements des URL de flux peuvent être détectés par Thunderbird et mis à jour automatiquement pour les utilisateurs. Consultez le Bug 304917 (en anglais) pour découvrir les deux méthodes pour le faire.
  • Nouveau dans Thunderbird 54 : une fréquence de mise à jour recommandée par l'éditeur est montrée à l'utilisateur dans la fenêtre Abonnements aux flux si les balises pertinentes sont incluses dans votre flux. Suivez la spécification sur la syndication pour prévenir de la fréquence de mise à jour souhaitée.

Astuces avancées

  • La fréquence de mise à jour des flux dans Vérifier les nouveaux articles devrait être paramétrée de façon à minimiser l'utilisation de la bande passante et la taille du processus Thunderbird, si l'éditeur n'utilise pas la balise Last-Modified décrite ci-dessus. Si cette balise est utilisée, un message Il n'y a aucun nouvel article pour ce flux. est affiché immédiatement dans la barre d'état lorsqu'on demande la mise à jour des nouveaux messages à deux instants très rapprochés.
  • Une URL de flux peut être ajoutée sans être connecté à Internet ; l'ajout en mode hors-ligne ignorera la validation du flux. Dans ce mode (pour passer en hors-ligne, cliquez sur l'icône dans la barre d'état), une boîte de dialogue apparaît et demande de passer en mode connecté pour récupérer les nouveaux messages. Ignorez la demande, le flux sera ajouté. Le titre du flux sera par défaut l'URL et pourra être édité ultérieurement. Une fois en ligne, Thunderbird peut échouer à récupérer le flux si l'URL ou la syntaxe sont invalides, mais il sera présent dans la base de données.
  • Nouveau dans Thunderbird 54 : les utilisateurs avec vraiment beaucoup de flux ont la possibilité de choisir le nombre limite de flux traités simultanément en réglant la préférence « rss.max_concurrent_feeds ». Par défaut, cette valeur est 25.
  • Nouveau dans Thunderbird 54 : les dossiers de flux qui contiennent une URL d'abonnement en erreur (serveur non joignable, fichier de flux non trouvé, erreur de certificat, etc.) sont signalés par une icône. Ouvrez la fenêtre Abonnements aux flux, choisissez le flux, sélectionnez l'URL du flux et cliquez le bouton Vérifier pour vérifier l'existence de problèmes de type réseau.
  • Thunderbird a des logs détaillés (journal des connexions) pour l'activité des flux, visible dans Outils > Console d'erreurs. Réglez le paramètre Feeds.logging.console à debug ou trace (et redémarrez) pour voir les détails du traitement du flux.

FAQ des dysfonctionnements

Q. Pourquoi les messages de flux sont-ils parfois dupliqués ?

R. Les messages de flux avec du contenu identique mais des identifiants différents ne sont pas détectés comme dupliqués. Consultez ce forum pour bien plus de détails.

Q. Lors de la consultation d'une page web de flux, pourquoi le navigateur s'ouvre-t-il ou une page quelconque se charge-t-elle dans le navigateur ?

R. Comme Thunderbird n'a pas été conçu pour être un navigateur web, il envoie toutes les requêtes de liens à votre navigateur par défaut. Dans ce cas, le script sur la page web du flux tente d'ouvrir un lien. La meilleure solution est d'installer l'extension Adblock Plus. En plus d'avoir des filtres intégrés efficaces, Adblock Plus vous permet de configurer les URL personnalisés ou les domaines qui doivent être bloqués. Consultez le Bug 524281.

Q. Pourquoi ne puis-je pas voir certains documents, images, vidéos ou d'autres contenus inclus lors de l'affichage d'un résumé de flux ?

R. Ceci est dû à la désactivation de JavaScript pour les messages (courriers électroniques, messages sur des groupes de discussion, résumés de flux). La demande d'implémentation d'une option configurable par l'utilisateur pour activer Javascript, pour les résumés de flux uniquement, est disponible ici : Bug 456481.

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy, Banban, J2m06, Macbetha, YD. Vous pouvez également aider - découvrez comment.