Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The print function on websites doesn't work in Firefox.

  • 14 پاسخ
  • 202 have this problem
  • 199 views
  • آخرین پاسخ توسّط wteague

more options

I want to print information from a certain website by selecting the Print View button. That works. But when I select the Print function, nothing happens. In other words, Firefox has stopped printing from websites. Other print functions (such as Word 2007) work just fine.

All Replies (14)

more options

Please give us a few specific example web pages where you're having that problem. I clicked ten different links here - http://www.ed.gov/ - and didn't find one page with a Print Preview function. Sorry, I am not willing to look through an entire website looking for Print Preview buttons.

Modified by the-edmeister

more options

Chosen Solution

more options

Thanks for this set of troubleshooting notes for Firefox printing issues. The first one in the list fixed my problem -- resetting the print.print_printer in "about:config."

Somehow, the latest updates for Firefox must have had a teeny bug that turned this item to "off," but I'm just guessing here.

What a helpful bunch you-all are!

more options

To the-edmeis...

My description was unclear. The Print Preview function is on the Firefox file dropdown menu. Doesn't matter -- printing wasn't happening from there or from the Print button frequently available on websites of all sorts.

cor-el's solution worked!

I appreciate your quick attention.

more options

I can print from web pages using mic explorer but not from Firefox. I get a message that I need to download the web page to my documents with the file name xps and type of file as XPS Document.xps. I have been previously been able to print from web pages but when I downloaded 3.6.13 I have not bee able to print from a web page I have uninstalled Firefox and reinstalled but still no ability to print from a web page

Modified by bkwiller

more options

You either don't have your Printer selected or you have Print to File selected.

http://kb.mozillazine.org/Problems_printing_web_pages

more options

Thank you ,I did not have the correct printer selected

more options

You're welcome.

more options

For some of us less tech aware:

I got no help from MOZ but found a solution

I tried to uninstall from the firefox unilstall got the same result.

I just uninstalled from Windows control panel then searched the computer for mozilla files, all of them including HIDDEN files and deleted all of them except the administrator required ones.

Then I installed a new version.

Presto.

Remember to save your bookmarks before doint this.

more options

Same problem, could not print web page. Deleted HP Smart Web Print program. Print function worked after removal. Firefox 4 Beta 8

Modified by orbis.rh

more options

I'mhaving a similar problem. Up until a few days ago Firefox was working fine, but the past few days I cannot print from some websites. eg. I log into TD Waterhouse WebBroker, load their Action Reports on various companies, and everything looks good on screen. But when I try to print a selected report (say 3 pages out of 25 or 40 or 60 pages) the printer simply feeds through a blank sheet and stops. I can print from other websites eg. the Brain Aneurism Foundation, and can print from TD Waterhouse using Safari. I checked with TD Waterhouse support; they say they find Mac OS X so unreliable they don't support it! Looks like something has gone4 haywire in a recent FireFox update??

more options

Yes, it might be a "bug" in a recent Firefox update. You might try the solution that worked for me -- at the top of this thread, the link from cor-el to the kb.mozillazine. It involved a very simple adjustment to a printing setting. If I could do it, anyone could!

more options

worked like a charm! Thank you.

more options

I just ran into this problem on Firefox 4. I could not Print or Print Preview. The solution to my problem was to remove the add on "HP Smart Web Printing 4.60" that had been added without my awareness. Also, then I had to remove any and all other Print addons, restart Firefor a couple of times, deleted the current Cache in Firefox and my %temp% directory - and then it started to work again. The "about:config." method might have worked, but I hadn't seen that suggestion yet. Clearly there are some bugs in Firefox 4's print sections.