Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to suppress the "no style associated" warning when viewing XML files?

  • 2 respuestas
  • 6 tienen este problema
  • 37 visitas
  • Última respuesta de smoore716

more options

The default text/xml type handler displays XML as a nice tree, but there is this annoying message on top of the page: "This XML file does not appear to have any style information associated with it. The document tree is shown below."

Is there any way to suppress it while still using the default tree view? Thanks.

The default text/xml type handler displays XML as a nice tree, but there is this annoying message on top of the page: "This XML file does not appear to have any style information associated with it. The document tree is shown below." Is there any way to suppress it while still using the default tree view? Thanks.

Todas las respuestas (2)

more options

Hello! That's not a message that can be toggled, it's part of the tree-view page, like the "Support Forum" label above your post. :) It's just informing you that you're viewing the source of the XML file because it's not styled with CSS, and it's the same behaviour Google Chrome has with such files. Hope it helps anyway!

more options

I want to view an XML file attached to an e-mail in the XML format in a Firefox tab. The e-mail is forwarded to Thunderbird on my Win PC from a Super Backup Android app on my Smartphone. But when I click it in the e-mail, expecting to see a nicely formatted, HTML-like page view in a Firefox tab, all I see is the document tree view - w/ the msg you list. So is there an XML style Add-on (CSS, other styles?) which causes Firefox to display the file in a user-friendly format? Is there another way to accomplish this w/out an add-on? Hope you have the decoder ring for this puzzler. Thanks.

Modificadas por smoore716 el