Showing questions tagged: Show all questions

Compatibility: an increasing number of websites and features do not work in Firefox on Linux

I believe everyone has a right to choose the browser and operating system they use. I choose to use Firefox because I care about my privacy, and because of features like … (read more)

I believe everyone has a right to choose the browser and operating system they use. I choose to use Firefox because I care about my privacy, and because of features like multi-account containers - as a software developer these are non-negotiable. I choose to use Linux for similar reasons, and many Linux distributions come with Firefox preinstalled as a default browser. In light of recent changes to Google's data collection through Chrome, I am more than ever committed to using Firefox as my only browser.

However over the last year or so, I have noticed an increasing number of websites or features on websites have stopped working in Firefox on Linux, forcing me to use Chrome against my wishes. Examples include the entirety of the Australian government's MyGov website; the phone call feature in Slack; and Google Meet meetings (no audio). I know people who use Firefox on other operating systems and they have not had these problems, so I can only assume that the issue is specific to Firefox on Linux.

I am not trying to suggest that Mozilla is responsible for this in any way - if Google or Slack or the government refuse to support Firefox on Linux, that's their responsibility, not Mozilla's. However, I am not convinced that the lack of support is intentional, or that it isn't a quirk of the particular Linux distribution I use or the version of Firefox included in the package manager. Any advice would be appreciated.

My Firefox version is 84.0.1, and my Linux distribution is KDE Neon User Edition 5.21 which uses Ubuntu 20.04 under the hood.

Asked by loathgrim 2 days ago

Last reply by tjn21 3 hours ago

FireFox is schizophrenic! How do I stop it from switching languages on my PC?

I have just had my PC updated to Win 10 at a neighborhood PC shop here in Germany. But now I can't get all the screens to speak in English. I have placed a check-marke … (read more)

I have just had my PC updated to Win 10 at a neighborhood PC shop here in Germany. But now I can't get all the screens to speak in English. I have placed a check-marke on several Menus that ask for a language preference. But it doesn't seem to help. What I have been getting when Mozilla opens up with a split screen is, one screen is in English and the other is in German. I suspect the cause for this is because my e-mail address has a '.de' at the very end, which is Germany. So It looks to me like there is a s/w problem at your end. The s/w keeps looking at my address, instead of the screens where I have asked it to write to me in the English language. Is there a fix for this problem yet? Or must I wait some more before it get's fixed.

Asked by warp4dennis 12 hours ago

Last reply by cor-el 3 hours ago

Firefox Blocking Video Playback

I am working in an online class and we are asked to record videos in an online platform for school. When I go to hit the play button on anyone's video I get an error mess… (read more)

I am working in an online class and we are asked to record videos in an online platform for school. When I go to hit the play button on anyone's video I get an error message. This does not happen in other browsers, but I want to keep using Firefox. Is there a privacy or cookie setting that could be causing this to happen?

Asked by marion.reader42 1 day ago

Last reply by cor-el 3 hours ago

Chat window does not open

Hi, when I'm on pages where I need to chat with customer service, Firefox has stopped opening the chat tab / window. I click on "chat" but no one happens. Nothing opens a… (read more)

Hi, when I'm on pages where I need to chat with customer service, Firefox has stopped opening the chat tab / window. I click on "chat" but no one happens. Nothing opens and no message pops up is stopped. Why does it happen like this all of a sudden? I have not made any changes to settings.

Asked by 20tassar 16 hours ago

Last reply by milosagastume11 4 hours ago

Recent Activities

Hi, I just downloaded the Firefox on my galaxy S6 device. It is a great browser and its really fast. I am having a problem of history from last week that many of the webs… (read more)

Hi, I just downloaded the Firefox on my galaxy S6 device. It is a great browser and its really fast. I am having a problem of history from last week that many of the website didn't show in history. Mostly I use Facebook , pintrest and ihomedental a. I am unable to see my recent activities, Can anyone guide me the solution?

Asked by juliamicheal975 14 hours ago

Last reply by milosagastume11 4 hours ago

Can't leave a website?

The absolute weirdest problem. If I'm on the Brita website (brita.com) and type in another url to navigate away, I press enter, and it just refreshes the same page I was … (read more)

The absolute weirdest problem. If I'm on the Brita website (brita.com) and type in another url to navigate away, I press enter, and it just refreshes the same page I was on. This happens across the brita.com domain, regardless of what url I type in, even if I type the full url (including https://www.), and if I click a search or url suggestion in the dropdown, even in a private window, anything. This has never happened to me with any other website.

Obviously I can just close the tab and open another, but this is strange enough I figured I'd see if anyone could figure it out (or at least replicate my experience). I would appreciate any insights!

Asked by pandacantante 1 day ago

Last reply by ·´¯`·...¸>-)))º> ~dbben 10 hours ago

Firefox mutes video after pausing or scanning

On a number of sites (YouTube, Twitch, Netflix, etc), after pausing and resuming a video or jumping to a new timestamp, the video will play but be muted. The video player… (read more)

On a number of sites (YouTube, Twitch, Netflix, etc), after pausing and resuming a video or jumping to a new timestamp, the video will play but be muted. The video player does not show it is muted, but no sound is playing. Jumping to another timestamp or using a keyboard shortcut to jump a couple of seconds will resume audio playback. This started happening within the last few days. Any ideas on how to fix this would be appreciated

Asked by DJ 10 hours ago

VPN problem

Hi, I downloaded a express VPN on my system, but it is not working smoothly. Sometimes websites are not loading and showing the error of page is not found. facebook, appl… (read more)

Hi, I downloaded a express VPN on my system, but it is not working smoothly. Sometimes websites are not loading and showing the error of page is not found. facebook, apple.com and some of pages like thoughts on volcano hybrid in these websites and pages, in these pages and website I am facing the problem continuously, Kindly guide me the solution of this problem.

Asked by jenifer.jj748 15 hours ago

can't sign in to one of my google accounts, but I can on another

one of my google accounts, which I have been able to sign in through firefox for years, suddenly started giving me an error message after entering my email address on the… (read more)

one of my google accounts, which I have been able to sign in through firefox for years, suddenly started giving me an error message after entering my email address on the google sign in page. I have another google account and I'm able to sign i using firefox just fine. The error message given is:

This browser or app may not be secure. Learn more Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.

I'm using a windows 7 box and Firefox 85.0.2.

I'm able to sign in just fine when I use google chrome. I've cleared cache and data in the browser. I'm not sure what else to try. Any suggestions? Any other information I can provide to help identify the problem?

Asked by vseavello 21 hours ago

Last reply by FredMcD 16 hours ago

Unable to log in to Charles Schwab website

For at least the last 2 months I have had issues trying to log in to Charles Schwab, at either of these pages- https://client.schwab.com/Login/SignOn/CustomerCenterLogin.… (read more)

For at least the last 2 months I have had issues trying to log in to Charles Schwab, at either of these pages-

https://client.schwab.com/Login/SignOn/CustomerCenterLogin.aspx https://www.schwab.com/public/schwab/client_home

I use Firefox to save my login and after completing the user and login fields and clicking "Log in" the login/password fields go blank and I get this error message in red-

"Feature temporarily unavailable"

Clearing cookies and cache, re-starting browser and entering password manually do not help. I can login just fine using Internet Explorer. I also can log in outside of business hours (late evening) after 2 or 3 tries, also can log in on a different PC with Firefox (configured the same).

I have the following plugins- uBlock, DuckDuckGo Privacy Essentials and Ghostery- all of which are disabled for Schwab domains (schwab.com, client.schwab.com, lms.schwab.com).

Schwab's technical support figure there is something going wrong with Firefox but are unable to figure it out.

Any ideas? Thanks for helping.

Asked by mk869 2 days ago

Last reply by cor-el 1 day ago

"Security Error: Your session has been invalidated" https website doesn't load

Following website "https://www.hellobank.fr" is unreachable either in normal or private windows. There is another report but it is pretty old for now. https://support.mo… (read more)

Following website "https://www.hellobank.fr" is unreachable either in normal or private windows.

There is another report but it is pretty old for now. https://support.mozilla.org/en-US/questions/1025002

So I just want to understand is there is anything new since this post or do I have to apply a more efficient solution that removing user.js I don't want to take the risk of spoiling up my setup.

Asked by Clément 1 day ago

Last reply by cor-el 1 day ago

  • Solved

Video bug on older version of firefox!

So i downgraded to Firefox 55 and i like it. But i hate 1 thing, there is a green line when i watch a YouTube video on my downgraded Firefox. It is on the bottom of the s… (read more)

So i downgraded to Firefox 55 and i like it. But i hate 1 thing, there is a green line when i watch a YouTube video on my downgraded Firefox. It is on the bottom of the screen, Somebody help me to get rid of the green line?

Asked by Bosko Laska 3 weeks ago

Answered by Bosko Laska 1 day ago

  • Solved

I cannot get to youtube

I cannot get to youtube. I get this screen in the screenshot then it redirects to https://googleads.g.doubleclick.net/ads/preferences/cu/optout?continue=aHR0cHM6Ly9jb25zZ… (read more)

Asked by GardenSurfer 4 days ago

Answered by GardenSurfer 3 days ago

  • Solved

Some Form Text Boxes On Website Do Not Appear Using Firefox

I use a website (u-bill.com) to access my Product and Account information for software I purchased. To find my purchase I need to enter my email address and 1 of 3 other … (read more)

I use a website (u-bill.com) to access my Product and Account information for software I purchased. To find my purchase I need to enter my email address and 1 of 3 other items of information: Last 4 digits of CC; Order ID Nr; or Password. I am able to enter my email address but the text boxes for the other 3 do not appear. This only happens when I use Firefox as it is my preferred browser. I am able to enter the information in the form using Chrome. A search of possible fixes suggested disabling "hardware acceleration". I tried that and it did not work. Today was the first time I tried to access this information although I have had the account for 1 year so I do not know if Firefox ever was able to access it. I am using Firefox V 87.0 (64 Bit) and Windows 10. Here are two screen shots: #1 is the form using Firefox. #2 is the form using Chrome.

Asked by bruceburns12 2 days ago

Answered by ·´¯`·...¸>-)))º> ~dbben 1 day ago

My website is not showing the proper layout on the reading text window!

Hey There, I just started a blog Related to Digital Marketing, named Graphic Design Eye. and just got notified by one of my users that my website preview is not the same … (read more)

Hey There,

I just started a blog Related to Digital Marketing, named Graphic Design Eye. and just got notified by one of my users that my website preview is not the same in the reading text window by Google Chrome. Can anyone suggest any edits?

Thanks in advance

Asked by georgiajack62 1 week ago

Last reply by jonzn4SUSE 1 week ago

css issue - after firefox update

Hello, after an update the css is presented incorrectly. I tried on other devices, still the same. In chrome is working fine. I did not make any changes in the code. It w… (read more)

Hello, after an update the css is presented incorrectly. I tried on other devices, still the same. In chrome is working fine. I did not make any changes in the code. It was working and after the update i am facing css problems related with (display: flex) and (display:inline-table). Will it be fixed with an update?

I have uploaded two images (the correct and the problem)

Asked by ntinos 1 day ago

Last reply by jscher2000 1 day ago