Showing questions tagged: Show all questions

Slow Firefox

System: MSI B640 Tomahawk. I5 10600KU 32GB RAM Video: MSI 3070 X3 System Drive: 250GB fast Samsung SSD, with 50% free. System OS: W10Pro_x64 21H1, Defender, no Firewall,… (read more)

System: MSI B640 Tomahawk. I5 10600KU 32GB RAM

Video: MSI 3070 X3

System Drive: 250GB fast Samsung SSD, with 50% free.

System OS: W10Pro_x64 21H1, Defender, no Firewall, no extra AV. Firefox_93.0_x64

Network: TYPE: Dedicated FIBER LAN Provider: Telenet Account Type: FIBER_200 Plus +


Addons: Adblock + µblock FBPurity Block Sender New Tab Override Cookie Manager and Cookie quick Manager Auto-High-Quality for youtube Ant Downloader Video Downloadhelper Cute Save Button WebP Image Converter Translate Web Page

Additional Information: Open Pinned Tabs: In between 25 and 60, depending on my current activities.

Tried: Disabling each add-on until all were off. Safe Start. Nothing helps.

Understandings: 1) No browser is made to run up to 60 open tabs (possibly even more)!!! 2) I run a "plethora" (compared to most users) if add-ons; these also bring the use speed down. 3) Resource used: 2GB (with "mere 30 pages" open.

BUT: DESPITE that: I ALSO understand that, considering my system and Network Type, it should not even be problematic with 200 pages open at once. 2GB over 32GB of RAM? Not the slightest issue (and it often runs at 4GB RAM in use). My CPU never runs half high, even when I have like 60 pages open: Should not be an issue then either. My Video Card has plenty resource over as well when at highest for me usage." Again, it should be no issue. My Fiber Netware? Telenet BVBA, Mechelen Test results: Ping: 5ms Jitter: 2ms Download: 904.2 Mbps Upload: 038.3 Mbps Not the best, not the worst, but for simple browsing, more than, I would assume, plenty.

So, what gives, what is the issue? No extreme strain on the system, no background high-resource issues, sure: one or two add-ons in Firefox but these as well do not strain my system, no AV issues, no Firewall issues (I turned that off, I fail to get the need for one as a house-dog-tree user), yet slow performance. Also, while 30'ish tabs running, 2GB used of RAM? My my, what the hell do they do as Site Admins to have these amounts (and NO, I do not do porn, thank you.  :P I am well aware of other people having insane issues surfing porn, as I helped many of these folks)? Sure, Deviant is a larger one that is open, being a graphical site, but like Quora, FB, Hot- and G-Mail and similar, these ain't, so to get a 2GB usage is weird, I would assume. I said, assume: yes, I am not specifically an internet know-all, I know of networking as a former NOVEL Netware Supervisor under UNIX (also Spupervisor), but Networking in a company is not the same as internet.

So, what is going on, why is my browser so slow? Having turned of all and 1 page open it's lightning fast, but now ... So, it is the open tabs, and the add-ons, though when turned off, I see no real difference. Brings it to tabs. How come, it is this "heavy", even for my system, please?

Thank you. Xog.

Asked by Xogroroth 1 week ago

Last reply by Xogroroth 6 days ago

Browser isn't opening up at all! Quickly shutting off and asking to report crash!

I have used Firefox on Tues, but starting yesterday I am unable to open the browser at all. I uninstalled and reinstalled multiple times and haven't had any success. I re… (read more)

I have used Firefox on Tues, but starting yesterday I am unable to open the browser at all. I uninstalled and reinstalled multiple times and haven't had any success. I recently end tasked Cortana. Is that why I can't open the browser? Or is it something else. Please help. Nothing online seems to work for me. Mind you I can open and use other browsers. Thank you in advance.

      • i get no other explanation from firefox. just the crash reporter popup and maybe a "do you want to refresh" popup.

Asked by confused__user 6 days ago

Last reply by confused__user 5 days ago

BSOD DRIVER POWER STATE FAILURE

I am using a Cambio W101 tablet with windows 10 21H1 and Firefox 93.0. After getting the BSOD with the error message DRIVER POWER STATE FAILURE I followed the recommen… (read more)

I am using a Cambio W101 tablet with windows 10 21H1 and Firefox 93.0.

After getting the BSOD with the error message DRIVER POWER STATE FAILURE I followed the recommended suggestions like checking the drivers, removing the sleep mode, changing the power options.

I continue to get the BSOD only in one specific situation but frequently. It is when I use Libreoffice as my active window, while Firefox is inactive in the background. When I use either only Libreoffice or only Firefox as my active window nothing happens. There has also not been problems with other programs.

Does an inactive Firefox do something which triggers the BSOD?

Asked by walumg 5 days ago

Last reply by walumg 5 days ago

Frequent page crashes on a variety of sites

Here are some crash report IDs: bp-b62fab6a-df71-4382-bea5-d03050211024 bp-91a966b5-2a88-4712-b169-8f8dc0211024 bp-b8403004-faf3-4e38-a07d-201230211024 bp-666b6fbf-ecf4-4… (read more)

Here are some crash report IDs:

bp-b62fab6a-df71-4382-bea5-d03050211024 bp-91a966b5-2a88-4712-b169-8f8dc0211024 bp-b8403004-faf3-4e38-a07d-201230211024 bp-666b6fbf-ecf4-4085-9ac8-58dae0211024

Asked by sglenn06 3 days ago

Last reply by sglenn06 3 days ago

Firefox 93: I can't even type!

Ever since I updated, typing has become incredibly challenging... There's big delays in the words showing up, letters come out in the wrong places, & it doesn't impro… (read more)

Ever since I updated, typing has become incredibly challenging... There's big delays in the words showing up, letters come out in the wrong places, & it doesn't improve even when I clear cache, clear memory, & refresh pages. I don't know what else to do. Should I delete and re-install Firefox, or replace this with the previous version?

Asked by StevenCee 1 week ago

Last reply by StevenCee 4 days ago

ADobe Acrobat default PDF changed

The oddest thing happened today. Maybe not that odd based on other posts. I've always had Adobe Acrobat as my default PDF reader. For whatever reason, this afternoon, it … (read more)

The oddest thing happened today. Maybe not that odd based on other posts. I've always had Adobe Acrobat as my default PDF reader. For whatever reason, this afternoon, it changed itself back to FF reader. I don't know how that happened. One moment it was working fine and then it wasn't. I reset it back to Adobe. Any explanation as to why it would change itself? Thanks

Asked by arejfour 6 days ago

Last reply by arejfour 2 days ago

I am constantly getting a bar at the top of the screen saying "Mozilla is not responding"...

I am constantly getting a notice at the top of the screen that says "Mozilla is not responding". It all stalls and then eventually, Mozilla apparently starts to respond a… (read more)

I am constantly getting a notice at the top of the screen that says "Mozilla is not responding". It all stalls and then eventually, Mozilla apparently starts to respond and it goes to the page I choose. I have kept up with all the updates and am not a huge online person in the first place. Why does this happen? It is so often, I am tempted to change browsers.

Asked by meandsinger2010 2 days ago

Last reply by meandsinger2010 2 days ago

Twitter video/gifs showing as black screen (audio works fine)

Only on Firefox (not Chrome, for example) animated gifs and videos on Twitter will not display -- they instead show a black screen. When paused or not yet played, there i… (read more)

Only on Firefox (not Chrome, for example) animated gifs and videos on Twitter will not display -- they instead show a black screen. When paused or not yet played, there is a visible image, but as soon as I press play, it goes to black. The audio on a video will play just fine, but the screen/image is still black.

I have checked my graphics drivers for updates and they are all up-to-date. Also the gifs/videos play just fine if I use Chrome.

Firefox is up to date. I'm on v 93.0 (64-bit).

Asked by ghelfrich 2 days ago

Last reply by ghelfrich 1 day ago

Firefox not playing any audio whatsoever

Hello. Starting yesterday, Firefox has stopped playing audio from every website and even local files. Yes, I read this article and no, the sound is not being muted instea… (read more)

Hello. Starting yesterday, Firefox has stopped playing audio from every website and even local files. Yes, I read this article and no, the sound is not being muted instead the sound just refuses to play. In the screenshot, it shows that the "play" "mute" and speed option are greyed out. Also, I tried using safe mode and audio still wouldn't play. What should I do?

Asked by Computer 22 hours ago

Last reply by Computer 48 minutes ago

Slow printing on Mac

Printing pages from firefox browser to my printer is extremely slow. I followed troubleshooting steps including shutting off print preview in firefox. I posted a bug repo… (read more)

Printing pages from firefox browser to my printer is extremely slow. I followed troubleshooting steps including shutting off print preview in firefox. I posted a bug report but haven't received any further assistance.

Asked by egutwillig 6 days ago

save dialog spawning active finder extension every time it gets called

Hi there Whenever I use the open/save dialog all the active "Finder extensions" spawn a child process even if they already have one running. I'm not sure this is a Firefo… (read more)

Hi there

Whenever I use the open/save dialog all the active "Finder extensions" spawn a child process even if they already have one running. I'm not sure this is a Firefox bug or a macos (api) bug. I have the Betterzip and Graphicconverter Extensions active. This seems to have started with version 92 and/or 93. In the beginning everything seems alright, but after a while the finder/system begins to beachball for 20-30 seconds. When I then try to quit firefox the whole system becomes unresponsive and I have to power-off with the switch.

This is with the latest macos 11.6 and FF 93.

Kind regards,

Dhark01

Asked by dhark01 4 days ago

Website is no more responsive Using HPElite Book On Firefox.

Hey There, My Website is Working Perfectly fine over the Dell Series on all the browsers but not Performing well on HPELIte Book Using Firefox. https://cpsandtypingtest.c… (read more)

Hey There, My Website is Working Perfectly fine over the Dell Series on all the browsers but not Performing well on HPELIte Book Using Firefox. https://cpsandtypingtest.com/speed-roller-checkerAnyone from the team can look into this guide or solution.

Asked by asadrazamr4567 4 days ago

VA-API support in Firefox Snap

In 21.04, I was able to successfully enable VA-API support for Firefox for hardware video acceleration using my amdgpu on Wayland. Mainly, following steps from https://ub… (read more)

In 21.04, I was able to successfully enable VA-API support for Firefox for hardware video acceleration using my amdgpu on Wayland. Mainly, following steps from https://ubuntuhandbook.org/index.php/2021/08/enable-hardware-video-acceleration-va-api-for-firefox-in-ubuntu-20-04-18-04-higher/

Since upgraded to 21.10 which uses snap version by default, I've noticed increased CPU usage when playing youtube videos. When I checked by running Firefox from command line, I can see that I can't seems to open vaapi driver correctly:

$ /snap/bin/firefox Importing existing firefox profiles from /home/ymchen/.mozilla/firefox Found default profile: dhjf4r7r.default-1587103347891 Import done in 3.141 s amdgpu: os_same_file_description couldn't determine if two DRM fds reference the same file description. If they do, bad things may happen! libva info: VA-API version 1.7.0 libva info: Trying to open /snap/firefox/631/gnome-platform/usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so libva info: va_openDriver() returns -1 libva info: VA-API version 1.7.0 libva info: Trying to open /snap/firefox/631/gnome-platform/usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so libva info: va_openDriver() returns -1

Installing firefox from apt, I can see that vaapi still works:

$ /usr/bin/firefox libva info: VA-API version 1.12.0 libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so libva info: Found init function __vaDriverInit_1_12 libva info: va_openDriver() returns 0 libva info: VA-API version 1.12.0 libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so libva info: Found init function __vaDriverInit_1_12 libva info: va_openDriver() returns 0 libva info: VA-API version 1.12.0

Curiously, VA-API version available in snap version is older 1.7.0 compared to the apt installed version 1.12.0. Perhaps the "packaged" version of the dependencies in snap version is outdated?

I've also noticed that the file /snap/firefox/631/gnome-platform/usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so does not exist.

Any idea how to get Firefox snap to work with VA-API? Thanks

Asked by fusion82 3 days ago

Audio & Video Playback

Whenever I have a tab playing any form of audio, and another different tab begins playing audio, both tabs will stutter/pause for about a second, and block each other mom… (read more)

Whenever I have a tab playing any form of audio, and another different tab begins playing audio, both tabs will stutter/pause for about a second, and block each other momentarily. This is especially noticeable whenever I use something like Discord, where the constant pings will frequently interrupt my YouTube video. Even when I mute the Discord tab, it still causes my YouTube video to stutter and pause.

I have tried deleting Firefox completely, and removing all old add-on/extensions, preferences, %appdata% files, etc., and nothing works. I don't get this issue at all when using Chrome or Edge, so I'm having a hard time understanding why this is happening. Many years ago, back when I first used Firefox, I never encountered this issue.

Now that I re-downloaded Firefox this last year, I've had this annoying issue without any way to remove it. I'm quickly approaching my wit's end trying to solve this issue. I have asked a few friends who use Firefox, and none of them have this issue. All the guides from this site so far have proves unhelpful in trying to resolve my issue. If you could help out, please let me know!

Asked by EliteWolfHunter 3 days ago

CPU spike while typing in other app

Recently notice CPU spikes while: - i type text in other apps - and it feels like firefox captures my input - not using firefox directly, it just run by itself without an… (read more)

Recently notice CPU spikes while:

- i type text in other apps
- and it feels like firefox captures my input
- not using firefox directly, it just run by itself without any load
- and this spikes happens only when firefox is runs, when closed all fine
- same thing with waterfox which uses the same codebase confirming

that the issue is related.

Asked by 0sPAcU 3 days ago

DNS Timeout for autopush.prod.mozaws.net in Windows 10 Event Log

An error reoccurs in the Windows 10 Event Log every 15 minutes. What could be causing this? Details: Source: DNS Client Events Event: 1014 Level: Warning User: NETWORK SE… (read more)

An error reoccurs in the Windows 10 Event Log every 15 minutes. What could be causing this?

Details: Source: DNS Client Events Event: 1014 Level: Warning User: NETWORK SERVICE General Details: Name resolution for the name autopush.prod.mozaws.net timed out after none of the configured DNS servers responded.

Asked by Frank R. Pollard, Jr. 2 days ago

MS Windows 10, Firefox v.18.5.0.0 - "Changes not Saved. An unexpected error has prevented your changes from being saved."

Sorry, I suspect this is an often asked question, but after endless searching on this site, and trying many old solutions, I still can not create, save, and use a User Pr… (read more)

Sorry, I suspect this is an often asked question, but after endless searching on this site, and trying many old solutions, I still can not create, save, and use a User Profile. [See uploaded photo]

First, when I explore my C:\Users\Bud Parker\AppData\Roaming\Mozilla\Firefox\Profiles folder I find empty folders named for the many times I have attempted to recreate a usable Firefox profile. There is no JSON File or anything else in any of the folders. Hence, it appears I cannot save a created profile. Of course, if it isn't saved in the appropriate location - I'm dead in the water.

I tried saving one on my Desktop and using it, all to no avail. In past, I've run some aggressive maintenance programs cleaning up Windows, but I could always enter Firefox. Of course, that does not mean it didn't finally occur...

By the way, I can use a Portable version of Firefox, just not an installed version. I completely uninstalled Firefox and reinstalled it with the current version. Still nothing.

So, now I ask the Mozilla Brain Trust for assistance. Let me say in advance that I appreciate you reading and thinking about this,

Bud

Asked by Bud 2 days ago

FF93 incredibly slow on each initial page load

As above. I don't really keep track of versions but it's at v93 right now and only this week started to perform extremely slowly with regards to the initial loading of ~9… (read more)

As above. I don't really keep track of versions but it's at v93 right now and only this week started to perform extremely slowly with regards to the initial loading of ~90% of the pages I visit, even cached and frequented sites. Once past that it performs as normal. Speedtesting is fine but Browserbench results are horrendous. (This is my first time running this test so I don't have a previous FF result to compare with.)

FF93: 59.497 Chrome95: 119.820 Edge95: 117.970

https://imgur.com/a/qw3CWI0

Already tried: clearing site data and cache, incognito, safe mode, and of course cutting addons to a minimum.

Currently installed: AdBlock Plus Dark Reader Don't Accept image/webp Facebook Container ffCK Overlays uBlock Origin View Image Ressurected YouTube NonStop

Can someone advise what else can be done or what is going on please? I've been faithful to FF for over a decade and have all my bookmarks, history and credentials saved to this account. However if this is going to be the user experience moving forward - then all I can say is I will not be joining the declining Firefox user base. W10, i5-9400f, 32GB ram, wired CAT6 + 1Gbit Fibre.

Asked by nicky9499 13 hours ago