Showing questions tagged: Show all questions
  • Solved
  • Archived

High CPU Usage in a separate process in task manager

I have been using firefox for more than 4 years now. But from about a year, i m facing the issue with the Sudden High CPU usage in Windows task manager. The task manager… (read more)

I have been using firefox for more than 4 years now. But from about a year, i m facing the issue with the Sudden High CPU usage in Windows task manager.

The task manager has 2 different firefox processes. One being actual instance i am running. and the 2nd being the automatically opened in background.

i have figured out whenever i have active internet connection and my system is on charging the 2nd task automatically starts in background and uses upto 80% of cpu usage. Ending the 2nd task form task manager doesn't affect anything. only the cpu usage drops. Also Closing my firefox instance does nothing to that 2nd task.

I have tried lot of solutions i found on community. Nothing seems to help. problem still persist. I even posted comments on ongoing threads. but no reply from anywhere.

this is the last time i m trying. if i get a solution its good. otherwise i am going to shift to edge. I have no other choice.

Screenshots from multiple dates are attached.

Asked by Kj 1 year ago

Answered by Kj 9 months ago

  • Solved
  • Archived

How to add Help => About Firefox in Firefox home page

Hi, Firefox is great but is there a way to add the Help => About Firefox webpage in Firefox home page? This is to simplify Firefox updates. Because although Firefox… (read more)

Hi,

Firefox is great but is there a way to add the Help => About Firefox webpage in Firefox home page? This is to simplify Firefox updates. Because although Firefox downloads updates, you still need to activate Help => About Firefox to update the Firefox version.

In Chrome you can add this to home page: chrome://settings/help and when you open Chrome it goes to this page and updates itself.

Does Firefox have the same capabilities so that we don't need to wait on users to click on Help => About Firefox to update Firefox?

Thanks and regards,

QB

Asked by qb941g 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Firefox blocks pop-ups from a website that has an exception for pop-ups.

I have a website that open pop-ups automatically using javascript. That is the expected behaviour of it. So I went into Firefox options and made an exception for that sit… (read more)

I have a website that open pop-ups automatically using javascript. That is the expected behaviour of it. So I went into Firefox options and made an exception for that site. If I go to the site and wait so it can do its thing, it opens about a few of them, and then Firefox decides that the rule I have set up is garbage, and firefox decides to ignore it and block the pop-ups from the site.

Why?

Why on Earth does Firefox decides that he must do something against the rule that the user has set up. Why does it have this completely disrespect to the user settings?

I am honestly really mad at whoever decided that ignoring an exception from the user was the default behaviour.

Now, if someone knows enough what is going on they will tell me, go to about:config, go to this obscure command and change its value, value which I can't know without coming here and ask. If I create an exception, then I am in my right to expect that the browser should do exactly as the exception has been configured.

By the way I have tried with the troubleshooting mode and still happens.

Asked by mail1729 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

toolbar text vanished, can't get text OR icons back

I'm on the ESR and just updated from 112.0.2 to 113.0.1. I had text rather than icons displayed on my toolbar. Now the text has vanished and I can't find a way to get t… (read more)

I'm on the ESR and just updated from 112.0.2 to 113.0.1. I had text rather than icons displayed on my toolbar. Now the text has vanished and I can't find a way to get text OR icons back. I have a disabled extension Classic Theme Restorer installed, but I thought it was already disabled long ago. In the Customize Toolbar dialog, the unused icons are displayed with text labels. When I drag one to the toolbar, it turns invisible like all the rest.

Asked by gsknick 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Unable to sign into mail after latest update 113.0.1 Windows 10

Message We are unable to process your request at this time Please try again in 1 hour Have tried rebboted laptop run windows defender offline scan. Does not work on any… (read more)

Message We are unable to process your request at this time Please try again in 1 hour

Have tried rebboted laptop run windows defender offline scan. Does not work on any of my accounts Same problem in Chrome and Edge!

Asked by jas_samrauk 1 year ago

Answered by jas_samrauk 1 year ago

  • Solved
  • Archived

Active tab is NOT visible

With the dark mode of Firefox on Windows 10 desktop it is IMPOSSIBLE to see which of the several tabs is the one that is open. I work with tabs not windows as I always n… (read more)

With the dark mode of Firefox on Windows 10 desktop it is IMPOSSIBLE to see which of the several tabs is the one that is open.

I work with tabs not windows as I always need to see all the pages/websites open that I work with in one view, and so it is a hassle and nuisance NOT to be able to tell which tab is active, having to click through each one or guess.

It's one of those small yet significantly impacting on the user experience things which one would have thought by now Firefox developers would fix.

The ACTIVE tab needs to be in different colour may be on a yellow background with dark font so that people can EASILY find it with several tabs open on the screen.

Any thoughts on this? is there perhaps an option to enable it - which I am oblivious to?

thanks

Asked by etcetera777 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Firefox crashes when trying to log into websites

For the past few weeks, Firefox has started crashing when logging into various websites. I've updated Firefox, cleared cookies etc, reinstalled Firefox, opened it in Trou… (read more)

For the past few weeks, Firefox has started crashing when logging into various websites. I've updated Firefox, cleared cookies etc, reinstalled Firefox, opened it in Troubleshooting mode, updated my OS, disabled extensions... everything I can think of. After some sleuthing, it seems to only happen when trying to log into a website. Doesn't happen on every site, which is weird.

This is so frustrating, please help!

Asked by Jeff 1 year ago

Answered by Jeff 1 year ago

  • Solved
  • Archived

Can't get to about.config

When I type about.config in the address bar, I just see search results for it, instead of going to the config page. I tried enabling a separate search bar in settings, a… (read more)

When I type about.config in the address bar, I just see search results for it, instead of going to the config page. I tried enabling a separate search bar in settings, and also turned off all suggestions, but that did not help. I still see the spyglass search icon on the address bar. How do I get past it?

Asked by joelkfla 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Importing non-csv passwords

Hello. My laptop died and according to IT is "gone". My hard disk however can still be accessed. I was able to access my firefox profile data from the old hard disk, and … (read more)

Hello. My laptop died and according to IT is "gone". My hard disk however can still be accessed. I was able to access my firefox profile data from the old hard disk, and I was able to find the two firefox password files (key4.db and logins.json), as described in https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data. However, when I use the procedure described in https://support.mozilla.org/en-US/questions/1416465 to import the passwords on my new firefox on my new laptop, it does not work: firefox tries to look for a csv file, but there is none: I only have the "raw" db and json files, because i never had the opportunity to "export" my pwds as a csv file. Is there a way to import pwds from one version of firefox (the one running on my dead machine) to another copy of firefox (the one running on my new machine), if those pwds have not been previously "exported" as csv files by the "original" firefox/machine? thank you!

Asked by alexandros4 9 months ago

Answered by cor-el 9 months ago

  • Solved
  • Archived

Can't unblock popup

Hi, I seem to having multiple problems with Firefox over the last few weeks... This problem is - I can't unblock popups. I have got popup blocking enabled, with a coupl… (read more)

Hi,

I seem to having multiple problems with Firefox over the last few weeks...

This problem is - I can't unblock popups. I have got popup blocking enabled, with a couple of Exceptions - it's been working fine until I wanted to use it today. I have tried turning off popup blocking, re-entering the exceptions - nothing is helping!!!

Does anyone know what to do?

Thanking you Pedro

Asked by PedroSMS 1 year ago

Answered by Terry 1 year ago

  • Solved
  • Archived

Keeper extension for Firefox

I cannot install the Keeper extension for firefox on version 113.0.1. I get an error "Download failed. check your connection". I have successfully installed the extensi… (read more)

I cannot install the Keeper extension for firefox on version 113.0.1. I get an error "Download failed. check your connection". I have successfully installed the extension on other browsers on the same desktop computer, and on Firefox earlier versions on other computers at home.

Asked by joewvicars 1 year ago

Answered by jonzn4SUSE 1 year ago

  • Solved
  • Archived

High memory and cpu usage for just opening the browser

I been having problems with firefox using up most of my cpu while browsing some websites and it doesn't even load as fast as before. This has been happening for a few day… (read more)

I been having problems with firefox using up most of my cpu while browsing some websites and it doesn't even load as fast as before. This has been happening for a few days now. Prior to this, firefox was fine and loading pretty quick, but these last few days have been painful.

Thinking that was a small bug, i restarted my computer. Before opening the firefox again, I opened up task manager to check how much resources will the browser be using. Before that usage would be normal and not even close to high, but opening firefox and waiting a few seconds to let the home window appear, the task manager showed that it was using all of it still.

I browsed some other help questions on this website and disabled "Use recommended performance settings", because that was one of the solutions on one of the relevant questions. But even that didn't do reduce resource usage either. Is there any way to fix this or will I have to suck it up and suffer with slow loading?

Asked by Rude Red 1 year ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

Blank bar at bottom of window on 113 version

On 112, I had my css set up to make the status bar hidden and only show the url path when I moused over it in the lower left corner of the window. It also cut itself shor… (read more)

On 112, I had my css set up to make the status bar hidden and only show the url path when I moused over it in the lower left corner of the window. It also cut itself short to only the length of the url similar to the www.wikipedia.org box in the attached picture. After upgrading to 113, my browser has this black bar at the bottom. When I cleared out my css file, urls would show up in the bar when I moused over them. I've tried a few different css fixes but none of them will get it back to how I had it working in 112. The picture attached is what I'm getting in 113 right now with the css below. the black bar below the mouse over url goes all the way across the window and is always visible. Here is my current css file:

radiogroup:focus-visible > radio[focused="true"] > .radio-label-box {

outline: 1px dotted black !important;

}

:root{ --toolbar-field-focus-border-color: transparent !important; }

:root{ --uc-titlebar-padding: 10px; }

@media (-moz-os-version: windows-win7),(-moz-os-version: windows-win10){

:root[sizemode="maximized"][tabsintitlebar]{ --uc-titlebar-padding: 8px }

}

#toolbar-menubar[autohide="true"] > .titlebar-buttonbox-container,

#TabsToolbar > .titlebar-buttonbox-container{

position: fixed;

display: block;

top: var(--uc-titlebar-padding,0px);

right:0;

height: 40px;

}

/* Mac specific. You should set that font-smoothing pref to true if you are on any platform where window controls are on left */

@supports -moz-bool-pref("layout.css.osx-font-smoothing.enabled"){

:root{ --uc-titlebar-padding: 0px !important }

.titlebar-buttonbox-container{ left:0; right: unset !important; }

}

:root[uidensity="compact"] #TabsToolbar > .titlebar-buttonbox-container{ height: 32px }

#toolbar-menubar[inactive] > .titlebar-buttonbox-container{ opacity: 0 }

#navigator-toolbox{ padding-top: var(--uc-titlebar-padding,0px) !important; }

.titlebar-buttonbox-container > .titlebar-buttonbox{ height: 100%; }

#titlebar{

order: 2;

-moz-appearance: none !important;

--tabs-navbar-shadow-size: 0px;

}

#unified-extensions-button{

display: none !important;

}

.titlebar-placeholder,

#TabsToolbar .titlebar-spacer{ display: none; }

/* Also hide the toolbox bottom border which isn't at bottom with this setup */

#navigator-toolbox::after{ display: none !important; }

@media (-moz-gtk-csd-close-button){ .titlebar-button{ -moz-box-orient: vertical } }

/* These exist only for compatibility with autohide-tabstoolbar.css */

toolbox#navigator-toolbox > toolbar#nav-bar.browser-toolbar{ animation: none; }

#navigator-toolbox:hover #TabsToolbar{ animation: slidein ease-out 48ms 1 }

/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/tabs_on_bottom_menubar_on_top_patch.css made available under Mozilla Public License v. 2.0

See the above repository for updates as well as full license text. */

/* Menubar on top patch - use with tabs_on_bottom.css */

/* Only really useful if menubar is ALWAYS visible */

:root:not([sizemode="fullscreen"]){ --uc-window-control-width: 0px !important }

:root{

/* height if native titlebar is enabled, assumes empty menubar */

--uc-menubar-height: 22px;

}

:root[tabsintitlebar]{

/* height when native titlebar is disabled, more roomy so can fit buttons etc. */

--uc-menubar-height: 22px;

}

#navigator-toolbox{ padding-top: calc(var(--uc-menubar-height) + var(--uc-titlebar-padding,0px)) !important }

:root[sizemode="fullscreen"] #navigator-toolbox{ padding-top: 0px !important; }

#toolbar-menubar{

position: fixed;

display: flex;

top: var(--uc-titlebar-padding,0px);

height: var(--uc-menubar-height);

width: 100%;

overflow: hidden;

}

#toolbar-menubar > .titlebar-buttonbox-container{ height: 100%; order: 100; }

#toolbar-menubar > [flex]{ flex-grow: 100; }

#toolbar-menubar > spacer[flex]{

order: 99;

flex-grow: 1;

min-width: var(--uc-window-drag-space-width,20px);

}

#toolbar-menubar .titlebar-button{ padding: 2px 17px !important; }

#toolbar-menubar .toolbarbutton-1 { --toolbarbutton-inner-padding: 3px }

/* Status-bar */

#main-window:not([inFullscreen="true"]) > body::after{

display: -moz-box;

content: "";

height: 20px;

border-top: solid 0px #505050;

}

.browserContainer>statuspanel { left: 4px !important; bottom: 0px; transition-duration: 0s !important; transition-delay: 0s !important; }

.browserContainer>statuspanel>.statuspanel-inner>.statuspanel-label { margin-left: 0px !important; border: none !important; padding: 0px !important; }

window[inFullscreen="true"] #browser-bottombox { display:none !important; }

window[inFullscreen="true"] .browserContainer>statuspanel[type="overLink"] .statuspanel-label { display:none !important; }

#statuspanel #statuspanel-label {

-moz-appearance: none !important;

border: 0px solid black !important;

}

Asked by drogers4114 1 year ago

Answered by drogers4114 1 year ago

  • Solved
  • Archived

Adblocker plus

I have adblocker plus and is not blocking my facebook ads. (I am using it on my iMac). So I removed it, then reinstalled it and it still does not block the facebook ads. … (read more)

I have adblocker plus and is not blocking my facebook ads. (I am using it on my iMac). So I removed it, then reinstalled it and it still does not block the facebook ads.

I tried refreshing firefox 3 times but it got stuck in the "almost done" part and I had to quit firefox each time since it would not complete the process.

What else can I do?

Thanks, Martha

Asked by mpoinar1 1 year ago

Answered by TyDraniu 1 year ago

  • Solved
  • Archived

The address wasn’t understood (webpack)

Please excuse me if I miss any details.... this is my third time trying to submit this issue. I will just skip to the meat of it this time. I'm getting this error while… (read more)

Please excuse me if I miss any details.... this is my third time trying to submit this issue.

I will just skip to the meat of it this time. I'm getting this error while working from my localhost. I have been working on a personal project for years with this set up with no issues until today. I can no longer click on the errors in the console log and be directed to the Debugger tab. When I click on errors, nothing happens. If I try to open them in a New Tab, I get the error below:


The address wasn’t understood

Firefox doesn’t know how to open this address, because one of the following protocols (webpack) isn’t associated with any program or is not allowed in this context.

   You might need to install other software to open this address.


I have also noticed firefox does not even load all the files until I refresh it at least twice. Even when it is all loaded properly, the error persists.

I have tried: - restarting firefox - restarting my computer - clearing ALL cache and cookies - running firefox in safe mode - disabling all add ons - disabling performance mode (was already off) - checking network.protocol-handler.external.javascript = false (it is)

Let me know if there is any other information I can provide. I really dislike having to work in chrome for this so I hope I can find a solution as soon as possible.

Asked by iamshi 1 year ago

Answered by iamshi 1 year ago

  • Solved
  • Archived

Missing "Send Tab to Device" button on linux

When I right click a tab I do not get the option to "Send Tab to Device" that I am used to on Windows. Is this missing from the Linux version? Or is there a setting for i… (read more)

When I right click a tab I do not get the option to "Send Tab to Device" that I am used to on Windows. Is this missing from the Linux version? Or is there a setting for it?

I have searched the internet for this problem and could not find such things. I would appreciate any help!

Asked by info3416 1 year ago

Answered by info3416 1 year ago

  • Solved
  • Archived

Imported Passwords Not Showing In Firefox Under "Saved Logins" After Resetting PC

Hi, I've imported around 200+ passwords from another web browser as '.csv file' in Firefox from option of 'import from a file.' During the import, I was logged into my… (read more)

Hi,

I've imported around 200+ passwords from another web browser as '.csv file' in Firefox from option of 'import from a file.'

During the import, I was logged into my Firefox account as well.

But, after resetting PC, I downloaded the Firefox and logged on with my Firefox account, and there are only 29 passwords showing up, rest of the passwords are not there.

And, now I do not have access to that .csv file as well.

I am on Windows 11 and had reset my PC with option to 'Keep My Files' so there is no data loss as per my side or on the hard disk drive.

Please help me to get those passwords back. They are extremely important to me.

Thanks in advance!

Asked by Karan 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago

  • Solved
  • Archived

Twitter videos getting darker and with wrong colours when I fullscreen them. Same happen for all the videos on youtube (fullscreen and normal size)

Since the last Firefox update (I'm now using Firefox 113.0.1 64bit on Windows 11) when I play a video on Twitter, it plays with the right colors until I fullscreen it. Wh… (read more)

Since the last Firefox update (I'm now using Firefox 113.0.1 64bit on Windows 11) when I play a video on Twitter, it plays with the right colors until I fullscreen it. When I fullscreen it, the video becomes darker and the colors are wrong.

  • The same happens to youtube videos (both fullscreen or normal size): the colors are not right and they looks darker.
  • The same problem happens using both my laptop's internal monitor and the external monitor.
  • I tried to reinstall Firefox but it didn't fix it.
  • I also tried to take a screenshot of the "wrong colors" videos using the Windows screenshot tool but the output image is displayed with the right colors and not with the darker ones.
  • Using Chrome the colors are correct and I never had this problem before the last Firefox update.

Asked by Guloma 1 year ago

Answered by TyDraniu 1 year ago

  • Solved
  • Archived

113.0.1 Has Issues

Prior to Version 113.0.1 I had No problems with all my web sites. Now, I have major issues. From not being able to log on to having to close the browser totally because F… (read more)

Prior to Version 113.0.1 I had No problems with all my web sites. Now, I have major issues. From not being able to log on to having to close the browser totally because Firefox won't allow me to go back to the site's home page. I know this accurate as I can log on to the sites via Safari and No problems and the sites work correctly.

Asked by thboo 1 year ago

Answered by jscher2000 - Support Volunteer 1 year ago