Showing questions tagged: Show all questions

Prevent websites to use dark theme

Hello, I know this question is probably somewhere here but I can't find the answer (what I tried below). So, I have a Debian 10 computer, with Firefox 78.15.0esr. I'm usi… (read more)

Hello,

I know this question is probably somewhere here but I can't find the answer (what I tried below).

So, I have a Debian 10 computer, with Firefox 78.15.0esr. I'm using the Adwaita (dark version) theme on my OS.

The problem is that Firefox uses the dark theme in Its menus (I don't mind) but It transmits to websites this setting and thus, websites supporting dark mode use it (Google, DuckDuckGo for example). I don't like that. I want them to use the light mode but keeping my theme on my OS.

So, I tried to change the value to 0, 1, 2, 3 (I tried each for them) for the setting layout.css.prefers-color-scheme.content-override and put "Adwaita:light" in the widget.content.gtk-theme-override field in about:config. Each time I restarted Firefox. It never works, websites still continue to use the dark theme...

Thanks in advance

Asked by Dimitri 1 month ago

Last reply by Terry 1 month ago

Firefox Nightly

Hello, Can you please tell me how to downgrade Firefox Nightly to Firefox Stable Release channel on Linux Ubuntu. When I try to exchange the firefox versions in the snap … (read more)

Hello,

Can you please tell me how to downgrade Firefox Nightly to Firefox Stable Release channel on Linux Ubuntu. When I try to exchange the firefox versions in the snap store of Ubuntu I seem to loose my whole data stored in Firefox.

Thanks.

Best NR

Asked by NR 3 weeks ago

Last reply by Kiki 2 weeks ago

How to set homepage favicon for my site?

The bookmark and tabs show my favicon but the firefox empty landing page does not show my favicon. Instead it shows a generated icon... What do I need to do to make favic… (read more)

The bookmark and tabs show my favicon but the firefox empty landing page does not show my favicon. Instead it shows a generated icon...

What do I need to do to make favicon show?

I have this in my head

``` <link rel="icon" href="/static/favicon.png" /> <link rel="apple-touch-icon" sizes="128x128" href="/static/favicon.png" /> <link rel="manifest" href="/static/manifest.json" crossorigin="use-credentials" /> <link rel="shortcut icon" type="image/png" href="https://fuckedweb3.com/static/favicon.png" /> <link rel="icon" type="image/png" sizes="32x32" href="/static/favicon.png" /> <link rel="image/x-icon" size="32x32" type="image/x-icon" href="/favicon.ico" /> ```

Asked by anthony85 1 day ago

Last reply by techguy150 22 hours ago

after last update the yt permanently paused

after last update of ff, the yt videos are paused. when press a start button or a space bar the video playing for a fraction of second and stops again. if holding a space… (read more)

after last update of ff, the yt videos are paused. when press a start button or a space bar the video playing for a fraction of second and stops again. if holding a space bar longer the video is chopped is start - stop pieces. my system manjaro linux ( Linux 5.15.78-1-MANJARO (x86_64) ). ff version 107.0 (64-bit) thanks in advance Lukas

Asked by lukas_0 11 hours ago

Last reply by jonzn4SUSE 3 hours ago

  • Archived

why is the "find-in-page" function broken? (random occurence. reload may solve it. restart will solve it)

See the attached screenshot. the function is mostly useless as-is now. This is on Firefox 87 Manjaro 21 (Linux) Default theme is used. According to https://www.reddit.co… (read more)

See the attached screenshot. the function is mostly useless as-is now.

This is on Firefox 87 Manjaro 21 (Linux)

Default theme is used.


According to https://www.reddit.com/r/firefox/comments/8k3sq4/firefox_updated_to_6001_and_the_search_box_is_no/ there's something wrong with userchrome.css in the profile but that file should be patched if that's the case.

Why this hasn't been patched since it's introduction in version 60 is beyond me.

Asked by ExileFox 1 year ago

Last reply by jonzn4SUSE 1 year ago

  • Archived

Chronik alles löschen funktioniert nicht

Habe Firefox 87 für Linux in Gebrauch. Seit kurzem reagiert das Programm nicht auf den Befehl "Löschen" "Alles" und sogar einzelne Einträge nicht. Hat jemand eine Idee? … (read more)

Habe Firefox 87 für Linux in Gebrauch. Seit kurzem reagiert das Programm nicht auf den Befehl "Löschen" "Alles" und sogar einzelne Einträge nicht. Hat jemand eine Idee?

Asked by w-richter-mnster 1 year ago

Last reply by thomas.kelso 1 year ago

  • Archived

Open correct program on download with FF on Linux

I'm using FF on Linux FC 30. If I download a file, let's say it's an RPM file it gives I get a dialog that says "You have chosen to open: Someprogram-1.2.3.rpm. What sho… (read more)

I'm using FF on Linux FC 30. If I download a file, let's say it's an RPM file it gives I get a dialog that says "You have chosen to open: Someprogram-1.2.3.rpm. What should Firefox do with this file Open with Apper Installer (default)"

If I click OK, nothing seems to happen. The "Apper" program does not open. Similarly, if I download a PDF, a PDF viewer does not open either. I'm not sure why it offers to open with that if it does not actually do it."

Instead, I have to click on the Downloads arrow, open the containing folder, right click on the file in a file explorer and have it open that application. Or, find wherever FF decided to put the file, currently FF favors /tmp/mozilla_my_id_0 and execute the program in a terminal.

I'd like to have FF actually do what it offered to do. I like to have it ask first. That part is good. But I want it to actually run the program. Apper exists on my system, and I have PDF viewers as well.

Secondly, I want to have FF download files in the normal Downloads folder and not some place off /tmp.

How can both things be fixed?

Thanks, Ben

Asked by ben.pracht 1 year ago

Last reply by Terry 1 year ago

  • Archived

Looking for Firefox 68 on Raspberry Pi

In short, I am looking for the Firefox 68 armhf deb? package installation file for Raspberry Pi OS (Raspbian) 10. --- I use Raspbian 10 (Raspberry Pi OS). I used to keep … (read more)

In short, I am looking for the Firefox 68 armhf deb? package installation file for Raspberry Pi OS (Raspbian) 10.

---

I use Raspbian 10 (Raspberry Pi OS). I used to keep a Firefox ESR 68 on hold (apt-mark hold) on 1 of my 2 Raspberry Pi machines. I offered this machine to a friend.

Now on my only left Raspberry Pi, Firefox ESR 68 is no longer provided by apt.

But I still need Firefox 68 on it, in order to remotely debug my userscripts on Firefox for Android 68.11.0 (latest version to support add-ons like Violentmonkey, thus userscripts) through adb.

Anyone knows how to install it back? I think I need an armhf.deb file, right?

I found: http://legacy.raspbian.org/raspbian/pool/main/f/firefox-esr/ https://archive.raspbian.org/raspbian/pool/main/f/firefox-esr/ https://github.com/jdonald/firefox-armhf/releases

But no trace of a version 68 deb file.

I then found some firefox-68.11.0esr.tar.bz2 in https://archive.mozilla.org/pub/firefox/releases/68.11.0esr/linux-x86_64/ Is x86_64 same as armhf? How do we install .tar.bz2 files in Linux?

I also see a firefox-68.11.0esr.snap in https://archive.mozilla.org/pub/firefox/releases/68.11.0esr/snap/ I would like to avoid installing snap but maybe I should try this instead, does it include armhf?

Asked by jesus2099 1 year ago

Last reply by cor-el 1 year ago

  • Archived

Firefox lost all my logins

Firefox lost all my logins/passwords. This happened last year and now it happens again. I've tried to find the old logins.json file and of course it does not work with it… (read more)

Firefox lost all my logins/passwords. This happened last year and now it happens again. I've tried to find the old logins.json file and of course it does not work with it. It is empty. I'm using linux and there is no problem with any antivirus, it is simply a Firefox 'classical' error!

WHY is this happening? What is in the mind of the programmer responsible for this error? I can't understand why is he unable to keep a single file intact?

Why Mozilla is blaming the user for not having a backup. Firefox is messing this file, not the user! Why don't you fix Firefox and stop blaming the user? Why don't you simply FIX THE PROBLEM? You are "working on it" for years. Is it rocket science to JUST LET THE FILE ALONE?

Asked by ogv41564 1 year ago

Last reply by ·´¯`·...¸>-)))º> ~dbben 1 year ago

  • Archived

strange user interface appearance if I have set Firefox to remember my tabs

I have Firefox installed on an XUbuntu 20.04.2 LTS machine. preferences to "restore previous session" on startup. Intermittently, when I launch the browser, one of my wi… (read more)

I have Firefox installed on an XUbuntu 20.04.2 LTS machine. preferences to "restore previous session" on startup. Intermittently, when I launch the browser, one of my windows has a very strange appearance (please note the general look of the window in the attached screenshot and ignore the "page cannot be displayed" message, as the screenshot was taken when I was not connected to the Internet.)

I have already tried reseting Firefox and that does not make the problem go away permanently; it always comes back eventually. (Note: I cleared cache before, and cookies after, taking the screenshot but before opening this support request. So the "troubleshooting information" attached reflects how it is after cookies are cleared.)

Asked by 4232jl 1 year ago

Last reply by jonzn4SUSE 1 year ago

  • Archived

speed of firefox

I'm facing speed differences between Chromium and Firefox. I checked all the hints how to speed up FF, nothing helped. I also de-installed FF complete (linux Mint) and re… (read more)

I'm facing speed differences between Chromium and Firefox. I checked all the hints how to speed up FF, nothing helped. I also de-installed FF complete (linux Mint) and reinstalled with new settings (initially raw system only) but difference between Chromium and FF is still given, FF appr. 130 MBit/s download and 150 upload, Chromium 190 -200 down, same for up. Checked with OOKLA, same server, repeated checks over 5 days. I have a 200MBit/s FTTH connection

Asked by peter 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Screenshot contains only the upprer left corner

When I take a Screenshot within Firefox the Screenshot only contains the upper left quarter of the image. Firefox_Screenshot1.png shows how I take the Screenshot and Fire… (read more)

When I take a Screenshot within Firefox the Screenshot only contains the upper left quarter of the image. Firefox_Screenshot1.png shows how I take the Screenshot and Firefox_Screenshot2.png shows the result. DE: bspwm

Asked by TGP 1 year ago

Last reply by jonzn4SUSE 1 year ago

  • Archived

Change the direction of writing, in Wikipedia

When I right-click on the "Reverse Page Direction" menu, the writing direction does not change, and remains the same, and I have to use an external plugin. Thanks to the … (read more)

When I right-click on the "Reverse Page Direction" menu, the writing direction does not change, and remains the same, and I have to use an external plugin.

Thanks to the respondents

Asked by ishayko71 1 year ago

Last reply by cor-el 1 year ago

  • Archived

why can't I login to https://www.edx.org/? Same password works fine on chrome.

edx complains of too many login attempts (!?), but *login works fine on chrome* see also: can't login to chase.com: chase displays a full screen login form in place of th… (read more)

edx complains of too many login attempts (!?), but *login works fine on chrome*

see also: can't login to chase.com: chase displays a full screen login form in place of the home page, which doesn't actually let you login. site is fully functional in brave browser

Asked by omega108 1 year ago

Last reply by FredMcD 1 year ago

  • Archived

Firefox bloquea equipo

Soy usuario de firefox con Ubuntu 18.04. En varias ocasiones al tener varias pestañas de navegación el equipo se bloquea por completo, solo es posible forzar el apagado c… (read more)

Soy usuario de firefox con Ubuntu 18.04. En varias ocasiones al tener varias pestañas de navegación el equipo se bloquea por completo, solo es posible forzar el apagado con el boton de encendido. También creo que este problema lo tenia con Ubuntu 16.

¿Alguna sugerencia?

Asked by jluishg 1 year ago

Last reply by JP 1 year ago