Showing questions tagged: Show all questions

How to enable closing tabs in order of appearance to avoid jumping around

Today when I close many tabs using control w firefox seems to randomly jump around when choosing which next tab to close I wish to have firefox always close the adjac… (read more)

Today when I close many tabs using control w firefox seems to randomly jump around when choosing which next tab to close

I wish to have firefox always close the adjacent tab to the tab I just closed

This should be the default behavior ... I do not see any setting for this ... is there an addon to do this ?

I am using the latest firefox on ubuntu

      • UPDATE*** below answer for setting `browser.tabs.selectOwnerOnClose` has no impact on this

Asked by EventHorizon 3 months ago

Last reply by James 3 months ago

Firefox being extremly laggy

I switched from windows 10 to 11 and to a new laptop. Here in my new laptop Asus tuf 15 ,even though it has better RAM , internet connection, cache memory, cores the FIRE… (read more)

I switched from windows 10 to 11 and to a new laptop. Here in my new laptop Asus tuf 15 ,even though it has better RAM , internet connection, cache memory, cores the FIREFOX doesnot function properly. It's extremly laggy specially when I use YOURUBE . In my earlier HP laptop with 8 GB ram I could use 10-15 tabs at one time .It would still not lag . It could do web development at the same time I could watch youtube tutorials. But now I barely open 4-5 tabs the youtube starts freezing up to the extent that I really get frustrated. Please so something or I will have to switch to BRAVE browser or something.

Asked by MANAS UNIYAL 3 months ago

Last reply by zeroknight 3 months ago

Passwords on phone not showing up on laptop

Hello, I use the Firefox browser on my phone and laptop, and have Lockwise on my phone where all the passwords are stored. Until yesterday, all these passwords would alw… (read more)

Hello,

I use the Firefox browser on my phone and laptop, and have Lockwise on my phone where all the passwords are stored. Until yesterday, all these passwords would always appear in my Firefox browser stored passwords. Now, they only show up in Lockwise on my phone and do not show up in the phone or Laptop Firefox browser.

I have followed this guide: https://support.mozilla.org/en-US/kb/end-of-support-firefox-lockwise and am syncing passwords across devices, but this did not solve the problem.

Has anyone else encountered this and know how to fix it?

Thank you.

Asked by spampinatodesign 3 months ago

Last reply by Paul 3 months ago

Developer Edition switched to dark background and I cannot undo this setting

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:prefer… (read more)

I change nothing in my settings and I am now on Dark background everywhere despite having: - forced the system settings (OS) to stay in light background - in about:preferences appearance I've manually selected (forced) the light background - in about:config I've tried to switch the browser.theme.content-theme to "1" (instead of "0")

this is really frustrating, I would like to get a better "reading" of what happens, as an Engineer I am happy to also squint at logs if needed, please consider adding a preference / settings change log file

Asked by looeegee 3 months ago

Last reply by cor-el 3 months ago

Is AdBlock scamming all Firefox users, or do you not want their partnership?

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam a… (read more)

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam all users on all sites.

Asked by Benjamin_Minney 3 months ago

Last reply by cor-el 3 months ago

Twitch - Non-Supported Browser Message

Attempting to log-in on Twitch with Firefox Browser - Developer version 122.0b9 (64-bit) is currently not possible, repeated messages are prompted by the Twitch website a… (read more)

Attempting to log-in on Twitch with Firefox Browser - Developer version 122.0b9 (64-bit) is currently not possible, repeated messages are prompted by the Twitch website about "unsupported browser" and to contact browser support to resolve this issue.

Clearing cache, disabling extensions did not work. Using regular Firefox works without issues, only noticed this being an issue after most recent update for Firefox Dev browser.

Side effect as well since update is that any Cloudflare captcha is impossible and all website that use Cloudflare to "authenticate" that I'm human just outright fail or continue indefinitely.

Asked by BiddinWar 3 months ago

Last reply by zeroknight 2 months ago

Firefox 122.0b9 stops responding when the file dialog is triggered

No crash report, no trace, no anything. I click "Save [insert] as...", and Firefox hangs and stops responding. Windows automatically shuts it off when clicking. Launching… (read more)

No crash report, no trace, no anything. I click "Save [insert] as...", and Firefox hangs and stops responding. Windows automatically shuts it off when clicking. Launching Firefox again sometimes says there was a problem reloading the session, but that's not guaranteed.

Asked by TheTank20 3 months ago

Last reply by zeroknight 3 months ago

page has infinite reloading

I'm experiencing a problem when I visit certain websites, like 'https://mui.com/x/react-data-grid/'. Every time I try to access this site, the page starts an infinite rel… (read more)

I'm experiencing a problem when I visit certain websites, like 'https://mui.com/x/react-data-grid/'. Every time I try to access this site, the page starts an infinite reloading loop, preventing me from using the website normally.

Asked by elhaddajiotmane 3 months ago

Last reply by zeroknight 3 months ago

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (read more)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 2 months ago

Last reply by zeroknight 2 months ago

Primary Password asked every time I open the browser

Dear community, since some recent update I am asked for a primary password every time I open the browser, which is higly annoying. I like my passwords protected by a pri… (read more)

Dear community,

since some recent update I am asked for a primary password every time I open the browser, which is higly annoying. I like my passwords protected by a primary password and in former times it was only asked for when trying to reveal a saved password. I know this has probably to do with me using Firefox sync, because I use the browser on my Android too but I would like to keep my devices synced. Besides: On my phone I am only asked for a fingerprint when accessing passwords, not every single time I open the app. There must be a way to reconfigure this on a desktop, right?

Asked by Jonah 2 months ago

Last reply by cor-el 2 months ago

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter?

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter? … (read more)

Cursor won't show when writing a letter or note. So I don't know where i stop typing? It works here but not when I open my browser to write letter?

Asked by JSM 2 months ago

Last reply by zeroknight 2 months ago

"Your browser is being managed by your organization"

"Your browser is being managed by your organization" is on the top of my settings page and it preventing me from using some of my streaming services. I am at my home, don… (read more)

"Your browser is being managed by your organization" is on the top of my settings page and it preventing me from using some of my streaming services. I am at my home, don't work at a job where I would ever be on a network, what the heck? It is some name I don't even know. Did I get hacked? Is it a virus? Nothing I have seen on here so far has worked, and I AM NOT A LINUX USER. (After looking at other answers, seems to be a problem with Linux.) I am on Windows 11. Thanks!

Asked by jbunds 2 months ago

Last reply by cor-el 2 months ago

Windows 10-Where else is Firefox accessing on my boot drive when it's installed to a secondary drive?

Took me a while to figure out how to get the full installer to install to my faster and larger D drive, but I finally did. Then I discovered it was still accessing C: un… (read more)

Took me a while to figure out how to get the full installer to install to my faster and larger D drive, but I finally did.

Then I discovered it was still accessing C: under: D:\Users\[Username]\AppData\Local D:\Users\[Username]\AppData\Roaming

So I now have my Mozilla folders in both locations pointed to D: with a symbolic link or whatever.

But it STILL seems to be accessing C: to do SOMETHING, and I'm not sure what or where, as searching C: for Firefox or Mozilla turns up nothing.

It still thrashes my C: drive though, especially noticeable if I'm using it for something else at close to 100% and Firefox for example loads a Youtube page that was unused/not in focus for a while.

Somehow it's STILL causing as much activity on C as D and I'm not sure why...if I was maybe I could point more directories to D with more Symbolic links (or whatever they're called...I may be misremembering since I set this up a few weeks ago, but they seem to work fine).

(I gave up on Chrome...I can point a bunch of stuff at D, but sooner or later it breaks its ability to do updates until I move stuff to C...I'm guessing maybe the updater "fixes" something in the background that breaks it. Thankfully Firefox seems to update just fine (I do NOT use the background process, I just check every day), and I got 122 today seemingly fine. No idea why browsers are so weird about getting installed on an alternative drive compared to other programs...it's a pretty common thing to want!)

Asked by Wolf 2 months ago

Last reply by zeroknight 2 months ago