Showing questions tagged: Show all questions

Firefox v122 --profile option is not working properly

Hi, I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap) and when using the --profile option to specify the startup pr… (read more)

Hi,

  I am running the latest Firefox v122 (firefox_122.0+build1-0ubuntu0.22.04.1~mt1_amd64.deb not snap)

and when using the --profile option to specify the startup profile it fails to start even on a NEW system that never ran Firefox if I give it a directory that resides on a mounted ext3 filesystem.

  All the permissions are OK and yet running strace I see an error and after a few second will get the

generic pop-up with the error message: (after a few seconds)

Firefox is already running, but is not responding. To use Firefox, you must first close the existing Firefox process, restart your device, or use a different profile.

 Running the SAME from /tmp works fine, but I need the profile to reside on a persistent storage area

so if the LIVE distro restarts then it can restore the previous session, bookmarks, options, etc...


============================================================
 The 2 directories were created identically and have the exact same permissions:

xubuntu@xubuntu:~$ mkdir /tmp/firefox3

xubuntu@xubuntu:~$ mkdir /media/xubuntu/sys_n01_home/mozilla/firefox3

xubuntu@xubuntu:~$ ls -ald /tmp/firefox3 drwxrwxr-x 17 xubuntu xubuntu 1080 Jan 21 22:05 /tmp/firefox3

xubuntu@xubuntu:~$ ls -ald /media/xubuntu/sys_n01_home/mozilla/firefox3 drwxrwxr-x 17 xubuntu xubuntu 4096 Jan 21 21:13 /media/xubuntu/sys_n01_home/mozilla/firefox3

============================================================

The only difference is that one is mounted on tmpfs and the other is on /dev/nvme0n1p2:

xubuntu@xubuntu:~$ df -k /tmp/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on tmpfs 32560016 351528 32208488 2% /tmp

xubuntu@xubuntu:~$ df -k /media/xubuntu/sys_n01_home/mozilla/firefox3 Filesystem 1K-blocks Used Available Use% Mounted on /dev/nvme0n1p2 195751828 51056068 142695768 27% /media/xubuntu/sys_n01_home


============================================================

When starting firefox with the /tmp/firefox3 profile directory it works fine and starts up:

xubuntu@xubuntu:~$ firefox --profile /tmp/firefox3

newfstatat(AT_FDCWD, "/tmp/firefox3", {st_mode=S_IFDIR|0775, st_size=1040, ...}, 0) = 0 newfstatat(AT_FDCWD, "/tmp/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/tmp/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=-487933736}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = 0 uname({sysname="Linux", nodename="xubuntu", ...}) = 0


BUT when using the persistent storage on the real filesystem (but SAME exact permissions) it fails:

newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3", {st_mode=S_IFDIR|0775, st_size=4096, ...}, 0) = 0 newfstatat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", {st_mode=S_IFREG|0664, st_size=0, ...}, 0) = 0 openat(AT_FDCWD, "/media/xubuntu/sys_n01_home/mozilla/firefox3/.parentlock", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 11 fcntl(11, F_GETLK, {l_type=F_UNLCK, l_whence=SEEK_SET, l_start=0, l_len=0, l_pid=1519466008}) = 0 fcntl(11, F_SETLK, {l_type=F_WRLCK, l_whence=SEEK_SET, l_start=0, l_len=0}) = -1 EACCES (Permission denied) close(11) = 0

Am I doing anything wrong or is this some weird startup issue / race condition in the parentlock management?

Thank you for looking into this.

  -Sanjiyan

PS: I can upload the full strace file for both scenarios if needed. Thanks again.

     running on an xubuntu distribution "22.04.2 LTS (Jammy Jellyfish)"

Asked by Sanjiyan 4 months ago

Last reply by zeroknight 4 months ago

Logging on to online banking

Have used online banking with Santander for some time but am now experiencing problems logging on. Getting message https://retail.santander.co.uk/ErrorPages/500.htm Ran… (read more)

Have used online banking with Santander for some time but am now experiencing problems logging on. Getting message https://retail.santander.co.uk/ErrorPages/500.htm Rang Santander and they suggest it is a browser problem. Have tried a number of things but problem persist

Asked by john.mullen2 3 months ago

Last reply by zeroknight 3 months ago

Firefox jump lists

I apologize for not knowing where to put this question. I have the latest version of Firefox installed and pinned to my taskbar. When I right-click on the Firefox icon … (read more)

I apologize for not knowing where to put this question. I have the latest version of Firefox installed and pinned to my taskbar. When I right-click on the Firefox icon that's pinned to my taskbar a list of things that I've downloaded as well as some other things shows up. Now I understand that I can manually clear these items, but that's a pain. I searched online for an answer and through my researching found that these items are called jump lists. I then searched for a solution for how to disable them and followed the instructions I'd found on a majority of sites that provided a solution. Even after doing this the jump list is still enabled and I don't know where else to go. I have attached two pictures showing the steps I've taken and that the jump list is still active.

Asked by firefox2653 4 months ago

Last reply by zeroknight 4 months ago

Stop jumping to a new search box or the address bar when searching. V122

Yes I have tried everything that has been written or suggested on how to fix the fixup. Still nothing has worked. About:config everything has been set to false that has b… (read more)

Yes I have tried everything that has been written or suggested on how to fix the fixup. Still nothing has worked. About:config everything has been set to false that has been suggested. It seems this latest version wants to eliminate our ability to customize and you even know how dangerous this is.

Asked by justoriole 4 months ago

Last reply by zeroknight 4 months ago

Is AdBlock scamming all Firefox users, or do you not want their partnership?

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam a… (read more)

AdBlock has not made any updates for Firefox for eleven months. Do they just not care, or has Mozilla rejected them? The internet is terrible enough as it loves to scam all users on all sites.

Asked by Benjamin_Minney 4 months ago

Last reply by cor-el 4 months ago

Update seems to have removed the "restore previous session" button.

Hello! After updating from 108 to 122, there's no restore previous session button. The recently closed tabs option only returned half of the tabs. Will this bug be repair… (read more)

Hello! After updating from 108 to 122, there's no restore previous session button. The recently closed tabs option only returned half of the tabs. Will this bug be repaired and how can I get back the tabs?

Asked by smcdougal 4 months ago

Last reply by jonzn4SUSE 4 months ago

any easy way to change colors on exitinge theme ?

How can i edit the color of text from exiting theme .. as the picture i need an easy way make text with another color like red or orange or at least make black border ou… (read more)

How can i edit the color of text from exiting theme .. as the picture i need an easy way make text with another color like red or orange or at least make black border outline white titles more thicker and or bold ..

Asked by Winter Mohammad Shoaib 4 months ago

Last reply by zeroknight 4 months ago

Twitch - Non-Supported Browser Message

Attempting to log-in on Twitch with Firefox Browser - Developer version 122.0b9 (64-bit) is currently not possible, repeated messages are prompted by the Twitch website a… (read more)

Attempting to log-in on Twitch with Firefox Browser - Developer version 122.0b9 (64-bit) is currently not possible, repeated messages are prompted by the Twitch website about "unsupported browser" and to contact browser support to resolve this issue.

Clearing cache, disabling extensions did not work. Using regular Firefox works without issues, only noticed this being an issue after most recent update for Firefox Dev browser.

Side effect as well since update is that any Cloudflare captcha is impossible and all website that use Cloudflare to "authenticate" that I'm human just outright fail or continue indefinitely.

Asked by BiddinWar 4 months ago

Last reply by zeroknight 3 months ago

Firefox Browser

I got a notice from Mozilla that Firefox was updated over night. Now when I hit a link it goes to edge instead of Firefox. In the Firefox settings, it still says that F… (read more)

I got a notice from Mozilla that Firefox was updated over night. Now when I hit a link it goes to edge instead of Firefox. In the Firefox settings, it still says that Firefox is my default browser. I do not want to use Edge. How do I fix this. I have used Firefox for many years.

Asked by mmcdonald3945 4 months ago

Last reply by TyDraniu 4 months ago

Default Browser Issues

When I select a link in an email, it opens op Edge, rather than Firefox. This just started happening today. I have followed multiple options for making Firefox my defau… (read more)

When I select a link in an email, it opens op Edge, rather than Firefox. This just started happening today. I have followed multiple options for making Firefox my default Browser, but nothing seems to work. I am using Windows 11 Home Addition. Thank You!

Asked by dhwelsh13 4 months ago

Last reply by zeroknight 4 months ago

Hellllp!!!! Firefox has deleted all cookies and passwords and reverted to a profile that is five years old

Help!!! After using this profile to sign in here to ask a question yesterday, upon restarting Firefox today it has deleted my entire login history, cookies and all passwo… (read more)

Help!!! After using this profile to sign in here to ask a question yesterday, upon restarting Firefox today it has deleted my entire login history, cookies and all passwords. However, when I go to recover these, the only default profile I can find when I do an "about:profiles" is one that is five years old.

I can literally no longer access any of the sites I use because al of the logins are gone.

Help! How do I get all my data back? My life is over if I cannot access any of my business sites, emails, Paypal, Amazon accounts or anything.

Asked by Lover_of_Goats 4 months ago

Last reply by cor-el 4 months ago

No history or bookmarks

Firefox has stopped saving history and I am unable to save any bookmarks. This seems to have happened recently for no reason I can understand. I haven't made any change… (read more)

Firefox has stopped saving history and I am unable to save any bookmarks. This seems to have happened recently for no reason I can understand. I haven't made any changes. I use a VPN but was doing so before this happened. I have checked all the settings and also deleted the places.sqlite file. When I click <bookmark current tab> nothing happens and history shows as empty.

Asked by sambain 4 months ago

Last reply by cor-el 4 months ago

Firefox is not loading or requires multiple reloads to access some pages since the most recent update

Since the most recent update, I am finding that Firefox has become highly unresponsive when it comes to loading some pages. Some are fine but others such as Reddit and Wi… (read more)

Since the most recent update, I am finding that Firefox has become highly unresponsive when it comes to loading some pages. Some are fine but others such as Reddit and Wikipedia will not or only partially load. Pictures will often only half load or not at all. News articles will often print text and fonts but nothing else.

This not occurring on all sites. And it doesn't seem to matter whether the site is https activated or not as some of the other threads seem to indicate is the problem.

I need a solution to this.

Asked by Lover_of_Goats 4 months ago

Last reply by zeroknight 4 months ago