YouTube videos don't work with Firefox

YouTube videos not working with Firefox since recent updates. Videos start to load but don't don't complete. Firefox is the only browser with this issue. Have tried three… (read more)

YouTube videos not working with Firefox since recent updates. Videos start to load but don't don't complete. Firefox is the only browser with this issue. Have tried three other browsers without issue.

Asked by lbertrand 3 weeks ago

Last reply by lbertrand 3 days ago

20 GB RAM usage, pagefile takes up all space on C: - 300 tabs in Tree Tabs

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works wel… (read more)

First, this post is basically Congratulations for Firefox upon working almost flowlessly under this extreme heavy load without crashing. Saving/loading sessions works well. (which is unexpected but makes me _very_ happy :-)) Firefox exits properly without any exceptions, no matter how long it runs, or how many times the PC is sent to STR mode meanwhile.

Second, everything is fine, except RAM usage. No matter how many RAM is installed, Firefox takes up all of it after a few days of normal operation. I have recently upgraded my PC from 16 to 24 GB of RAM only for this sole reason to see if anything changes, but it did not produce any noticable change, except that it takes 5-7 days for Firefox to fill up all the RAM instead of the 3-4 days before. Disk space on C: drive was nullified by Firefox as the paging file went up to 50 GB.

I want to hunt down this thing. I have approx. 300 tabs, 2 addons, and Hardware Acceleration is disabled since otherwise Fox hangs several times a day (have to be killed from outside). Pics are attached. https://addons.mozilla.org/hu/firefox/addon/tree-tabs/ https://gitlab.com/kroppy/TreeTabs

I'd like to get suggestions where to start.

  1. Disabling or replacing the adblocker ?
  2. Inspecting memory usage on Process Manager (about:processes) and Task Manager (about:performance) pages ?
  3. Installing some external tools like Firemin ?

Please don't suggest neither safe mode nor disabling all addons, since that makes it impossible to reproduce this amount of load, which is the primary reason behind the symptom.

I PrtScr'ed Process Manager and Task Manager, see that RAM sizes per page are normal in Task Manager, but not in Process Manager (10 times more).

CPU usage is totally normal for this load, even when memory is in the heaven. See the TaskMan pic. (I suppose that's because of ad blocking)

Thanks for any ideas,

Peter B. (I'm PC enthusiast)

-- Windows 7 Ultimate SP1 64 bit Firefox 106.0.5 (latest autoupdated) no firewall nor any antivirus - since 20 years with no infection ... AMD FX-6350 Six-core ASUS M5A99FX PRO R2.0 24 GB DDR3 1600 MHz Sapphire Radeon HD 5750 1GB (AMD Catalyst 15.11.1, Nov 18, 2015)

Asked by Peter B. 3 weeks ago

Last reply by Peter B. 11 hours ago

Picture-in-picture not showing

When on youtube or any video website, when I click the PiP button on the side of the video, instead of having the video popup on the screen I have a new windows (only vis… (read more)

When on youtube or any video website, when I click the PiP button on the side of the video, instead of having the video popup on the screen I have a new windows (only visible in the windows taskbar) which is invisible.

If I try to hover the (empty) preview in windows, it should hide everything else and show the window, but nothing happens as if the popup create a window but stops in the middle.

I tried with Firefox (v107.0 64-bit) and Firefox dev edition (v108.0b6 64-bit), same problem. I tried disabling every addon/theme, same problem. I tried disabling hardware acceleration, same problem. I tried Troubleshoot mode, works correctly.

Before re-installing Windows it worked normally. What could be the problem ?

Asked by EdgelordMcTeabag 1 week ago

Last reply by EdgelordMcTeabag 6 days ago

Explore possibilities of using System Theme 1.0 in Firefox 91.9.1esr and later.

After moving to Firefox 91.9.1esr I found problem with System theme 1.2. The color of tab add button was changed, and the button is not visible with my Windows 7 classic … (read more)

After moving to Firefox 91.9.1esr I found problem with System theme 1.2. The color of tab add button was changed, and the button is not visible with my Windows 7 classic windows system theme. So, I'm trying to find a way to port System theme 1.0 color scheme to newer firefox versions.

Creation of a simple theme with firefox color extension works. But it is unable to recreate the effects related to active and inactive window color changes. As, I had to use bitmap to get the OS blue color transition pattern.

It seems the system theme is stored in omni.ja file. Modification of the omni.ja seems to be not a practical solution. So, it would be a better way to create an addon theme with the same code as the System Theme 1.0.

The first question is, if it will be possible to create a theme with the same code as a system theme has. Will it be able to perform the same way?

The next question is: Where the source code of the system theme is? I was unable to find it in the Firefox source. It seems, it is not stored in any obvious location.

Asked by sforforsoft 1 week ago

Last reply by sforforsoft 6 days ago

Reinstalling Firefox

I am currently having problems with my Firefox browser. For example often if I type something into the google search box at the right of the address bar and hit return no… (read more)

I am currently having problems with my Firefox browser. For example often if I type something into the google search box at the right of the address bar and hit return nothing happens until I go down and select Bing instead of the google setting. Also in hotmail (I am on a desktop) if I go to reply, the original is now ether twice. This does not happen if I use Google browser. But I prefer Firefox as I have used it for years.

My concern is if I delete Firefox and reinstall it, I may lose some of the settings or bookmarks that I have set over the years.

Any suggestions? Please simple as i am old and not computer savvy.

Your help would be so appreciated. I am currently on Firefox 107.0 (64 bit)

Thanks, Anthony

Asked by avwood 6 days ago

Last reply by avwood 50 minutes ago

Unable to download jpg file complete since latest update

Unable to download jpg file complete. Get error message and image down will have .part after filename.jpg. DeepDreamGenerator.com site from user 'file manager' view. C… (read more)

Unable to download jpg file complete. Get error message and image down will have .part after filename.jpg. DeepDreamGenerator.com site from user 'file manager' view. Can download ok if I right click image to show in new tab. Cannot find adblocker to disable which was DDG Team suggested was happening. I can download from file view in MS browser. Problem started after latest update.

Asked by Cowgirl_in_the_Sand 1 week ago

Last reply by Cowgirl_in_the_Sand 6 days ago

Encrypted HTTPS websites always ask if I want to trust the certificate

I am using Mozilla Firefox 64-bit with version 107.0 on Windows 10 21H2. I connect very often to HTTPS websites without a valid certificate. Often with certificates issue… (read more)

I am using Mozilla Firefox 64-bit with version 107.0 on Windows 10 21H2. I connect very often to HTTPS websites without a valid certificate. Often with certificates issued by themselves. Before it was always enough to say "I trust this website" once. Now the question comes again and again, whenever I connect. What could be the cause of this?

Asked by Andreas Fendt 2 weeks ago

Last reply by Andreas Fendt 5 days ago

XUL Runner Pop Up Information Message

After the second to the last update to Firefox I started experiencing an information pop up message "Could not determine any profile running in backgroundtask mode!". Is… (read more)

After the second to the last update to Firefox I started experiencing an information pop up message "Could not determine any profile running in backgroundtask mode!".

Is there a fix for this?

Thank you.

Asked by vwilyard 2 months ago

Last reply by vwilyard 23 hours ago

I was having problems with WWF on FB a few days ago. I think it's their problem after I cleared my cache and temp files. But now Firefox won't recognize me and I have to log into all of my programs like it's the first time (i.e., Insta, LinkedIn, etc.)

I want to be able to use Firefox like I did before! Tired of having to re-log-in to programs that I didn't used to have to before I cleared cache, etc. Dee … (read more)

I want to be able to use Firefox like I did before! Tired of having to re-log-in to programs that I didn't used to have to before I cleared cache, etc.

Dee

Asked by dee0015 6 days ago

Last reply by dee0015 6 days ago

Your system has run out of application memory

I am using the latest version of Firefox with Mojave on a Mac. Lately I have experienced slowness despite the fact that I didn't add any software and I have Norton checki… (read more)

I am using the latest version of Firefox with Mojave on a Mac.

Lately I have experienced slowness despite the fact that I didn't add any software and I have Norton checking for viruses. Recently I got a message "Your system has run out of application memory" when I had 5 tabs open in Firefox. I checked Activity Monitor and it showed Firefox using 1.16 GB. 7 other apps were open, the next one with the highest memory usage was Mail (465 MB). Activity Monitor showed 30 instances of FirefoxCP Isolated Web Content entries.

I attached a screen capture showing what Firefox was using in one of these instances. Is this "normal" with 5 tabs open?

I closed the open tabs and quit Firefox. Memory usage by Firefox went down, but after a short time the problem happened again.

A search on the internet showed lots of similar complaints about FirefoxCP Isolated Web Content. Is this a known bug? Any way to avoid this problem?

Thanks.

Asked by Sue 1 month ago

Last reply by Sue 4 days ago

Save path dosent remember

I dont know how to explain or how its called, What i want to know when i use Firefox for docker app i have to type path every time i want to use download while on Chrome … (read more)

I dont know how to explain or how its called, What i want to know when i use Firefox for docker app i have to type path every time i want to use download while on Chrome when i double click i get drop down with paths i allready used so i just pick instead type every time (it can be frustrating because sometimes i mistype)

Image shows best what i mean :)

Asked by neocro44 1 week ago

Last reply by neocro44 5 days ago

All my PCs have lost settings/ history/ shortcuts on Firefox today.

Hi, we have 4 PCs (3 running Win 10 and one Win 7) which updated themselves today and lost everything. Settings, add-ons, bookmarks, shortcuts all gone; looks like a new … (read more)

Hi, we have 4 PCs (3 running Win 10 and one Win 7) which updated themselves today and lost everything. Settings, add-ons, bookmarks, shortcuts all gone; looks like a new install. I checked the other threads and the profiles; there is only one profile and no backup. How to get my stuff back?

Asked by uspec 1 week ago

Last reply by uspec 5 hours ago

FireFox not closing because of incomplete download during Selenium automation

when running automation in firefox,in my case i want to check file was downloaded in particullar time,if file wasn't downloaded,i want to close the firefox.but, because o… (read more)

when running automation in firefox,in my case i want to check file was downloaded in particullar time,if file wasn't downloaded,i want to close the firefox.but, because of incomplete download browser not closing alternatively it shows popup(screenshot attached) and which is unable to handle with automation,In automation it's too hard every time run and click it manually,so kindly help me to overcome this,Thank you

Asked by sathanraj95 1 week ago

Last reply by sathanraj95 5 days ago

Firefox 107 unable to view amazon prime in hd

I am using Firefox 107.0 on windows 10 64bit 21H2 (19044). Im a unable to watch amazon prime videos on HD. this issue only seems to be on firefox, while using the same ac… (read more)

I am using Firefox 107.0 on windows 10 64bit 21H2 (19044).

Im a unable to watch amazon prime videos on HD. this issue only seems to be on firefox, while using the same account.

Hoping someone can help me here

Asked by ScarVite 1 week ago

Last reply by ScarVite 5 days ago

Garbled font in Firefox on macOS Monterey (12.6.1)

Hello :) I'm using Firefox 107.0 on macOS 12.6.1 and I'm having weird issues with the displayed font. It appears on the startup screen of Firefox and on websites (see scr… (read more)

Hello :)

I'm using Firefox 107.0 on macOS 12.6.1 and I'm having weird issues with the displayed font. It appears on the startup screen of Firefox and on websites (see screenshots attached).

The garbled font is called ".SF NS".

I've tried turning the option "Allow pages to choose their own fonts, instead of your selections above" on and off without success.

I have also tried enabling and disabling hardware acceleration - also without luck.

The issue does **not** appear in safe mode. Unfortunately resetting the theme and disabling all extensions hasn't helped either :(

I have also downloaded and installed a font called "SFNS Display" but the issue persists.

Uninstalling Firefox (with AppCleaner) and reinstalling hasn't fixed the problem.

I don't know what else to try. Can someone help me please? :)

Asked by Gutenberg 1 week ago

Last reply by Gutenberg 3 days ago

Firefox Start Page

Now that my search engine for Firefox start page (Bing) have stopped showing images for older browsers (I just get a blank grey screen with their search bar). Upgrading F… (read more)

Now that my search engine for Firefox start page (Bing) have stopped showing images for older browsers (I just get a blank grey screen with their search bar).

Upgrading FF is not an option.

I want to use my own image (but not sure how to go about this). A Bookmark ?

Thanks

Asked by webmaster115 1 week ago

Last reply by webmaster115 5 days ago

Bookmarks mouse hover not working properly in normal mode

I have a recent problem with mouse hover with Bookmarks in the Menu bar. Basically; it no longer shows the URL info in the drop down box, only a blank, box appears. I a… (read more)

I have a recent problem with mouse hover with Bookmarks in the Menu bar. Basically; it no longer shows the URL info in the drop down box, only a blank, box appears. I am using Windows 7 and the current Firefox 107.0. It appears to be a Windows 7 issue, because I have the same problem on my Win 7 desktop and Win 7 laptop, but a laptop with Windows 11 is OK.

The really odd part is this. If I run Firefox in troubleshooting mode in either Win 7 machine, the problem goes away, and the drop down box works fine, and displays the URL info. If I manually disable my add-ons in normal mode on either machine however, the problem does NOT go away.

One last odd point. On my desktop, when I am in normal Firefox mode, and look at Bookmarks in the History tab from the menu bar, the last (bottom most) bookmark, and ONLY the last bookmark WILL display the box info correctly. On my Win 7 laptop the same effect occurs, but the last (bottom most), bookmark will sometimes work properly in other folders, such as Other bookmarks for instance.

Also; the URL box does work properly with the ‘Show your bookmarks’ button, and the bookmarks menu if I use the “Open application menu”. These options produce too much ‘white space’ however, and are not as convenient to use. The drop down box works fine with other browsers, but Firefox is my favorite browser. I have searched the Internet and the forum, and not found a similar problem.

Attached are two photos showing the result in normal and troubleshooting mode. Thank you in advance.

Asked by kolchak 6 days ago

Last reply by kolchak 6 days ago