Showing questions tagged: Show all questions

Firefox not printing frame contents within webpage

Running Windows 10 and Firefox 102.9.0esr 64-bit. I seem to have affected the print facility so that the contents of a frame within a webpage do not print. The frame cont… (read more)

Running Windows 10 and Firefox 102.9.0esr 64-bit. I seem to have affected the print facility so that the contents of a frame within a webpage do not print. The frame contents do show on the preview screen but then disappear when the Print button is pressed and they are not printed. The rest of the webpage is printed OK. Typically this happens to the 'Sellers Description' on an Ebay item. I have upgraded to Firefox 115.7.0esr but this has not fixed the problem. The print works fine on another machine running Windows 10 and Firefox 91.6.0esr 64-bit. Is there a way to get the full print back? Regards, LRB

Asked by lyn.bennett6 1 day ago

Last reply by jonzn4SUSE 27 seconds ago

Websites tell me I need to enable Javascript despite the fact that it is enabled

Today a website told me I needed to enable JavaScript in order to continue, despite the fact that it is enabled. At first, when I received this message, I turned off t… (read more)

Today a website told me I needed to enable JavaScript in order to continue, despite the fact that it is enabled. At first, when I received this message, I turned off the "NoScript" extension and tried again, but the website still gave me that same message. So then I went to the about:config page. and it showed that JavaScript is enabled because it showed a value of "true". This sort of thing has happened more than once in the past. I'm forced to go to another browser such Microsoft Edge or Chrome, where I do not encounter this problem. Why is this happening in Firefox, and what can I do about it? My operating system is Windows 10 Professional, and if you need any other details, please let me know. I will appreciate your assistance.

Asked by Larry951 1 week ago

Last reply by zeroknight 37 minutes ago

MY LOCATION (LOCATION OF THE DEVICE UPON WHICH FIREFOX IS THE BROWSER)

This is so very simple and so the fact that it seems impossible to get a straight answer makes me instantly suspicious. Here is the question: What is my location? Simple!… (read more)

This is so very simple and so the fact that it seems impossible to get a straight answer makes me instantly suspicious. Here is the question: What is my location? Simple! In other words, I have Mozilla Firefox installed on a physical device, which HAPPENS to be a desktop computer, not a mobile phone, etc. In other words, it stays here. So why do alllllll the sites act as though I am literally 930 miles...from my actual, physical location! I have NO VPN running...none. Unfortunately, Firefox is using Google location services, WHICH IS THE PROBLEM. I just installed Firefox, instead of Chrome, to solve that problem. I guess THAT was a stupid move, Firefox is worse!

There needs to be a manner in which the USER can INPUT THEIR LOCATION. I'm not trying to "trick" anyone...I'm actually trying to give people ACCURATE INFORMATION which apparently is beyond the capabilities of the internet, to provide.

Asked by R C 5 hours ago

Last reply by zeroknight 1 hour ago

Problems with Firefox installation

I had posted my question yesterday and received a response from jscher2000. I sent a reply to the response by email a short while ago, but I wasn't sure it went through. … (read more)

I had posted my question yesterday and received a response from jscher2000. I sent a reply to the response by email a short while ago, but I wasn't sure it went through. Therefore, at the possible expense of having you receive the reply twice, I have recopied it here:

Thank you for trying to help me download Firefox onto my computer. As per your advice, I first tried shutting down and restarting my computer. That did not work. Then I went onto the link you sent me: https://www. mozilla,org/en-US/firefox/all/#product-desktop-release . The installation began, but only got up to around 80 - 90%. It stopped at the point where it said Execute: "C:|Program Files\Mozilla Firefox\default-browser-agent.exe" register-task 308046B... (It looks like there might be some more letters and/or numbers after the "B", but I can't see what they are.) I waited a few more hours to see if the installation would continue, but it did not. I then went back to try downloading Firefox in the regular way. First I got a message, "Now installing. Firefox will be ready in just a few moments." Again, installation proceeded to around 80 - 90 %, and then I got a message, "Hmmm. For some reason, we could not install Firefox. Choose OK to start over." Starting over didn't help. I got the same message. Any further help or advice that you can give me would be greatly appreciated. drzee1946 email: [removed from public support forum]

Asked by drzee1946 17 hours ago

Last reply by James 6 hours ago

How to get rid of google account

I had one email that I linked with a mobile game but I logged off and sold it. But every time I went to google.com and clicked sign in then It pops up the old Google acco… (read more)

I had one email that I linked with a mobile game but I logged off and sold it. But every time I went to google.com and clicked sign in then It pops up the old Google account which I already sold. And I have to select new email and login again. It seemed in every time I went to google I have to re-login again. Its very bother me.

Asked by benztpk1994 10 hours ago

Last reply by cor-el 8 hours ago

It appears I have "Silk Privacy Pass" in firefox and I never put it there - I can't remove it

I've discovered it has something to do with Amazon. I didn't know I had it until I just migrated to Windows 10 and a new firefox update occurred. Even then, my only cl… (read more)

I've discovered it has something to do with Amazon.

I didn't know I had it until I just migrated to Windows 10 and a new firefox update occurred.

Even then, my only clue is a little orange "triangle" that shows up at the top line of the 'hamburger' menu at the top right on the screen. When I clicked on it, I got a message saying "Silk Privacy Pass wants to update".

I went to my installed extensions/themes screen and there is nothing about a silk extension or add-on.

It also showed up when I looked in the startup configuration and it showed it was loading during startup there. I disabled it. But today I just got the orange triangle again an hour ago wanting me to let it update.

I want it gone!! Especially when it showed up on my system without my asking or knowingly agreeing to it.


FWIW, I also ran Agent Ransack (search utility) on the drives and "Silk" does not come up as a file name for an app, DLL or any other file.

Asked by Owen McDonald 17 hours ago

Last reply by jscher2000 - Support Volunteer 9 hours ago

Backup

Last time I tried backing up my bookmarks, they were saved in a file that was basically a list, a list that can't be imported back to Firefox bookmarks, but just a list. … (read more)

Last time I tried backing up my bookmarks, they were saved in a file that was basically a list, a list that can't be imported back to Firefox bookmarks, but just a list. I would like to know if there's a way to actually export and import bookmarks with one click, rather than me having to add 200 pages from the list manually. When I tried importing the file, the list ended up somewhere random and not where bookmarks are

Asked by Devin M V 1 day ago

Last reply by jscher2000 - Support Volunteer 9 hours ago

Cookies being written and automatically deleted

Hello, I work for Microsoft, and one of our sites offers users a way to opt out of personalized advertising on some Microsoft domains by setting a cookie. The site: http… (read more)

Hello,

I work for Microsoft, and one of our sites offers users a way to opt out of personalized advertising on some Microsoft domains by setting a cookie. The site: https://account.microsoft.com/privacy/ad-settings/signedout

When the user clicks the toggle to Off, we cycle through four domains via an iframe and write a TOptOut cookie on each one. If everything is working properly, the user should then be able to go to www.bing.com and see a TOptOut cookie on Bing that will prevent personalized advertising on that domain.

The problem is, this stopped working in Firefox. We have verified that it still works* in 115.7.0, but in 122.0.1 and 123.0, the cookie is written and then deleted on refresh. If the user doesn't already have Bing open in another tab, they'll never see the cookie at all. I have verified this behavior in Bing several times, on my work machine (Firefox 122.0.1 on Windows 10) and my personal machine (Firefox 122.0 snap on Xubuntu 23.10).

  • It still works on our corporate VPN in 115.7.0, but not on my coworker's non-VPN machine. Same version. I'm really not sure what's up with that one.

This is a large concern for us. Because the cookies can still be written, it doesn't trip our test for third-party cookies being disabled. Because the cookie for microsoft.com is written, the toggle will show up as Off even after a refresh. This is misleading to our users.

I have gone over the Firefox docs on Enhanced Tracking Protection and Total Cookie Protection, but neither seem to handle this case. Firefox does not block any trackers on account.microsoft.com or on www.bing.com. It's fine if the cookies are in separate jars, we just want them to be written to the proper domains and not deleted. Can anyone tell me what changed in Firefox recently? Is this expected behavior, or a bug? If it's expected behavior, what can we do to allow users to opt out of personalized advertising?

Asked by amleek 1 day ago

Last reply by jscher2000 - Support Volunteer 9 hours ago

How to debug FF startup, not using the profiler? After reboot, FF always takes 14 minutes to start the first time.

I run the latest Firefox (v122.0.1) on Windows 11. Since last week, FF takes 14 minutes to start the first time after a boot. :-( Usually FF starts in ~3 seconds. … (read more)

I run the latest Firefox (v122.0.1) on Windows 11.

Since last week, FF takes 14 minutes to start the first time after a boot. :-( Usually FF starts in ~3 seconds.

I reboot the laptop. I wait a minute. I start FF. Nothing happens for 14 minutes. Finally the browser window suddenly appear and everything is working normally. I exit FF (no remaining firefox.exe processes are running). I start FF again. Now it starts immediately as usual. :-) But: I reboot and start FF. Again, it takes 14 minutes to start. This is reproduceable every time.

I haven't tried to *solve* this by refreshing FF or simillar. Right now I'm more interested in debugging this and finding out what is wrong.

I found https://profiler.firefox.com/docs/#/./guide-startup-shutdown which states how to automatically start the profiler at startup.

12:40 I boot the computer, login and wait a minute. 12:43 I start CMD.EXE and run:

 cd c:\Program Files\Mozilla Firefox
 set MOZ_PROFILER_STARTUP=1
 set MOZ_PROFILER_STARTUP_ENTRIES=20000000
 set MOZ_PROFILER_STARTUP_INTERVAL=100

12:44 I run:

 firefox.exe

No GUI appear. (it won't appear until 14 minutes later) I open the Task Manager and see one (1) firefox.exe process, taking 0% cpu. (pid 17668) 12:48 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:50 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:52 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:54 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:56 One more process running for a few seconds. Commandline is just "c:\Program Files\Mozilla Firefox\firefox.exe", no more options. 0% CPU. 12:58 The browser GUI finally appear. Everything is now normal. It is showing one (1) tab with my start-page (google) just as it should. (my Task Manager now show 12 FF processes running, with various options) 12:59 I click the icon to stop the profiling.

I open the profile. [Profile Info] says:

 Recording started: Sat 17 Feb 2024 12:58
 Recording length: 1m12s 

So my profiling data don't show what happens between 12:44 to 12:58 :-(

Just for the sake of it, I'm attaching a pic of the first 10 seconds of the profile (at 12:58).

PS: Between 12:44 and 12:58 no FF window exists at all. Alt+Tab show no FF and in Task Manager I can't do any "Window" management, it is greyed out. I.e. no FF window exists for this process.

Question 1) What should I do to debug what happens between 12:44 and 12:58?

Question 2) How can it be that it takes 14 minutes to start FF from scratch (boot) while it starts quickly (~3 seconds) if it has been started once? I mean, all firefox.exe processes are gone when I exit FF, so starting FF again should be like starting from scratch, but apparently something is different.

Question 3) Is it normal that a FF, with only one tab (https://google.com/), run 12 processes in Task Manager?

Asked by elofu17 5 days ago

Last reply by cor-el 11 hours ago

downloading/installing Firefox

I have been using Firefox for quite some time. Suddenly it stopped working on my computer, I tried uninstalling and reinstalling, but I keep getting a message that there … (read more)

I have been using Firefox for quite some time. Suddenly it stopped working on my computer, I tried uninstalling and reinstalling, but I keep getting a message that there is a problem with the download and installation. Can anyone help? Let me know if you need any further information. Thank you in advance.

Asked by drzee1946 1 day ago

Last reply by cor-el 11 hours ago

New Computer

I recently migrated data from my old MacBook Pro to a new MacBook Air. I installed Firefox on my new computer as it did not migrate. It installed fine but will not launch… (read more)

I recently migrated data from my old MacBook Pro to a new MacBook Air. I installed Firefox on my new computer as it did not migrate. It installed fine but will not launch. Please help.

Asked by Charlie 1 day ago

Last reply by jonzn4SUSE 12 hours ago

FireFox

The last few days I have been unable to connect to Microcenter (www.microcenter.com) when using FireFox. Get an error Forbidden - ID: db4a0787baff80adb2df6dd9d9881a53, th… (read more)

The last few days I have been unable to connect to Microcenter (www.microcenter.com) when using FireFox. Get an error Forbidden - ID: db4a0787baff80adb2df6dd9d9881a53, the # changes everytime you try. But the website works fine when I use google chrome and microsoft edge.

Asked by stevewk11 18 hours ago

Last reply by cor-el 12 hours ago

Bookmarks

After re-installing Firefox, my Bookmarks are gone. I could reinstall them as I go along, but my Folders (used to organize) are also gone. Worse: I cannot seem to figu… (read more)

After re-installing Firefox, my Bookmarks are gone. I could reinstall them as I go along, but my Folders (used to organize) are also gone. Worse: I cannot seem to figure out how to re-create folders or move those Bookmarks I have. Any suggestions.

Asked by jf360cpw 13 hours ago

Last reply by cor-el 12 hours ago

Twitter's Login page doesn't load in Firefox

Twitter's login page won't load when I try to open it in Firefox. https://twitter.com/ https://twitter.com/ loads just fine, account pages like https://twitter.com/firefo… (read more)

Twitter's login page won't load when I try to open it in Firefox. https://twitter.com/ https://twitter.com/ loads just fine, account pages like https://twitter.com/firefox load just fine, and individual tweets individual tweets load just fine. But when I click the login button on any working page, or go directly to the login page at https://twitter.com/i/flow/login, all I get is a white rectangle in the middle of the screen that flashes a loading-spinner for a few frames every two seconds but never actually loads any page content.

I can log in just fine in Chrome, so the problem is specific to Firefox. The problem started at least a week ago, but I don't log in on my desktop regularly enough to know exactly when the problem started.

I turned my Browser Privacy setting to "Standard" and cleared all site data from Twitter, with no effect. I use uBlock Origin, but the problem persists when I disable it. The problem also occurs in Private windows.

Asked by Z Lawton 14 hours ago

Last reply by cor-el 13 hours ago

If I start typing in the URL bar while Firefox is still launching, it will add the URL of my homepage after what I've typed in.

Just what they title says. If I launch Firefox and immediately click in the URL bar to type in a search, instead of preventing the page URL from appearing, it adds it af… (read more)

Just what they title says. If I launch Firefox and immediately click in the URL bar to type in a search, instead of preventing the page URL from appearing, it adds it after my cursor once the page has loaded. For example, if I launch Firefox and immediately start typing "weather in my area" it becomes "weather in my areahttps://www.youtube.com/feed/subscriptions".

This is a mild frustration, but a persistent one. It must be possible to fix, because other browsers (Chrome) are clever enough to not add any text once the user clicks the URL bar. What can I do to stop this from happening?

Asked by alidwell 15 hours ago

Last reply by cor-el 13 hours ago

Cookie blocking

Since last upgrade Firefox seems unable to access any wordpress sites. Always says to enable cookies. I've done that but still not possible access. Is Firefox now beco… (read more)

Since last upgrade Firefox seems unable to access any wordpress sites.

Always says to enable cookies. I've done that but still not possible access.

Is Firefox now becoming so "secure" it is useless?

There are more and more web sites where Firefox just is no longer a viable browser.

There is no clear "ENABLE" cookies option to resolve this just pages on explanations about safety yada yada yada.

I just want a button that says ENABLE COOKIES so I don't have to constantly seek answers to use this browser on a particular web site.

As much as I hate Chrome I am finding it more useful now than FireFox

Asked by pck24 5 months ago

Last reply by jonzn4SUSE 16 hours ago

Kaspersky flagging firefox

Hi dear Community! As of recent, my AntiVirus software is flagging Firefox.exe (Full path: C:\Program Files\Mozilla Firefox\firefox.exe) as a vulnerable application. I h… (read more)

Hi dear Community!

As of recent, my AntiVirus software is flagging Firefox.exe (Full path: C:\Program Files\Mozilla Firefox\firefox.exe) as a vulnerable application. I have been using firefox for years (Because I love it, you guys are heroes) and i have been using Kaspersky for years. Firefox has only been flagged as of recent.........

I hope someone knows why, has this too or can calm my paranoia

Some Additional information:

Have you clicked any suspicious links? No i have not. The links i have visited were all https, checked and acknowledged by Kaspersky and i can say with full certainty that the sites were legit

Have i downloaded any files as of recent? Yes, but from reputable sources and always checked using Hashes and validating using KSN (Kaspersky security network).

(For the Mods, im sorry for previously posting this in the wrong forum.)

Asked by averticalhorizontal 1 day ago

Last reply by jonzn4SUSE 20 hours ago

no sound come out from the berswer

Hi... I have an issue which no sound for media like YouTube .. I have check all sittings are default, and I have fallow up all topic still no sound question and all sitti… (read more)

Hi... I have an issue which no sound for media like YouTube .. I have check all sittings are default, and I have fallow up all topic still no sound question and all sitting are OK!? I can't play any videos with sound !!! need help please...

Asked by abdo 1 day ago

Last reply by jonzn4SUSE 20 hours ago