Showing questions tagged: Show all questions

Possible IPC memory leak - how to pinpoint the culprit?

Hey there, I'm having trouble with Firefox. Something inside Firefox is eating up my RAM and CPU. Usually I recognize the problem happening because my laptop fans ramp up… (read more)

Hey there, I'm having trouble with Firefox. Something inside Firefox is eating up my RAM and CPU. Usually I recognize the problem happening because my laptop fans ramp up. The problem occurs on my laptop as well on my desktop (both on latest stable Firefox[Build ID: 20220513165813] and Windows 11). The workaround is to kill the Firefox subprocess which is using most of the CPU and RAM. Then everything is back to normal for some time, until Firefox starts messing with me again.

While trying to pinpoint the problem I'm stuck. I can't find a culprit other than the fact it has something to do with Firefox. Clean reinstalling did not help. The Firefox Task Manager doesn't know anything about huge amounts of RAM being taken. I searched for solutions on the net and the about:memory indicates the problem is some IPC related stuff:

 {
  "process": "Main Process (pid 12648)",
  "path": "queued-ipc-messages/content-parent(Browser, pid=9612, open channel, 0x22e4b33fc30, refcnt=38)",
  "kind": 2,
  "units": 1,
  "amount": 0,
  "description": "The number of unset IPC messages held in this ContentParent's channel.  A large value here might indicate that we're leaking messages.  Similarly, a ContentParent object for a process that's no longer running could indicate that we're leaking ContentParents."
 }

The bug reporting guidelines(https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html) are encouraging me to attach steps to reproduce and try the steps listed on https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources . But I've exhausted the steps there (Except for upgrading the PC / RAM).

Especially on the go this Firefox-RAM-Party takes quite some battery and right now while writing this Firefox has >100GB virtual RAM reserved for some IPC messages, I personally think this is too much. So I'd like to file a report, but without steps to reproduce I'm afraid the developers are going to say 'well, that's something we are not able to diagnose', because I am unable to explain how to reproduce it. It just happens from time to time.

The anonymized about:memory report: https://bin.disroot.org/?2ba01ef78154cce4#8PLVqLTd9qgaRn2QVX2P17hkbHQyrTDuVAwoykj2cBxg

I left Firefox running like this for about half an hour and at 138GB reserved RAM Windows slaughtered my Firefox. The resulting crash report: https://bin.disroot.org/?0bc57492585dde4b#5YtbWgXcbZSkWYmg2CGkVn9iiipYwfYbxUfCLhmMJh7d

Do you have a clue where I might find out who sends those IPC messages, and therefore who is responsible for this?

Asked by Sewana 6 days ago

Last reply by Sewana 18 minutes ago

I lose the connection with google (gmail, drive, translator)

When I open gmail in Firefox browser, I lose the connection very often, it also happens with google drive. But it does not happen to me if I use Outlook from the web, I o… (read more)

When I open gmail in Firefox browser, I lose the connection very often, it also happens with google drive. But it does not happen to me if I use Outlook from the web, I only lose the connection with Google from Firefox.

However, if I open the same thing using Google Chrome, this does not happen, it works correctly throughout the day, and I do not lose the connection.

My version of Firefox is 100.0.2 (64-bit) on my notebook I have Windows 10 Pro installed.

Asked by elserhumano 2 hours ago

Web Applications are Distorted.

Whenever I use web-applications that use WebGL or anything similar, they are always distorted. And yes, I have tried disabling Performance Settings, but that only slightl… (read more)

Whenever I use web-applications that use WebGL or anything similar, they are always distorted. And yes, I have tried disabling Performance Settings, but that only slightly helped.

Asked by cromeydavid 13 hours ago

Last reply by cromeydavid 12 hours ago

Long delay until Homepage is opened

There is a large delay between when I open Firefox, and when it finally loads my homepage (Bing.com). To help troubleshoot, I installed Wireshark, and performed a packet… (read more)

There is a large delay between when I open Firefox, and when it finally loads my homepage (Bing.com). To help troubleshoot, I installed Wireshark, and performed a packet capture.

At timestamp 13.547047 seconds, it sends a query for detectportal.firefox.com. At this point we know the browser is open and functioning.

At timestamp 19.768820 it sends a query for www.bing.com. It's taken over 6 seconds, before firefox even tries to load my homepage.

What is it doing for those 6 seconds? How do I get it to load Bing at timestamp 13.547048?

Asked by Brian 21 hours ago

Missing min/max/close buttons

Hello. I don't know which Firefox release broke this essential feature. The problem started after I enabled Aero in my Windows 7 system. It happens often if I have an ope… (read more)

Hello. I don't know which Firefox release broke this essential feature. The problem started after I enabled Aero in my Windows 7 system. It happens often if I have an open tab with https://www.o2tv.cz/ which uses some DRM to play TV content.

Asked by pavel.lastovicka 4 days ago

Last reply by pavel.lastovicka 1 day ago

connecting to sites

upon enabling "do not connect to http" very, very, very often i got the attached error message when the site said it was https and it was very often reliable places like … (read more)

upon enabling "do not connect to http" very, very, very often i got the attached error message when the site said it was https and it was very often reliable places like my bank and TaxAct. It seemed like such a good idea but i quit out of frustration.

Asked by rboelte 1 day ago

Last reply by rboelte 1 day ago

XULRunner error

Dear Mozilla Community members, For a while now I get sort of an error message some time after Windows start (every time): "XULRunner Could not determine any profile runn… (read more)

Dear Mozilla Community members,

For a while now I get sort of an error message some time after Windows start (every time): "XULRunner Could not determine any profile running in backgroundtask mode!"

I managed to find out that XULRunner is connected to Mozilla but I haven't found any info about this particular message so far, therefore, I would appreciate your help solving this issue.

Thank you in advance.

Kind regards, Ewelina

Asked by Ewelina 3 days ago

Last reply by Ewelina 1 day ago

A recent update destroyed the restore session feature

A recent update had destroyed my firefox experience. Recently I've noticed that that this client no longer stores sessions. It will only store one session, the last sess… (read more)

A recent update had destroyed my firefox experience.

Recently I've noticed that that this client no longer stores sessions. It will only store one session, the last session, and any stored sessions that are still stored when the client crashes again becomes corrupt. I used to rely on sessions to save large amounts of tabs. However, my client just crashed due to a power outage, I was quickly skimming through my tabs in order to reduce cpu usage and weed some out... when the client suddenly crashed again before I could restore them. I lost them all.

All of a sudden I find myself without an incentive to keep using firefox. Why have you made your client worse? Everything I had was gone, and due to an accident. There is nothing loaded on my computer. And yet it crashed for no reason and everything is gone. If I had an older version of firefox, this would not have happened.

Can you please tell me what happened to your restore session feature and why its total garbage now? Please fix it. I really hate losing weeks worth of research. And no, looking in my history wont help. I have reviewed thousands if not tens of thousands of websites over the several weeks it took to accumulate that research. Finding it all again in my history is impossible. That's why I rely on tab storing services.

How about you make a restore session library tab that stores all your stored sessions securely. I am tired of this data constantly being deleted.

Asked by Ikelos 1 day ago

Browser freezes using Gmail and Youtube

Hello, Recently I was forced to install some "stuff" on my work laptop. Unfortunately, I am not quite sure what they installed. I have contacted my IT department and all … (read more)

Hello,

Recently I was forced to install some "stuff" on my work laptop. Unfortunately, I am not quite sure what they installed. I have contacted my IT department and all I've gotten in response is that "we haven't blocked any browser or sites."

Since this update, I find that Gmail will eventually show an error and when I go to refresh the page, the loading screen never completes. Additionally, Youtube will eventually declare that I have no connection and at that point I can no longer open new browser tabs.

I have updated Firefox, used troubleshooting mode, removed extensions, turned off ad blockers (uBlock Origin), and nothing seems to work—these issues always appear again eventually.

I would greatly prefer to not use Chrome, so if there is anything I can do to fix these issues I would be all ears to know what it is.

Thank you, John

Asked by johnvemery88 3 days ago

Last reply by johnvemery88 2 days ago

Wrong colors when uploading photo to Facebook (via FB wall)

Hi! I am not sure, if Mozilla is the reason, or Facebook is the reason. But since I can't get any help from FB, I'd like to check also here. At first, I thought that th… (read more)

Hi!

I am not sure, if Mozilla is the reason, or Facebook is the reason. But since I can't get any help from FB, I'd like to check also here.

At first, I thought that the problem is on my side, since I am using ICC profiles and maybe I did something wrong. But It is not the problem on my side. I tried with an original jpg file, directly from my camera.

So, when I upload JPG to the Facebook, color of the image changes. This happens only if I publish it directly to my FB wall. If I go to FB "publishing tools" (on FB pages), everything works normal. If I upload the same photo via for example Chrome or Vivaldi, everything works, even if I upload directly to the FB wall.

So the problem occurs only If I upload from Mozilla (I have latest version 100) to the FB wall. Not via "publishing tools" on FB page. But problem is the same if I publish on my FB business page wall. So I assume that the problem is on FB side, that somehow renders files differently then via their Publishing tools. But I am allowing that Mozilla does something to them via the interface.

There must be some problem with Mozilla too, since all images work OK with Chrome or Vivaldi. So, something in relation of Mozilla - Facebook wall.

Currently I just use Chrome for uploading to FB, but I don't want that.

Not sure what to do now. FB does not reply, maybe Mozilla can help or check? I attached a sample photos, to see difference. Here is my Mozilla gfx.color profile too: https://i.ibb.co/CWRHWnh/6.jpg

Asked by S. 1 week ago

Last reply by S. 3 days ago

PK not found (e1)

As of two to three days ago (ca 20/05/22) when navigating to a website (regardless of whether it has been previously visited or not) a message appears stating "PK not fou… (read more)

As of two to three days ago (ca 20/05/22) when navigating to a website (regardless of whether it has been previously visited or not) a message appears stating "PK not found (e1)". I have to click it in order to view the website. Sometimes the message also has a checkbox stating "Allow notifications like this from www.example.com to take you to their tab". I am using the latest FFox 100.0.2 and am fairly sure the problem started after the update before the last one (the last one was this morning 22/05/22).

Asked by bdweiler 5 days ago

Last reply by bdweiler 4 days ago

Firefox crashing every time I try to See all downloads

Seems like there's a bug in the new update. I can't see all the downloads, no matter how I try to open the list of downloads, the browser immediately crashes. I tried rei… (read more)

Seems like there's a bug in the new update. I can't see all the downloads, no matter how I try to open the list of downloads, the browser immediately crashes. I tried reinstalling (started a new profile, etc), the issue still persists.

Asked by elh.rotem 3 weeks ago

Last reply by elh.rotem 5 days ago

FireFox Suspended? and Update to v.100 problem

Over the past few days FireFox v. 99.0.1 had been non-responsive on a tab. Got to the point I had to close FF and tried to use cCleaner to clear cache/history etc. How… (read more)

Over the past few days FireFox v. 99.0.1 had been non-responsive on a tab.

Got to the point I had to close FF and tried to use cCleaner to clear cache/history etc.

However cCleaner could not proceed as it claimed FF was still open.

Using Windows Task Manager I found FireFox was "Suspended" (screenshot 1)

I then terminated the task - so cCleaner could proceed.

Then FF appeared to work OK. Until the next time....

It just happened a few minutes ago closing FF - using cCleaner - once again FF was "suspended" and had to be terminated in Task Manager.

On FF help it said Update to version 100 which I did BUT the update got stuck on the FF Update - for several minutes (definitely over 10 mins) so I had to terminate the FF Updater using Windows Task Manager (screenshots 2 & 3) again used Task Manager to terminate that.

FF appeared to open OK even showed the version 100 What's new tab.

BUT when I used FF help to check version I got Restart FF to update to version 100 (screen shot 4) Perhaps the last might temporary due to terminating the what appeared to be stuck Updater, but it was worth mentioning.

PC details: OS Name Microsoft Windows 10 Home Version 10.0.19044 Build 19044 System Model HP Pavilion 590-p0097c Desktop PC System Type x64-based PC Processor Intel(R) Core(TM) i5-8400 CPU @ 2.80GHz, 2808 Mhz, 6 Core(s), 6 Logical Processor(s) Installed Physical Memory (RAM) 8.00 GB

Any help appreciated.

Thanks,

Vincent

Asked by UnknownVT 3 weeks ago

Last reply by UnknownVT 6 days ago