X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get FF4 to use Google's I'm feeling lucky feature?

Posted

I first thought it was something in DNS, but yet this is not a problem in FF3.6.13

My web browsing workflow was as follows- Type name of website in address bar, hit enter, wait for mozilla.org homepage to load.

Now if I do the exact same thing in FF4b12, I get a google search results page instead of the mozilla.org homepage.

Why is that? And where in about:config can I go to fix that?

I have tried this on two different internet connections, my home ISP using the ISP provided DNS and at my workplace where we run an in-house DNS server.

I am on a Mac running Snow Leopard 10.6.6, I use AdblockPlus and FirefoxB persona.

See the google query differences below- FF4b10/11 used it and it works the same in FF3.6

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=mozilla

This is the query in FF4 b12- http://www.google.com/search?q=mozilla&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

Do you see the difference??

Chosen solution

Firefox 3.6.* uses Google's "Browse by name" search rather that "I'm feeling lucky" To set Firefox 4 to use the browse by name search you need to change a hidden preference.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL, double-click on it and change it to the link shown below

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

If you want it to use the I'm feeling lucky search, set it to this link:

http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=

Read this answer in context 314

Additional System Details

Installed Plug-ins

  • iPhoto6
  • Shockwave Flash 10.1 r102
  • Java Plug-In 2 for NPAPI Browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12

More Information

Application Basics
Name
Firefox
Version
4.0b12
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b12) Gecko/20100101 Firefox/4.0b12
Profile Directory
Show in Finder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Feedback
1.0.6
true
testpilot@labs.mozilla.com
Adblock Plus
1.3.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Modified Preferences
Name
Value
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.buildID
20110222205430
browser.startup.homepage_override.mstone
rv:2.0b12
browser.tabs.autoHide
true
browser.tabs.closeButtons
0
extensions.lastAppVersion
4.0b12
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
15
network.http.pipelining.ssl
true
network.http.proxy.pipelining
true
places.database.lastMaintenance
1299625528
places.history.enabled
false
places.history.expiration.transient_current_max_pages
124822
privacy.sanitize.migrateFx3Prefs
true
Graphics
Adapter Description
0x22600,0x24300,0x20400
Vendor ID
0000
Device ID
0000
Adapter RAM
Adapter Drivers
Driver Version
Driver Date
Direct2D Enabled
false
DirectWrite Enabled
false
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows
1/1 OpenGL

TonyE
  • Moderator
1041 solutions 8840 answers

Chosen Solution

Firefox 3.6.* uses Google's "Browse by name" search rather that "I'm feeling lucky" To set Firefox 4 to use the browse by name search you need to change a hidden preference.

  1. Type about:config into the location bar and press enter
  2. Accept the warning message that appears, you will be taken to a list of preferences
  3. Locate the preference keyword.URL, double-click on it and change it to the link shown below

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

If you want it to use the I'm feeling lucky search, set it to this link:

http://www.google.com/search?btnI=I%27m+Feeling+Lucky&ie=UTF-8&oe=UTF-8&q=

Question owner

You have saved my sanity! Thank you! Thank you! Tony!

I didn't know there was "Browse by name" I just thought it was "I'm feeling lucky" But thank you again!

=)

TonyE
  • Moderator
1041 solutions 8840 answers

You're welcome

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

See also:

M1ke 0 solutions 2 answers

Helpful Reply

That's really useful to know, but it seems a bit rubbish of Mozilla to just sideline a really useful feature like the Awesome Bar "Browse by Name" and expect people to start Googling and going through about:config to fix it. How about a drop down list in Options > Content to select regular Google search, Browse by name or I'm feeling lucky, at the very least?

kumar303 0 solutions 6 answers

It's a shame that the feeling lucky feature was disabled in Firefox 4. But there is an addon to put it back: https://addons.mozilla.org/en-US/firefox/addon/luckybar/

TonyE
  • Moderator
1041 solutions 8840 answers

Note that the Luckybar is not the same as what is in Firefox 3.6.*, that adds the Google "I feel lucky" search. The method used in Firefox 3.6.* is the Google "Browse by name". My above method adds that back, or you can use this add-on for the English US Google browse by name search - https://addons.mozilla.org/firefox/addon/browse-by-name

kumar303 0 solutions 6 answers

right, they are the same exact thing. In fact, the source of LuckyBar's main.js is nearly identical to that of the Browse By Name addon. The Lucky Bar adds Mozilla Firefox as the referrer though (which it is).

TonyE
  • Moderator
1041 solutions 8840 answers

The 2 add-ons do slightly different things.

The add-ons page for Lucky bar add-on states that it uses Google's "I feel lucky search". With that search it will always take you to the most likely match.

The Browse by name add-on uses Google's "Browse by name" search. With that search, if there is a clear match it takes you to that site, otherwise it will show you the Google search page with the result of the Google search.

Prior to Firefox 2, the location bar search used "I feel lucky" from Firefox 2 to Firefox 3.6 it used "Browse by name"

kumar303 0 solutions 6 answers

Oh, I see what you mean. I didn't even know they were different. The description of LuckyBar is incorrect then because in the source I noticed it is setting keyword.URL to the browse by name service URL. Most non-technical users don't know what browse by name is but they remember the Feeling Lucky button, I think.

VinJocenti 0 solutions 1 answers

Hello TonyE

The “Browse by name” Keyword.url works, but why on earth this isn’t standard anymore in Firefox 4?

But there is a problem every time I started Firefox again I can start over again, because the Keyword.Url is get to his default setting again with is: chrome://browser-region/locale/region.properties Can’t I save the new settings?

The message I get is the following Firefox kan het bestand op jar:file:///C:/Program Files/Mozilla Firefox/omni.jar!/chrome/nl/locale/browser-region/region.propertiesx niet vinden


Could this have got something to do with the new Panorama function?

cchristians 0 solutions 1 answers

Thank you, thank you, thank you!!!!

noitidart 0 solutions 7 answers

Thank you!!! I have been hating the stupid FF4+ not im feeling lucky style for a long time. IFFFF I want to run a search I'll use the search box at top!!!

Thanks!! Firefox should restore this to default.

firefoxforever 0 solutions 1 answers

I know that this is an old post. But the information up top is valid still. Firefox version 8 converted to using Bing in the awesome bar. I hate Bing. This info I want to comfirm still works, and I am a very happy user now and all is right with the world.