X
Tap here to go to the mobile version of the site.

Support Forum

How does one delete the search history that comes up when I type in the search box?

Posted

When I type in the search box it reveals my past search , how do I delete or stop same. I have deleted my browser history but this still shows.

When I type in the search box it reveals my past search , how do I delete or stop same. I have deleted my browser history but this still shows.

Modified by don544

Additional System Details

This happened

Every time Firefox opened

This started when...

always

Installed Plug-ins

  • Version 1.7.1.0
  • Google Talk Plugin Video Accelerator version:0.1.43.4
  • Winamp Application Detector
  • Google Update
  • Shockwave Flash 10.1 r102
  • GEPlugin
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 2.0.31005.0
  • Virtual Earth 3D 4.00090316005 plugin for Mozilla
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Next Generation Java Plug-in 1.6.0_16 for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

More Information

Buddahfan 1 solutions 23 answers

Go to Tool - Clear Recent History

For a more thorough cleaning install the Forms History Control addon.

Go to Tool - Clear Recent History For a more thorough cleaning install the Forms History Control addon.
cor-el
  • Top 10 Contributor
  • Moderator
13082 solutions 119745 answers

Helpful Reply

You can right-click the text area in the search bar to "Clear Search History"

You can also disable: Tools > Options > Privacy > History: [ ] "Remember search and form history"

See also:

You can right-click the text area in the search bar to "Clear Search History" You can also disable: Tools > Options > Privacy > History: [ ] "Remember search and form history" See also: * [[Clear Recent History]] * http://kb.mozillazine.org/Search_Bar

Question owner

I have deleted all history that I can find , the search window still shows recent search if I type a search in the box

I have deleted all history that I can find , the search window still shows recent search if I type a search in the box

Question owner

does not delete the search ,if I type in the window still brings up recent search

does not delete the search ,if I type in the window still brings up recent search

Question owner

cor-el 15346 posts 1006 answers are you a bot or what?

cor-el 15346 posts 1006 answers are you a bot or what?

Question owner

Do not in any way wish to sound a witch that sounds better with a b

Do not in any way wish to sound a witch that sounds better with a b
the-edmeister
  • Top 10 Contributor
  • Moderator
4161 solutions 31330 answers

cor-el 15346 posts 1006 answers are you a bot or what?

Nope he's a real live person and that 15346 posts & 1006 answers is just since June or July when this forum software was updated and the counter started from scratch.

cor-el 15346 posts 1006 answers are you a bot or what? Nope he's a real live person and that 15346 posts & 1006 answers is just since June or July when this forum software was updated and the counter started from scratch.
cor-el
  • Top 10 Contributor
  • Moderator
13082 solutions 119745 answers

Make sure that you do not get confused by Use popular search suggestions in the Firefox Search bar.

The "Search Suggestions" are not your search history.
The search suggestions are loaded in real time by querying the (Google) search engine site based on what you typed so far in the search bar.
If "Clear Search History" is grayed out then the history is cleared or disabled.

You can disable the search suggestions by right-clicking the text field in the search bar and remove the mark before "Show Suggestions".

Make sure that you do not get confused by [[Search suggestions]]. The "Search Suggestions" are not your search history.<br /> The search suggestions are loaded in real time by querying the (Google) search engine site based on what you typed so far in the search bar.<br /> If "Clear Search History" is grayed out then the history is cleared or disabled. You can disable the search suggestions by right-clicking the text field in the search bar and remove the mark before "Show Suggestions".
future_don9 0 solutions 1 answers

Helpful Reply

try this. when search suggestion comes up after you have started typing, hold the cursor arrow over the suggestion so it is highlighted and press the delete button.

try this. when search suggestion comes up after you have started typing, hold the cursor arrow over the suggestion so it is highlighted and press the delete button.