X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Mozilla Firefox start page redirects to ask.com

Posted

Instead of Google, I am getting about:home as the default start page, and it redirects to ask.com instead of to Google when doing a search. I think the search page was open yesterday when the computer shut down due to a transient power outage, and it was on Google. I could try restarting Firefox again, but it will probably take ten minutes to reload everything I have open with my slow connection.

Additional System Details

This happened

Just once or twice

This started when...

after a transient outage (I think)

Installed Plug-ins

  • Shockwave Flash 10.1 r102
  • GEPlugin
  • Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Google Updater pluginhttp://pack.google.com/
  • Panda ActiveScan 2.0 Plugin for Firefox
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

More Information

running in safe mode

trustnoone 0 solutions 3 answers

Helpful Reply

http://support.mozilla.com/en-US/questions/769519 try this? if it helps?

Missundaztood9 0 solutions 1 answers

http://www.mozilla.org/en-US/home/

http://www.google.com/firefox

http://www.google.co.uk/firefox

Just use either of these

Modified by Missundaztood9

folk7541854 0 solutions 1 answers

Helpful Reply

The above, unfortunately, didn't work for me. I still had the ask.com redirect in the search bar on the about:home page. The following DID work: I went to Help - Restart with Add-ons disabled. When restarting, I clicked on“Reset all user preferences to Firefox defaults” and “Restore default search engines”. Voila!!! I only lost the "persona" in Firefox. That was it. Google search bar is back alive.

elle_13n 0 solutions 1 answers

it didnt work for me):

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Do you have a problem with the search engine on the about:home page?

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  • Open the about:config page via the location bar
  • Type in the Filter bar: mstone
  • Right-click the browser.startup.homepage_override.mstone line and select: Reset
  • Close and restart Firefox

If that didn't help then delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

See also:

Modified by Noah_SUMO