X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

JDK 1.6.0_21 plugin ?

Posted

well....not working...from jdk-6u21-linux-i586.bin

libjavaplugin_oji.so conflicts with libnpjp2.so so I left links to libjavaplugin_oji.so into /usr/lib/iceweasel/plugins and put links to libnpjp2.so into /usr/lib/mozilla/plugins and /usr/lib/firefox/plugins....

this way iceweasel works as expected... but no way with FF4...

As I need to work with standard SE (and no sun-java nor openjdk) I think I will have to revert to FF 3.6...

Am I missing something ?

Modified by desmatt

Additional System Details

Installed Plug-ins

  • The next generation Java plug-in for Mozilla browsers.

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:2.0b4) Gecko/20100818 Firefox/4.0b4

More Information

Debian Squeeze x86 32bits , bindv6only.conf=0
Paramètres de base de l'application
Nom
Firefox
Version
4.0b4
Répertoire de profil
Ouvrir le dossier correspondant
Plugins activés
about:plugins
Java(TM) Plug-in 1.6.0_21
Fichier : libnpjp2.so
Configuration de compilation
about:buildconfig
Source
Built from http://hg.mozilla.org/mozilla-central/rev/9d6448b6a677
Build platform
target
i686-pc-linux-gnu
Build tools
Compiler Version Compiler flags
/tools/gcc-4.3.3/installed/bin/gcc gcc version 4.3.3 (GCC) -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -pedantic -Wno-long-long -gdwarf-2 -fno-strict-aliasing -pthread -pipe -DNDEBUG -DTRIMMED -gdwarf-2 -Os -freorder-blocks -fomit-frame-pointer
/tools/gcc-4.3.3/installed/bin/g++ gcc version 4.3.3 (GCC) -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -pedantic -Wno-long-long -gdwarf-2 -fno-strict-aliasing -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -gdwarf-2 -Os -freorder-blocks -fomit-frame-pointer
Configure arguments
--enable-application=browser --enable-optimize --enable-update-channel=beta --enable-update-packaging --disable-debug --enable-tests --enable-official-branding --enable-debug-symbols=-gdwarf-2
Extensions
Feedback
1.0.2
true
testpilot@labs.mozilla.com
Préférences modifiées
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:2.0b4
extensions.lastAppVersion
4.0b4
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
31644
privacy.sanitize.migrateFx3Prefs
true
Accélération graphique
Direct2D activé
false

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

You need to remove all links to libjavaplugin_oji.so

Firefox versions later than 3.6 only work with the Next Generation plugin (libnpjp2.so)

See http://java.sun.com/javase/6/webnotes/install/jre/manual-plugin-install-linux.html

Question owner

Thank you for answering.

I kept libnpjp2.so in these three directories mentionned above....

Now I get (only Java and Flash from Adobe enabled)

$ firefox --safe-mode Exception in thread "main" netscape.javascript.JSException: Plugin instance for applet ID 2 was already released at sun.plugin2.main.server.LiveConnectSupport.getInfo(Unknown Source) at sun.plugin2.main.server.LiveConnectSupport.shutdown(Unknown Source) at sun.plugin2.main.server.JVMInstance.unregisterApplet(Unknown Source) at sun.plugin2.main.server.JVMInstance.recycleAppletID(Unknown Source) at sun.plugin2.main.server.JVMManager.recycleAppletID(Unknown Source) at sun.plugin2.main.server.MozillaPlugin.stopApplet(Unknown Source) at sun.plugin2.main.server.MozillaPlugin.destroy(Unknown Source)

Is there another plugin running somewhere ?

I had to deinstall some java-common , odbcinst, unixodbc...and now iceweasel works fine again......but still not FF4...

i'm running metacity and gnome both 2.30 versions....may be the problem....

from the bash , for FF4 I get :

      1. !!! [Parent][RPCChannel] Error: Channel timeout: cannot send/recv

Exception in thread "Java Plug-In Pipe Worker Thread (Server-Side)" java.nio.BufferUnderflowException at java.nio.Buffer.nextGetIndex(Unknown Source) at java.nio.DirectByteBuffer.get(Unknown Source) at sun.plugin2.message.transport.NamedPipeTransport$SerializerImpl.readByte(Unknown Source) at sun.plugin2.message.AbstractSerializer.readInt(Unknown Source) at sun.plugin2.message.transport.SerializingTransport.read(Unknown Source) at sun.plugin2.message.Pipe$WorkerThread.run(Unknown Source) Exception in thread "main" netscape.javascript.JSException: Plugin instance for applet ID 1 was already released at sun.plugin2.main.server.LiveConnectSupport.getInfo(Unknown Source) at sun.plugin2.main.server.LiveConnectSupport.shutdown(Unknown Source) at sun.plugin2.main.server.JVMInstance.unregisterApplet(Unknown Source) at sun.plugin2.main.server.JVMInstance.recycleAppletID(Unknown Source) at sun.plugin2.main.server.JVMManager.recycleAppletID(Unknown Source) at sun.plugin2.main.server.MozillaPlugin.stopApplet(Unknown Source) at sun.plugin2.main.server.MozillaPlugin.destroy(Unknown Source) Exception in thread "Java Plug-In Pipe Worker Thread (Server-Side)" java.nio.BufferUnderflowException at java.nio.Buffer.nextGetIndex(Unknown Source) at java.nio.DirectByteBuffer.get(Unknown Source) at sun.plugin2.message.transport.NamedPipeTransport$SerializerImpl.readByte(Unknown Source) at sun.plugin2.message.AbstractSerializer.readInt(Unknown Source) at sun.plugin2.message.transport.SerializingTransport.read(Unknown Source) at sun.plugin2.message.Pipe$WorkerThread.run(Unknown Source)

Modified by desmatt

Question owner

still no way...I installed xulrunner-1.9.1 xulrunner-dev...copied the link to libnpjp2.so in /usr/lib/xulrunner, xulrunner-1.9.1, iceape, midbrowser, xulrunner-addons, xulrunner-devel-1.9.1....

iceweasel works fine but still not FF4....

still investigating...

tld 0 solutions 1 answers

Helpful Reply

I suddenly started getting errors like " Plugin instance for applet ID 1 was already released" in Firefox 3.6.11 under Gentoo with the sun 1.6.22 plugin. I was dead in the water. Manually clearing the Cache directory under my ~/.mozilla profile directory corrected it. I have no clue what it was caching (I even had cache disabled with the Web Developer addon at the time), but it was breaking java bigtime...WTF?

Tom

Question owner

I remember I had a workaround for this issue in these times (long ago now)....first installing the sun-java6 package from my distro prior to use the standard package from Oracle-Sun and build it with "fakeroot make-jpkg" to have it "distro-packaged-installed"...and almost everything was in place under /usr/lib/vm except renaming the JRE plugin directory from ns7 to ns4... ....if these "souvenirs" can help.....

higuita 0 solutions 3 answers

For me using java from a local network machine worked fine, so this gave me the hint that might be a proxy problem...

i manage to solve this by configuring the java proxy from "use browser settings" to use automatic configuration and my proxy.pac url. please note that the my proxy needs authentication and that i dont have direct web access without the proxy.

higuita 0 solutions 3 answers

I put back the "user browser settings" and its still working fine... maybe a corrupted parameter?

i also, previously, reinstalled from debian the xulrunner and iceweasel (but i'm running mozilla firefox 64bits binary from my home dir, not the debian package), so it might also have done something to fix this