X
Tap here to go to the mobile version of the site.

Support Forum

JS script not loaded in pref directory

Posted

Hi all

I have distributed a .js file via gpo to the default location: C:\Program Files (x86)\Mozilla Firefox\defaults\pref\

It seems like it is only loaded on the very first boot. Once I disable the setting on about:config, the js file will not load / apply once I restart firefox.

The file looks like this(enableroot.js):

/* Allows Firefox reading Windows certificates */ pref("security.enterprise_roots.enabled", true);

I searched this and wasn't able to find any solution. Does anyone have experience with it?

best regards,

Trennety

Hi all I have distributed a .js file via gpo to the default location: C:\Program Files (x86)\Mozilla Firefox\defaults\pref\ It seems like it is only loaded on the very first boot. Once I disable the setting on about:config, the js file will not load / apply once I restart firefox. The file looks like this(enableroot.js): /* Allows Firefox reading Windows certificates */ pref("security.enterprise_roots.enabled", true); I searched this and wasn't able to find any solution. Does anyone have experience with it? best regards, Trennety

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.110 Safari/537.36

More Information

Roland Tanglao
  • Administrator
72 solutions 785 answers

Hi trennety:

I can't answer your questions since I know nothing about using Firefox in an enterprise setting using GPO but I'm assuming it's in an enterprise setting.

So I changed the product to Firefox for Enterprise

Maybe the folks can help you there:

https://support.mozilla.org/en-US/questions/firefox-enterprise

  • If not maybe you ask on the Enterprise mailing list?

https://mail.mozilla.org/listinfo/enterprise (or it's already been answered in the archives)

Cheers!

...Roland

Hi trennety: I can't answer your questions since I know nothing about using Firefox in an enterprise setting using GPO but I'm assuming it's in an enterprise setting. So I changed the product to Firefox for Enterprise Maybe the folks can help you there: * maybe it's in the docs? : https://support.mozilla.org/en-US/products/firefox-enterprise * maybe it's answered in the enterprise support forum already? https://support.mozilla.org/en-US/questions/firefox-enterprise * If not maybe you ask on the Enterprise mailing list? https://mail.mozilla.org/listinfo/enterprise (or it's already been answered in the archives) Cheers! ...Roland
cor-el
  • Top 10 Contributor
  • Moderator
17589 solutions 159130 answers
There are other ways to make Firefox import certificates from the Windows certificate store. *https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig See Certificates: *https://github.com/mozilla/policy-templates/blob/master/README.md

Question owner

Roland Tanglao said

Hi trennety: I can't answer your questions since I know nothing about using Firefox in an enterprise setting using GPO but I'm assuming it's in an enterprise setting. So I changed the product to Firefox for Enterprise Maybe the folks can help you there: https://support.mozilla.org/en-US/questions/firefox-enterprise
  • If not maybe you ask on the Enterprise mailing list?
https://mail.mozilla.org/listinfo/enterprise (or it's already been answered in the archives) Cheers! ...Roland

Hi Roland,

The GPO only copies the .js file into the defaults/pref dirctory. That works perfectly fine and I am not setting anything within firefox via GPO.

The file is copied fine but when I change the security.enterprise_roots.enabled to false and then restart firefox, it seems like the .js file is not loaded.

So is there a setting which sets back the options or disabled the load of such specific .js files?

As far as I have seen the autoconfig uses the same mechanic. In my opinion the load of the .js files within default/pref should work but apparently most of the times they don't.

''Roland Tanglao [[#answer-1180414|said]]'' <blockquote> Hi trennety: I can't answer your questions since I know nothing about using Firefox in an enterprise setting using GPO but I'm assuming it's in an enterprise setting. So I changed the product to Firefox for Enterprise Maybe the folks can help you there: * maybe it's in the docs? : https://support.mozilla.org/en-US/products/firefox-enterprise * maybe it's answered in the enterprise support forum already? https://support.mozilla.org/en-US/questions/firefox-enterprise * If not maybe you ask on the Enterprise mailing list? https://mail.mozilla.org/listinfo/enterprise (or it's already been answered in the archives) Cheers! ...Roland </blockquote> Hi Roland, The GPO only copies the .js file into the defaults/pref dirctory. That works perfectly fine and I am not setting anything within firefox via GPO. The file is copied fine but when I change the security.enterprise_roots.enabled to false and then restart firefox, it seems like the .js file is not loaded. So is there a setting which sets back the options or disabled the load of such specific .js files? As far as I have seen the autoconfig uses the same mechanic. In my opinion the load of the .js files within default/pref should work but apparently most of the times they don't.

Question owner

Hi all

I've solved it on another way. Best was to implement the admx file via gpo and set the appropriate settings located under: computer configuration>policies>administrative templates>mozilla>firefox>certificates>use windows certificates

ADMX available under: https://github.com/mozilla/policy-templates/releases

In case anyone has the same problem.

Thanks again ;)

Bet regards,

Trennety

Hi all I've solved it on another way. Best was to implement the admx file via gpo and set the appropriate settings located under: computer configuration>policies>administrative templates>mozilla>firefox>certificates>use windows certificates ADMX available under: https://github.com/mozilla/policy-templates/releases In case anyone has the same problem. Thanks again ;) Bet regards, Trennety
Roland Tanglao
  • Administrator
72 solutions 785 answers

Hi Trennety

Glad you got it working! Thanks for documenting, I bet somebody else in the Firefox for Enterprise "world" :-) will benefit from your hard work.

Cheers and Happy Holidays!

...Roland

Hi Trennety Glad you got it working! Thanks for documenting, I bet somebody else in the Firefox for Enterprise "world" :-) will benefit from your hard work. Cheers and Happy Holidays! ...Roland