X
Tap here to go to the mobile version of the site.

Support Forum

Not receiving updates

Posted

Hi, I've got a ZTE Open C that I purchased from JB Hi-Fi in Australia (unlocked). I've been using the phone since December last year, and it's still on the stock version 1.0. Whenever I check for an update, it tells me my phone is up to date. I know it isn't. Why am I not getting updates? Cheers, Anthony

Hi, I've got a ZTE Open C that I purchased from JB Hi-Fi in Australia (unlocked). I've been using the phone since December last year, and it's still on the stock version 1.0. Whenever I check for an update, it tells me my phone is up to date. I know it isn't. Why am I not getting updates? Cheers, Anthony

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

eyome 0 solutions 31 answers

Helpful Reply

Which phone you have? Which firefoxos version? Is it a community build or an official one?

Which phone you have? Which firefoxos version? Is it a community build or an official one?

Helpful Reply

eyome said

Which phone you have? Which firefoxos version? Is it a community build or an official one?

It's a ZTE Open C. I made an error in my previous post; it's on version 1.3.0.0. Either way, it's not up to date. It's an official build, I'd presume. I bought it from a retail store.

''eyome [[#answer-749092|said]]'' <blockquote> Which phone you have? Which firefoxos version? Is it a community build or an official one? </blockquote> It's a ZTE Open C. I made an error in my previous post; it's on version 1.3.0.0. Either way, it's not up to date. It's an official build, I'd presume. I bought it from a retail store.
Ilphrin 1 solutions 16 answers

On the Open C you won't receive updates as ZTE is not working on update anymore on this phone. If you want more recent updates you may want to see http://builds.firefoxos.mozfr.org for instructions about it

On the Open C you won't receive updates as ZTE is not working on update anymore on this phone. If you want more recent updates you may want to see http://builds.firefoxos.mozfr.org for instructions about it
eyome 0 solutions 31 answers

As Ilphrin said, I strongly advise you to move to a community rom. 2.1 or even 2.2...

As Ilphrin said, I strongly advise you to move to a community rom. 2.1 or even 2.2...

Question owner

eyome said

As Ilphrin said, I strongly advise you to move to a community rom. 2.1 or even 2.2...

Ah, makes sense. Will it work, though? I once installed Android on this phone from a ROM and my 3G stopped working and I had to send it back to ZTE for them to reinstall FFOS. I'd be very annoyed if this happened again. Can someone guarantee if I installed 2.2, that my 3G would work on Optus Aus?

''eyome [[#answer-749350|said]]'' <blockquote> As Ilphrin said, I strongly advise you to move to a community rom. 2.1 or even 2.2... </blockquote> Ah, makes sense. Will it work, though? I once installed Android on this phone from a ROM and my 3G stopped working and I had to send it back to ZTE for them to reinstall FFOS. I'd be very annoyed if this happened again. Can someone guarantee if I installed 2.2, that my 3G would work on Optus Aus?

Question owner

Bump.

Bump.

Question owner

Very helpful (kidding).

Very helpful (kidding).

Question owner

It's concerning that, once I ask a question that requires some amount of thinking/actual knowledge, you people have nothing to reply with. Is this what happens to every problem that requires more than a reboot or update?

It's concerning that, once I ask a question that requires some amount of thinking/actual knowledge, you people have nothing to reply with. Is this what happens to every problem that requires more than a reboot or update?
pg23 1 solutions 26 answers

Please remember that most people replying here are just other users, sharing our experiences. I know of no reason why 2.2 would not work, but I have a different phone. Hopefully you can get in touch with someone with the same phone here or elsewhere.

Please remember that most people replying here are just other users, sharing our experiences. I know of no reason why 2.2 would not work, but I have a different phone. Hopefully you can get in touch with someone with the same phone here or elsewhere.
Andrew
  • Moderator
321 solutions 4037 answers

Installing Android on the device is out of the scope of this support forum. We don't provide support for that. If 3G is currently working on your Firefox OS device, we can't do anything more.

Installing Android on the device is out of the scope of this support forum. We don't provide support for that. If 3G is currently working on your Firefox OS device, we can't do anything more.